Unable to install winehq-devel packages

Questions about Wine on Linux
Post Reply
latte
Level 2
Level 2
Posts: 23
Joined: Sat Mar 10, 2018 2:16 pm

Unable to install winehq-devel packages

Post by latte » Mon Apr 08, 2019 7:41 am

I ran into a wine update issue with bionic and winehq-devel. The update process is broken for me.

What did I do then?
- Remove the existing wine packages and then run sudo apt-get autoremove

- wine version then still gives 3.6

- listing all remaining packages: sudo apt list --installed | grep -i wine

fonts-wine/bionic,bionic,now 3.0-1ubuntu1 all [Installiert,automatisch]
libwine-development/bionic,now 3.6-1 amd64 [Installiert,automatisch]
wine-development/bionic,bionic,now 3.6-1 all [Installiert,automatisch]
wine-mono0.0.8/now 0.0.8-0ubuntu1 all [Installiert,lokal]
wine32-development/bionic,now 3.6-1 i386 [Installiert,automatisch]
wine64-development/bionic,now 3.6-1 amd64 [Installiert,automatisch]
winetricks/bionic,bionic,now 0.0+20180217-1 all [installiert]

Also removing all these including the package with the odd name "wine-mono0.0.8"

Now wine is not found anymore.

If I then apply
sudo apt install --install-recommends winehq-devel

it reports a dependency of winehq-devel on wine-devel (= 4.5~bionic) and that problems cannot be corrected and there are withhold defect packages.

Equally wine-devel cannot be installed and so forth.

However, the stable branch installs fine:
sudo apt install --install-recommends winehq-stable

User avatar
dimesio
Moderator
Moderator
Posts: 12677
Joined: Tue Mar 25, 2008 10:30 pm

Re: Unable to install winehq-devel packages

Post by dimesio » Mon Apr 08, 2019 5:39 pm

You are probably running into the libfaudio0 dependency. You need to get it from the OBS repo before installing Wine. viewtopic.php?f=8&t=32192

Post Reply