Dependencies Mismatched

Questions about Wine on Linux
Post Reply
tchagas
Level 1
Level 1
Posts: 5
Joined: Sat Apr 06, 2019 9:41 pm

Dependencies Mismatched

Post by tchagas » Sat Apr 06, 2019 9:52 pm

I'm trying to install Wine but to no avail. following the step by step of the own site and I can not ...

Code: Select all

sudo apt install --install-recommends winehq-stable
Reading package lists ... Ready
Building dependency tree
Reading status information ... Ready
Some packages could not be installed. This may mean that
you asked for an impossible situation or, if you are using the
unstable distribution, that some required packages were not
created yet or were taken from the "Incoming".
The following information may help resolve the situation:

The following packages have mismatched dependencies:
 winehq-stable: Depends: wine-stable (= 4.0 ~ stretch)
Debian 9

User avatar
dimesio
Moderator
Moderator
Posts: 12671
Joined: Tue Mar 25, 2008 10:30 pm

Re: Dependencies Mismatched

Post by dimesio » Sun Apr 07, 2019 5:59 am

The way to solve dependency issues is to work your way backwards. Try installing wine-stable, see what apt complains about, and try installing that. Repeat until you have everything installed.

tchagas
Level 1
Level 1
Posts: 5
Joined: Sat Apr 06, 2019 9:41 pm

Re: Dependencies Mismatched

Post by tchagas » Sun Apr 07, 2019 7:18 pm

dimesio wrote:The way to solve dependency issues is to work your way backwards. Try installing wine-stable, see what apt complains about, and try installing that. Repeat until you have everything installed.

Code: Select all

apt install wine-stable
Reading package lists ... Ready
Building dependency tree
Reading status information ... Ready
Some packages could not be installed. This may mean that
you asked for a dangerous situation, are you using a
Unstable distribution, not required
ticket or ticket.
The following information can help resolve the situation:

Packages follow the mismatched dependencies:
stable in wine: Depends: wine-stable-i386 (= 4.0 ~ stretch)


apt install wine-stable-i386
Reading package lists ... Ready
Building dependency tree
Reading status information ... Ready
Some packages could not be installed. This may mean that
you asked for an impossible situation or, if you are using the
unstable distribution, that some required packages were not
created yet or were taken from the "Incoming".
The following information may help resolve the situation:

The following packages have mismatched dependencies:
 wine-stable-i386: i386: Depends: libglib2.0-0: i386 (> = 2.12.0) but will not install
                         Depends: libgphoto2-6: i386 (> = 2.5.10) but will not install
                         Depends: libgstreamer-plugins-base1.0-0: i386 (> = 1.0.0) but will not install
                         Depends: libgstreamer1.0-0: i386 (> = 1.4.0) but will not install
                         Depends: libpulse0: i386 (> = 0.99.1) but will not install
                         Depends: libasound2-plugins: i386 but will not install
                         Recommended: libcups2: i386 but will not install
                         Recommended: libdbus-1-3: i386 but will not install
                         Recommended: libsane: i386 but will not install or
                                    libsane1: i386 but is not installable
                         Recommended: libsdl2-2.0-0: i386 but will not install

User avatar
dimesio
Moderator
Moderator
Posts: 12671
Joined: Tue Mar 25, 2008 10:30 pm

Re: Dependencies Mismatched

Post by dimesio » Sun Apr 07, 2019 7:49 pm

Install all those i386 packages one by one. Keep in mind that the versions of i386 packages must match the versions of the matching amd64 package or apt will refuse to install it.

tchagas
Level 1
Level 1
Posts: 5
Joined: Sat Apr 06, 2019 9:41 pm

Re: Dependencies Mismatched

Post by tchagas » Sun Apr 07, 2019 8:03 pm

Code: Select all

apt install wine
Reading package lists ... Ready
Building dependency tree
Reading status information ... Ready
The following additional packages will be installed:
  fonts-wine libodbc1 libosmesa6 libwine wine64
Suggested packages:
  libmyodbc odbc-postgresql tdsodbc unixodbc-bin ttf-mscorefonts-installer winbind winetricks playonlinux wine-binfmt dosbox wine64-preloader
Recommended Packages:
  wine32
The following packages will be REMOVED:
  virtualbox-6.0
The following new packages will be installed:
  fonts-wine libodbc1 libosmesa6 libwine wine wine64
0 packages upgraded, 6 new packages installed, 1 to be removed and 0 not upgraded.
You need to download 20.3 MB of files.
After this operation, 104 MB of disk space will be released.
Uninstalls my virtual box and installs an old version of wine

User avatar
dimesio
Moderator
Moderator
Posts: 12671
Joined: Tue Mar 25, 2008 10:30 pm

Re: Dependencies Mismatched

Post by dimesio » Mon Apr 08, 2019 5:42 am

tchagas wrote:

Code: Select all

apt install wine
That is not the command to install any of the WineHQ packages. Ask for help with any problems from whoever created the Wine package you are trying to install.

tchagas
Level 1
Level 1
Posts: 5
Joined: Sat Apr 06, 2019 9:41 pm

Re: Dependencies Mismatched

Post by tchagas » Mon Apr 08, 2019 9:51 am

I know the package is not that one, just wanted to inform that I can install it in the way I mentioned.

jkfloris
Level 6
Level 6
Posts: 654
Joined: Thu Aug 14, 2014 10:10 am

Re: Dependencies Mismatched

Post by jkfloris » Tue Apr 09, 2019 5:04 am

The following packages will be REMOVED:
virtualbox-6.0
This isn't a package from the official Debian repo.
Which repo's do you use?

tchagas
Level 1
Level 1
Posts: 5
Joined: Sat Apr 06, 2019 9:41 pm

Re: Dependencies Mismatched

Post by tchagas » Tue Apr 09, 2019 9:31 pm

jkfloris wrote:
The following packages will be REMOVED:
virtualbox-6.0
This isn't a package from the official Debian repo.
Which repo's do you use?
I searched the debian repository myself

Code: Select all

apt search virtualbox 

virtualbox-6.0/now 6.0.4-128413~Debian~stretch amd64 [installed,local]  Oracle VM VirtualBox

apt install virtualbox-6.0

jkfloris
Level 6
Level 6
Posts: 654
Joined: Thu Aug 14, 2014 10:10 am

Re: Dependencies Mismatched

Post by jkfloris » Wed Apr 10, 2019 3:49 am

Are there any other local packages?

Code: Select all

apt list --installed | grep "installed,local"
By the way, did you enable i386?

Code: Select all

sudo dpkg --add-architecture i386

Post Reply