Wine 4.3 Staging broke some games..

Questions about Wine on Linux
Post Reply
joshagosh
Newbie
Newbie
Posts: 2
Joined: Thu Mar 07, 2019 2:13 pm

Wine 4.3 Staging broke some games..

Post by joshagosh » Thu Mar 07, 2019 2:20 pm

Hey guys I recently updated to Staging 4.3, now World of Warcraft 3.3.5 and Warcraft 3 do not work. Warcraft 3 just loads a black screen with or without OpenGL flags but you can hear the audio, then 3.3.5 opens and displays correctly, but I get no cursor without the -opengl flag. I prefer to not use OpenGL on these games because I can't alt+f4 out of them if I do. I'm running the current stable version of KDE Neon. Thank you in advance. :)

User avatar
dimesio
Moderator
Moderator
Posts: 12684
Joined: Tue Mar 25, 2008 10:30 pm

Re: Wine 4.3 Staging broke some games..

Post by dimesio » Thu Mar 07, 2019 3:29 pm


joshagosh
Newbie
Newbie
Posts: 2
Joined: Thu Mar 07, 2019 2:13 pm

Re: Wine 4.3 Staging broke some games..

Post by joshagosh » Thu Mar 07, 2019 7:25 pm

Extremely similar to my issue. I can play World of Warcraft in opengl mode no problem, but sometimes my girlfriend and I like playing the original DotA on a LAN and we can't exactly do that at the moment unless I want to install Windows back on my laptop, which would be pointless just for one game. I'll definitely follow this bug report.

aslo
Newbie
Newbie
Posts: 4
Joined: Thu Aug 16, 2018 1:08 pm

Re: Wine 4.3 Staging broke some games..

Post by aslo » Tue Mar 19, 2019 3:43 am

Had same issue with 4.3, but it's now fixed with 4.4.

Post Reply