Can't open a file with Umlauts

Questions about Wine on Linux
Post Reply
meyer
Level 2
Level 2
Posts: 16
Joined: Sat Jul 15, 2017 2:38 am

Can't open a file with Umlauts

Post by meyer » Wed Feb 20, 2019 11:31 am

Hi,

i use the Program AvsPmod to open AviSynth-Scripts unter Ubuntu 18.04 with wine-development 3.6.1. This works without Problems, except there are Umlauts in the file name. Then i have an empty file like when AvsPmod is started without an input file. This is the Command i use to start the program:

Code: Select all

env WINEPREFIX=/home/ich/.wine wine "/home/user/.wine/drive_c/Program Files/AvsPmod/AvsPmod.exe" "example with ö.avs"
This doesn't make problems in other Windows applications such as VirtualDub. I tried the old AvsPmod 2.5.1 and also the new 2.6, the same with both versions. The problem is the file name of the AVS script, not the name that are loaded within the script. There is no error when i start the command in terminal. When i use winedebug (https://wiki.winehq.org/Debug_Channels) i have tons of messages. Is there a debug mod with less messages?

EDIT
When i open AvsPmod normally and open the file within the menu of the application, there is no problem.

lahmbi5678
Level 7
Level 7
Posts: 823
Joined: Thu Aug 27, 2009 6:23 am

Re: Can't open a file with Umlauts

Post by lahmbi5678 » Fri Mar 01, 2019 10:21 am

Maybe you are using a different locale in terminal than in your desktop environment. Also if you create a file under windows and try to access it in linux, it very probably will use a different codepage than linux. This stuff can be a real pain. It would be easier to just avoid the "ö".

You could try to put a
LC_ALL="c"
(kind of setting everything to neutral, ASCII) or e.g.
LANG=de_DE.UTF-8
in front of the wine command, assuming that want to have a german locale, UTF8, and that the locale is already installed in your linux system.

Post Reply