is OpenCL support limited to OpenCL 1.0 version ?

Questions about Wine on Linux
Post Reply
amruthsu
Newbie
Newbie
Posts: 2
Joined: Sun Jan 13, 2019 1:51 am

is OpenCL support limited to OpenCL 1.0 version ?

Post by amruthsu » Sun Jan 13, 2019 3:23 am

is OpenCL support limited to OpenCL 1.0 version ?
wine-staging-opencl-1.2-fails.png
wine clinfo_x64.exe SS
I am not able to use daz studio d-force features which requires opencl 1.2 at least.

Code: Select all

wine clinfo_x64.exe

complete terminal output attached.
wine-clinfo-opencl-versions.tar.xz
wine clinfo_x64.exe logs
(1.8 KiB) Downloaded 42 times
My System: Debian 9.6 Stretch, Nvidia Driver Stable 384.130, wine-staging latest [4.0 rc5]

My Question:
1. is wine-staging support is limited to OpenCL 1.0 ?
am i missing something , how to get opencl maximum version on wine-staging ?

2. also wine clinfo_x86.exe (32bit) not able to see opencl devices.
how to get opencl 32 bit support also ?
dpkg --add-architecture i386; apt update; all done, not that issue.

User avatar
DarkShadow44
Level 7
Level 7
Posts: 943
Joined: Tue Nov 22, 2016 5:39 pm

Re: is OpenCL support limited to OpenCL 1.0 version ?

Post by DarkShadow44 » Sun Jan 13, 2019 9:42 am

Seems like wine only supports opencl1.0, it's not a staging issue though.
The 32bit issue sounds like a driver issue, at least it happens with native 32bit clinfo too.

amruthsu
Newbie
Newbie
Posts: 2
Joined: Sun Jan 13, 2019 1:51 am

Re: is OpenCL support limited to OpenCL 1.0 version ?

Post by amruthsu » Wed Feb 20, 2019 4:18 am

I asked winehq to add support for opencl 1.2 version through bugzilla.
work in progress.

click here to track current status of the winehq opencl 1.2 version availability

Post Reply