WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 20 posts ] 



 
Author Message
 Post Posted: Fri Feb 15, 2019 3:05 pm 
Offline
Level 1
Level 1

Joined: Fri Feb 15, 2019 2:41 pm
Posts: 8
Hi all.

First of all, I want to indicate that I have looked in the forum for help and I have not come up with any solution that is "correct for me".

Installing wine with the found here I get this output:

sudo apt install --install-recommends winehq-devel

The following packages have unmet dependencies:
 winehq-devel: Depends: wine-devel (= 4.1 ~ bionic)
E: Unable to correct problems, you have held broken packages.

Then I tried to install the dependencies backwards until I have arrived at a dependency that seems to "want to reinstall the whole system". It's a joke, but the number of uninstalled packages is not normal ...

This has happened to me with this dependence:


-------------------------------------
Code:
winehq-devel: It depends: wine-devel (= 4.1 ~ bionic)
-------------------------------------
Code:
wine-devel: It depends: wine-devel-i386 (= 4.1 ~ bionic)
-------------------------------------
Code:
wine-devel-i386: i386: It depends: libgphoto2-6: i386 (> = 2.5.10) but it will not be installed
                        Recommend: libfontconfig1: i386 but it will not be installed
                        Recommend: libfreetype6: i386 but it will not be installed
                        Recommend: libpng16-16: i386 but it will not be installed or
                                    libpng12-0: i386 but it is not installable
                        Recommend: libsane: i386 or
                                    libsane1: i386 but will not install
                        Recommend: libtiff5: i386 but it will not be installed

------------------------------------
Code:
libgd3: i386
It depends: libfontconfig1: i386 (> = 2.12) but it will not be installed
               It depends: libfreetype6: i386 (> = 2.2.1) but it will not be installed
               It depends: libpng16-16: i386 (> = 1.6.2-1) but it will not be installed
               It depends: libtiff5: i386 (> = 4.0.3) but it will not be installed

-------------------------------------
Code:
libfontconfig1: i386: It depends: libfreetype6: i386 (> = 2.2.1) but it will not be installed
-------------------------------------
Code:
libfreetype6: i386: It depends: libpng16-16: i386 (> = 1.6.2-1) but it will not be installed

-------------------------------------

And right here, with
Quote:
libpng16-16:i386
is where it appears that 714 packages will be deleted and only 5 will be installed. This isn't normal.

Code:
uname -a
:
Linux 4.15.0-45-generic # 48-Ubuntu SMP Tue Jan 29 16:28:13 UTC 2019 x86_64 x86_64 x86_64 GNU / Linux



Revised posts:
viewtopic.php?f=8&t=31949
viewtopic.php?f=8&t=31807#p120342
viewtopic.php?f=8&t=31950

Any help is welcome.
Regards!


Top 
 Post Posted: Fri Feb 15, 2019 6:15 pm 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12490
ciltocruz wrote:
And right here, with
Quote:
libpng16-16:i386
is where it appears that 714 packages will be deleted and only 5 will be installed. This isn't normal.

This problem can occur when you have installed packages from third party PPAs that are not multiarch ready. You need to replace the non-multiarch-ready packages with the standard Ubuntu ones. https://bugs.winehq.org/show_bug.cgi?id=43080


Top 
 Post Posted: Sun Feb 17, 2019 2:40 pm 
Offline
Level 1
Level 1

Joined: Fri Feb 15, 2019 2:41 pm
Posts: 8
But... do I have to uninstall the 714 packages and reinstall them to be from the official ubuntu repositories? A lot of work ... I'll be without Wine until I get the next Factory Reset.


Top 
 Post Posted: Sun Feb 17, 2019 4:51 pm 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12490
ciltocruz wrote:
But... do I have to uninstall the 714 packages and reinstall them to be from the official ubuntu repositories? A lot of work ... I'll be without Wine until I get the next Factory Reset.

No. You need to figure out which package(s) installed on your system are not multiarch-ready, and replace them with ones that are. From what you've posted, I'd start by looking at libpng16.


Top 
 Post Posted: Mon Feb 18, 2019 1:44 am 
Offline
Level 1
Level 1

Joined: Fri Feb 15, 2019 2:41 pm
Posts: 8
dimesio wrote:
ciltocruz wrote:
But... do I have to uninstall the 714 packages and reinstall them to be from the official ubuntu repositories? A lot of work ... I'll be without Wine until I get the next Factory Reset.

No. You need to figure out which package(s) installed on your system are not multiarch-ready, and replace them with ones that are. From what you've posted, I'd start by looking at libpng16.



Okay. I have detected that this package seems to be "in conflict".

What steps should I do, uninstall the version without "i-386" and install the "i-386" version?

This package is a library ...

What happens if, removing the library, a lot of programs are uninstalled? Then I must reinstall them one by one?

Regards!!


Top 
 Post Posted: Mon Feb 18, 2019 8:57 am 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12490
You need both the 32 and 64 bit packages, both need to be the same version of the library, and both should be from the main Ubuntu repository. As to how to do that without apt wanting to uninstall programs, ask on the Ubuntu forum. I don't use Ubuntu so my knowledge of apt is pretty limited.


Top 
 Post Posted: Mon Feb 18, 2019 2:03 pm 
Offline
Level 5
Level 5

Joined: Thu Aug 14, 2014 10:10 am
Posts: 355
You can replace a package if you use a version number.

First find the right multiarch version you want to install.
The version number must be the same for both packages.
Code:
apt policy libpng16-16 libpng16-16:i386


Install the version with:
Code:
sudo apt install libpng16-16=<number> libpng16-16:i386=<number>


Top 
 Post Posted: Thu Feb 21, 2019 2:00 am 
Offline
Level 1
Level 1

Joined: Fri Feb 15, 2019 2:41 pm
Posts: 8
The problem remains the same. When I try to install one of those "i386" libraries, the system offers to uninstall more than 500 packages.

This is what the companion commented above. https://bugs.winehq.org/show_bug.cgi?id=43080

I really do not see a "quick" solution. I must go 1 to 1 looking at the i-386 packages and choosing the versions that suit them best.

And I've even tried installing an earlier version of Wine (3) and it does not work either.


Top 
 Post Posted: Thu Feb 21, 2019 7:53 am 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12490
Did you enable 32 bit architecture on your system as the instructions specify?


Top 
 Post Posted: Fri Feb 22, 2019 3:34 pm 
Offline
Level 1
Level 1

Joined: Fri Feb 15, 2019 2:41 pm
Posts: 8
Yes, I did it.


Top 
 Post Posted: Fri Feb 22, 2019 8:02 pm 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12490
You have to figure out which package(s) are not multiarch ready and replace them with ones that are. Do you really have so many packages installed from third party PPAs that you can't identify which ones are the problem?


Top 
 Post Posted: Sat Feb 23, 2019 3:54 am 
Offline
Level 1
Level 1

Joined: Fri Feb 15, 2019 2:41 pm
Posts: 8
Today, I have a travel.
Tomorrow I will see these packages and I will tell you my ppa's.

Thanks.


Top 
 Post Posted: Wed Feb 27, 2019 2:40 pm 
Offline
Level 1
Level 1

Joined: Fri Feb 15, 2019 2:41 pm
Posts: 8
I tried to install Ubuntu 18.10 by update. (all ppa disabled).

I have not been able to install wine without ppa's and the problem persists. Something wrong or some packages are wrong in my system.

Maybe the best thing is to format ... I do not see another solution.


Top 
 Post Posted: Thu Feb 28, 2019 4:41 am 
Offline
Level 5
Level 5

Joined: Thu Aug 14, 2014 10:10 am
Posts: 355
Quote:
I tried to install Ubuntu 18.10 by update

Was the update successful? If it was successful you also have to change the WineHQ repo from bionic to cosmic.

Quote:
Maybe the best thing is to format ... I do not see another solution.

You don't have to format your harddrive, but the decision is up to you.
There are tools available to find which packages are the culprit
Code:
sudo apt install apt-show-versions
apt-show-versions | grep "No available version"

Probably this will output a list with packages. These packages aren't part of Ubuntu, so they are save to remove.

An other option is to try aptitude
Code:
sudo aptitude install --with-recommends winehq-devel

Carefully read the output. Or post the terminal output.


Top 
 Post Posted: Thu Feb 28, 2019 8:17 am 
Offline
Level 4
Level 4

Joined: Fri Dec 01, 2017 5:26 pm
Posts: 121
winehq-devel does NOT depend on wine-devel.

But, you might have ubuntu repo's wine-devel installed, and that creates a conflict, cos you cant install wine-devel, and THEN add WineHQ PPA, and "upgrade" to winehq-devel afaik. You have to first uninstall wine-devel.

Code:
dpkg -l|grep -i wine

Ofc uninstalling packages here can risk uninstalling a lot of dependencies. I am at work atm, so cant really remember the exact commands used, but i would start by following something like this https://itsfoss.com/how-to-remove-or-delete-ppas-quick-tip/, and see if you can remove the winehq ppa without removing too much and see if some packages gets "released", and THEN you can uninstall whatever ubuntu version of wine-devel.

Once THAT is done, you add winehq ppa, and you should be able to install from winehq. It is cos of conflicts between ubuntu version of wine and winehq version of wine.

PS. Do not immediately press YES on anything popping up without using some sense.. cos suddenly you remove X11 and loads of shit and ends up with a non-usable system...


Top 
 Post Posted: Thu Feb 28, 2019 9:36 pm 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12490
Cybermax wrote:
winehq-devel does NOT depend on wine-devel..

Yes, it does. The winehq-devel packages do nothing but pull in the wine-devel, wine-devel-amd64 and wine-devel-i386 packages and install symlinks to make it the default wine version on the system. The winehq-stable and winehq-staging packages behave similarly.


Top 
 Post Posted: Fri Mar 01, 2019 12:06 pm 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2452
Location: Cambridge
Cybermax wrote:
...
But, you might have ubuntu repo's wine-devel installed, and that creates a conflict, cos you cant install wine-devel, and THEN add WineHQ PPA, and "upgrade" to winehq-devel afaik. You have to first uninstall wine-devel.
...


You seem to be confused.
Canonical do not supply a package called wine-devel.
This is specific to the WineHQ Ubuntu Wine packaging setup.

For reference: Ubuntu - Packages - Package Search "wine"

Bob


Top 
 Post Posted: Fri Mar 01, 2019 4:04 pm 
Offline
Level 4
Level 4

Joined: Fri Dec 01, 2017 5:26 pm
Posts: 121
Bob Wya wrote:
Cybermax wrote:
...
But, you might have ubuntu repo's wine-devel installed, and that creates a conflict, cos you cant install wine-devel, and THEN add WineHQ PPA, and "upgrade" to winehq-devel afaik. You have to first uninstall wine-devel.
...


You seem to be confused.
Canonical do not supply a package called wine-devel.
This is specific to the WineHQ Ubuntu Wine packaging setup.

For reference: Ubuntu - Packages - Package Search "wine"

Bob

Right you are.
I was probably thinking about just "wine" that is in Ubuntu package repo's. Sorry.

Best bet would still be to clear out the PPA, and re-add it imo.


Top 
 Post Posted: Sun Mar 10, 2019 9:37 am 
Offline
Level 1
Level 1

Joined: Fri Feb 15, 2019 2:41 pm
Posts: 8
I have removed all the PPAs and the update to ubuntu 18.10 was successful. Now it is another package that conflicts with both the canonical version and the PPA version.

I must have something that causes very bad dependencies but I can not find it ...


Top 
 Post Posted: Sun Mar 10, 2019 10:47 am 
Offline
Level 4
Level 4

Joined: Fri Dec 01, 2017 5:26 pm
Posts: 121
Well.. i dont have "another package" installed, so hard to troubleshoot that.......

Joking aside, its troublesome to troubleshoot at times, but you can check things like "aptitude" that have SOME explanations when it comes to conflicts, and suggestion what to do. However, do not just pop "Apply" without knowing what you do, cos whamola, your whole system is reduced to a pulp before your eyes :) Use it to gain clues to dependencies and stuff.

Another useful tool is apt-cache. You can use apt-cache to get repo info for instance
Code:
apt-cache madison winehq-devel

You may also "force" a older version of a package to get in line with Ubuntu repo's so that upgrades will work again.

Eg. If you have "another_package 2.0" installed, and the latest available at Ubuntu repo is 1.9, you can downgrade this with:
Code:
sudo apt install another_package=1.9

This can sometimes untagle breakage, in the case that "another_package 2.0" depends on something not available, while "another_package 1.9" have requirements in order.


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 20 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: No registered users and 12 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: