Mouse lag/stuck

Questions about Wine on Linux
Post Reply
BenjaC79
Newbie
Newbie
Posts: 2
Joined: Mon Feb 04, 2019 7:40 pm

Mouse lag/stuck

Post by BenjaC79 » Mon Feb 04, 2019 8:13 pm

Hello,

I get this issue with some games I have installed since last 4.0 upgrade, specifically Fallout (1) and Fallout New Vegas. Both with good ratings on AppDB. The issue is the mouse cursor getting slow/laggy, moving at uneven speed, sometimes stuck on the edges of the screen. Other than that these games seem to run just fine with no noticeable graphic lag.

I have tried different prefixes, 32 and 64bit archs, different winecfg configs, with and without bumblebee, with no success. Now I remember these games running fine not so long ago on this same computer.

I use debian stretch, wine-stable 4.0, multiarch.

Any help would be appreciated.

BenjaC79
Newbie
Newbie
Posts: 2
Joined: Mon Feb 04, 2019 7:40 pm

Re: Mouse lag/stuck

Post by BenjaC79 » Tue Feb 05, 2019 12:15 pm

Replying to my own post as I did further digging and testing.

With no results :
- Disabling/Enabling "Automatically capture the mouse in full-screen windows", "Allow the window manager to control/decorate the windows" in winecfg.
- Tried with the steam version (I used gog version previously) and the issue is the same (with steam beta, using Proton 3.16-6 Beta).

Then found a workaround in a post related to skyrim. For Fallout New Vegas setting "bBackground Mouse=1" in fallout.ini seems to prevent the issue. The gog version (already patched for high resolution) of Fallout 1 can be used with an alternative mouse input control that also does the trick: "ALT_MOUSE_INPUT=1" in f1_res.ini.

I'm still wandering as I remember not having these issues something like 6 months ago.
Hope this helps, sorry for the bad language.

ValterPravnik
Newbie
Newbie
Posts: 2
Joined: Sat Mar 23, 2019 7:55 am

Re: Mouse lag/stuck

Post by ValterPravnik » Sat Mar 23, 2019 8:07 am

I experienced the same thing with GTA San Andreas after upgrading to winehq 4.0 on Ubuntu 18.04.
Whenever I move the mouse there are severe lags/freezes for up to 3 seconds.

I also tried toggeling "Automatically capture the mouse in full-screen windows" on and off but this makes it only worse since then my keyboard stops working.

I decided rolling back to winehq 3.0.5 but i have no clue how to install it. Althoug I added the repository and the command

Code: Select all

apt-cache policy winehq-stable
shows me winehq stable version 3.0.5 I cant install it. But I can install winehq stable 4.0.

Really anoying

ValterPravnik
Newbie
Newbie
Posts: 2
Joined: Sat Mar 23, 2019 7:55 am

Re: Mouse lag/stuck

Post by ValterPravnik » Sat Mar 23, 2019 8:12 am

I experienced the very same think since upgrading to 4.0. I'm running Ubuntu 18.04 and Intel HD graphics 3000

In GTA San Andreas the game freezes for up to 3 seconds when I move the mouse. Prior to 4.0 everything worked fine.
Toggeling "Automatically capture the mouse in full-screen windows" also didn't solve it but made it worse since my keyboard stopped working.

I think in this reddit thread they are discussing the same problem:

https://www.reddit.com/r/wine_gaming/co ... ain_games/

jkfloris
Level 6
Level 6
Posts: 704
Joined: Thu Aug 14, 2014 10:10 am

Re: Mouse lag/stuck

Post by jkfloris » Sun Mar 24, 2019 10:45 am

apt-cache policy winehq-stable
shows me winehq stable version 3.0.5 I cant install it. But I can install winehq stable 4.0.
You should be able to install an older version with:

Code: Select all

(replace "something" with the Ubuntu package name.)
sudo apt install winehq-stable=3.0.5~something wine-stable=3.0.5~something wine-stable-amd64=3.0.5~something wine-stable-i386=3.0.5~something

JacobTheHeartless
Newbie
Newbie
Posts: 4
Joined: Tue Apr 09, 2019 11:42 am

Re: Mouse lag/stuck

Post by JacobTheHeartless » Sun Sep 01, 2019 2:07 am

Set bBackground Mouse=1 in oblivion.ini Helps with mouse lag in Oblivion. Thank you BenjaC79 ! Looks like issue is related to Bethesda's engine

Gregmus
Newbie
Newbie
Posts: 1
Joined: Fri Nov 22, 2019 4:28 am

Re: Mouse lag/stuck

Post by Gregmus » Fri Nov 22, 2019 4:29 am

BenjaC79 wrote:
Tue Feb 05, 2019 12:15 pm
Replying to my own post as I did further digging and testing.

With no results :
- Disabling/Enabling "Automatically capture the mouse in full-screen windows", "Allow the window manager to control/decorate the windows" in winecfg.
- Tried with the steam version (I used gog version previously) and the issue is the same (with steam beta, using Proton 3.16-6 Beta).

Then found a workaround in a post related to skyrim. For Fallout New Vegas setting "bBackground Mouse=1" in fallout.ini seems to prevent the issue. The gog version (already patched for high resolution) of Fallout 1 can be used with an alternative mouse input control that also does the trick: "ALT_MOUSE_INPUT=1" in f1_res.ini.

I'm still wandering as I remember not having these issues something like 6 months ago.
Hope this helps, sorry for the bad language.
Thank you so much. ALT_MOUSE_INPUT helped me with fallout2 in file f2_res.ini.

Post Reply