WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 2 posts ] 



 
Author Message
 Post Posted: Sun Jan 13, 2019 3:57 am 
Offline
Level 2
Level 2

Joined: Wed Jul 05, 2017 2:29 am
Posts: 25
Location: China, Shenyang
Repository : WineHQ
Code:
[me@localhost ~]$ sudo dnf install winehq-devel.i686
Last metadata expiration check: 0:25:09 ago on Sun 13 Jan 2019 04:12:19 PM CST.
Error:
 Problem: package winehq-devel-1:4.0.rc1-8.1.i686 requires wine-devel = 1:4.0.rc1-8.1, but none of the providers can be installed
  - package winehq-devel-1:4.0.rc1-8.1.i686 conflicts with wine-devel provided by wine-devel-1:4.0.rc1-8.1.i686
  - conflicting requests
  - package winehq-devel-1:4.0.rc2-14.1.i686 requires wine-devel = 1:4.0.rc2-14.1, but none of the providers can be installed
  - package winehq-devel-1:4.0.rc2-14.1.i686 conflicts with wine-devel provided by wine-devel-1:4.0.rc2-14.1.i686
  - package winehq-devel-1:4.0.rc3-10.1.i686 requires wine-devel = 1:4.0.rc3-10.1, but none of the providers can be installed
  - package winehq-devel-1:4.0.rc3-10.1.i686 conflicts with wine-devel provided by wine-devel-1:4.0.rc3-10.1.i686
  - package winehq-devel-1:4.0.rc4-3.1.i686 requires wine-devel = 1:4.0.rc4-3.1, but none of the providers can be installed
  - package winehq-devel-1:4.0.rc4-3.1.i686 conflicts with wine-devel provided by wine-devel-1:4.0.rc4-3.1.i686
  - package winehq-devel-1:4.0.rc5-14.1.i686 requires wine-devel = 1:4.0.rc5-14.1, but none of the providers can be installed
  - package winehq-devel-1:4.0.rc5-14.1.i686 conflicts with wine-devel provided by wine-devel-1:4.0.rc5-14.1.i686
  - package winehq-devel-1:4.0.rc6-4.3.i686 requires wine-devel = 1:4.0.rc6-4.3, but none of the providers can be installed
  - package winehq-devel-1:4.0.rc6-4.3.i686 conflicts with wine-devel provided by wine-devel-1:4.0.rc6-4.3.i686
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)

64bit winehq-devel works


Top 
 Post Posted: Sun Jan 13, 2019 7:00 am 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12468
You can't install winehq-devel.i686 alongside winehq-devel.x86_64, and you don't need to. The 64 bit package pulls in wine-devel-common.i686, which is the only 32 bit package you need for a WoW64 setup. The 32 bit winehq-devel package is meant for 32 bit systems; it installs pure 32 bit Wine.


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 2 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: Google [Bot] and 13 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: