Old School RuneScape Won’t Start

Questions about Wine on Linux
Post Reply
Eniws
Newbie
Newbie
Posts: 3
Joined: Sun Dec 23, 2018 9:43 pm

Old School RuneScape Won’t Start

Post by Eniws » Wed Dec 26, 2018 10:53 pm

Code: Select all

$ wine --version
wine-3.0 (Ubuntu 3.0-1zorin2)

Code: Select all

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Zorin
Description:	Zorin OS 12.4
Release:	12
Codename:	xenial
I’m trying to help someone who has Zorin OS run the Windows version of Jagex’s Old School RuneScape client. I’m running Zorin OS 12.4 Core in a virtual machine. You can get Zorin OS 12.4 Core from https://sourceforge.net/projects/zorin- ... o/download and Jagex’s Old School RuneScape client from http://www.runescape.com/downloads/olds ... 5880315931 Here is the output from running the MSI to install the client:

Code: Select all

user1@zorinosvm:~/Downloads$ wine start OldSchool.msi 
000d:err:module:load_builtin_dll failed to load .so lib for builtin L"windowscodecs.dll": /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /usr/lib/wine/../x86_64-linux-gnu/wine/windowscodecs.dll.so)
000d:err:module:import_dll Loading library windowscodecs.dll (which is needed by L"C:\\windows\\system32\\winemenubuilder.exe") failed (error c000007a).
000d:err:module:attach_dlls Importing dlls for L"C:\\windows\\system32\\winemenubuilder.exe" failed, status c0000135
user1@zorinosvm:~/Downloads$ 002b:err:mscoree:LoadLibraryShim error reading registry key for installroot
002b:err:mscoree:LoadLibraryShim error reading registry key for installroot
002b:err:mscoree:LoadLibraryShim error reading registry key for installroot
002b:err:mscoree:LoadLibraryShim error reading registry key for installroot
0034:err:module:load_builtin_dll failed to load .so lib for builtin L"windowscodecs.dll": /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /usr/lib/wine/../x86_64-linux-gnu/wine/windowscodecs.dll.so)
0034:err:module:import_dll Loading library windowscodecs.dll (which is needed by L"C:\\windows\\system32\\winemenubuilder.exe") failed (error c000007a).
0034:err:module:attach_dlls Importing dlls for L"C:\\windows\\system32\\winemenubuilder.exe" failed, status c0000135
0036:err:module:load_builtin_dll failed to load .so lib for builtin L"windowscodecs.dll": /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /usr/lib/wine/../x86_64-linux-gnu/wine/windowscodecs.dll.so)
0036:err:module:import_dll Loading library windowscodecs.dll (which is needed by L"C:\\windows\\system32\\winemenubuilder.exe") failed (error c000007a).
0036:err:module:attach_dlls Importing dlls for L"C:\\windows\\system32\\winemenubuilder.exe" failed, status c0000135
0038:err:module:load_builtin_dll failed to load .so lib for builtin L"windowscodecs.dll": /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /usr/lib/wine/../x86_64-linux-gnu/wine/windowscodecs.dll.so)
0038:err:module:import_dll Loading library windowscodecs.dll (which is needed by L"C:\\windows\\system32\\winemenubuilder.exe") failed (error c000007a).
0038:err:module:attach_dlls Importing dlls for L"C:\\windows\\system32\\winemenubuilder.exe" failed, status c0000135
003a:err:module:load_builtin_dll failed to load .so lib for builtin L"windowscodecs.dll": /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /usr/lib/wine/../x86_64-linux-gnu/wine/windowscodecs.dll.so)
003a:err:module:import_dll Loading library windowscodecs.dll (which is needed by L"C:\\windows\\system32\\winemenubuilder.exe") failed (error c000007a).
003a:err:module:attach_dlls Importing dlls for L"C:\\windows\\system32\\winemenubuilder.exe" failed, status c0000135
Based on that output it looks like there were problems but if I just double click the MSI file to run it instead of starting it through Terminal then it appears to install OK. I get the following output if I try to start the Old School client:

Code: Select all

user1@zorinosvm:~/Desktop$ wine start OldSchool\ RuneScape.lnk 
000d:err:module:load_builtin_dll failed to load .so lib for builtin L"windowscodecs.dll": /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /usr/lib/wine/../x86_64-linux-gnu/wine/windowscodecs.dll.so)
000d:err:module:import_dll Loading library windowscodecs.dll (which is needed by L"C:\\windows\\system32\\winemenubuilder.exe") failed (error c000007a).
000d:err:module:attach_dlls Importing dlls for L"C:\\windows\\system32\\winemenubuilder.exe" failed, status c0000135
user1@zorinosvm:~/Desktop$ 0030:err:module:load_builtin_dll failed to load .so lib for builtin L"msvcr100.dll": /lib/i386-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /usr/lib/wine/../i386-linux-gnu/wine/msvcr100.dll.so)
0030:err:module:import_dll Loading library msvcr100.dll (which is needed by L"C:\\windows\\system32\\msvcp100.dll") failed (error c000007a).
0030:err:module:load_builtin_dll failed to load .so lib for builtin L"MSVCR100.dll": /lib/i386-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /usr/lib/wine/../i386-linux-gnu/wine/msvcr100.dll.so)
0030:err:module:import_dll Loading library MSVCR100.dll (which is needed by L"C:\\jagexlauncher\\jagexlauncher\\bin\\MSVCP100.dll") failed (error c000007a).
0030:err:module:import_dll Library MSVCP100.dll (which is needed by L"C:\\jagexlauncher\\jagexlauncher\\bin\\JagexLauncher.exe") not found
0030:err:module:load_builtin_dll failed to load .so lib for builtin L"MSVCR100.dll": /lib/i386-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /usr/lib/wine/../i386-linux-gnu/wine/msvcr100.dll.so)
0030:err:module:import_dll Loading library MSVCR100.dll (which is needed by L"C:\\jagexlauncher\\jagexlauncher\\bin\\JagexLauncher.exe") failed (error c000007a).
0030:err:module:attach_dlls Importing dlls for L"C:\\jagexlauncher\\jagexlauncher\\bin\\JagexLauncher.exe" failed, status c0000135
The client does not start. Any suggestions? I haven't set up library or DLL overrides in winecfg, haven't set any non-default registry settings, or used used winetricks yet.

User avatar
DarkShadow44
Level 7
Level 7
Posts: 943
Joined: Tue Nov 22, 2016 5:39 pm

Re: Old School RuneScape Won’t Start

Post by DarkShadow44 » Thu Dec 27, 2018 10:53 am

As you see, it fails to load a lot of libraries - because of "/lib/i386-linux-gnu/libm.so.6". You need to fix that. Do you have up-to-date glibc?

Eniws
Newbie
Newbie
Posts: 3
Joined: Sun Dec 23, 2018 9:43 pm

Re: Old School RuneScape Won’t Start

Post by Eniws » Thu Dec 27, 2018 6:55 pm

The OS is as up to date as it can be right now.

Code: Select all

user1@zorinosvm:~/Desktop$ sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  gir1.2-appindicator3-0.1 liba11y-profile-manager-0.1-0
  liba11y-profile-manager-data
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

user1@zorinosvm:~/Desktop$ sudo apt dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  gir1.2-appindicator3-0.1 liba11y-profile-manager-0.1-0
  liba11y-profile-manager-data
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
I went looking for a glibc package. I didn't find one.

Code: Select all

user1@zorinosvm:~/Desktop$ dpkg -l glibc
dpkg-query: no packages found matching glibc

user1@zorinosvm:~/Desktop$ sudo apt install glibc
[sudo] password for user1: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package glibc

user1@zorinosvm:~/Desktop$ dpkg -l glibc*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
un  glibc-doc      <none>       <none>       (no description available)
Actually, glibc is the name of a source package. https://packages.ubuntu.com/source/xenial/libs/glibc I don't know a lot about Linux- only enough to fix something by myself once in a while- but seems like glibc isn't a package I'm meant to install. Perhaps you are interested in the following:

Code: Select all

user1@zorinosvm:~/Desktop$ dpkg -S /lib/i386-linux-gnu/libm.so.6
libc6:i386: /lib/i386-linux-gnu/libm.so.6

user1@zorinosvm:~/Desktop$ apt-cache policy libc6:i386
libc6:i386:
  Installed: 2.23-0ubuntu10
  Candidate: 2.23-0ubuntu10
  Version table:
 *** 2.23-0ubuntu10 500
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages
        100 /var/lib/dpkg/status
     2.23-0ubuntu3 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/main i386 Packages

user1@zorinosvm:~/Desktop$ apt-cache policy libc6
libc6:
  Installed: 2.23-0ubuntu10
  Candidate: 2.23-0ubuntu10
  Version table:
 *** 2.23-0ubuntu10 500
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
        100 /var/lib/dpkg/status
     2.23-0ubuntu3 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

user1@zorinosvm:~/Desktop$ ls -l /lib/i386-linux-gnu/libm*
-rw-r--r-- 1 root root 341948 Jan 14  2018 /lib/i386-linux-gnu/libm-2.23.so
-rw-r--r-- 1 root root  17960 Jan 14  2018 /lib/i386-linux-gnu/libmemusage.so
lrwxrwxrwx 1 root root     12 Dec 23 17:44 /lib/i386-linux-gnu/libm.so.6 -> libm-2.23.so
The 32-bit libc6 package which provides libm is installed and libm is present. Perhaps the version of Wine in Zorin OS 12.4 Core is looking for a version of libm that isn't available. I'm not the only one who has this issue. https://bugs.launchpad.net/zorin-os/+bug/1775454

User avatar
DarkShadow44
Level 7
Level 7
Posts: 943
Joined: Tue Nov 22, 2016 5:39 pm

Re: Old School RuneScape Won’t Start

Post by DarkShadow44 » Fri Dec 28, 2018 11:37 am

As far as I can tell, your glibc is too old. You have "libm-2.23.so" while it wants "GLIBC_2.27".

Do you use the offical winehq packages or how did you install wine?

Eniws
Newbie
Newbie
Posts: 3
Joined: Sun Dec 23, 2018 9:43 pm

Re: Old School RuneScape Won’t Start

Post by Eniws » Fri Dec 28, 2018 4:04 pm

I didn't install Wine. Zorin OS has Wine installed when the operating system is installed. I'm guessing it is installed by using the Ubuntu 16.04 Xenial repo package during installation of the operating system. One of the advertised advantages of Zorin OS is that it comes with support for running several Windows programs- no additional setup needed. Though, I know that adding support for running Windows programs on other distros isn't an ordeal, not needing to do that in Zorin OS can be appealing to Linux newbies.

User avatar
DarkShadow44
Level 7
Level 7
Posts: 943
Joined: Tue Nov 22, 2016 5:39 pm

Re: Old School RuneScape Won’t Start

Post by DarkShadow44 » Fri Dec 28, 2018 7:58 pm

Then that sounds like an issue you'd want to take to the ZorinOS team - they seem to have messed up the packaging.

Post Reply