WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 4 posts ] 



 
Author Message
 Post Posted: Mon Dec 24, 2018 5:31 am 
Offline
Level 1
Level 1

Joined: Mon Dec 24, 2018 5:12 am
Posts: 5
I am new to the Linux world and have installed Pinguy 18.04 (which is based on Ubuntu 18.04). I am trying to install wine by following the instructions exactly what is on the Ubuntu instructions page, making sure that I added the Bionic repository, and I can confirm that not one Cosmic repository is mentioned in sources.list. Everything works well until I executed 'sudo apt install --install-recommends winehq-stable', then my output is this:

[codeReading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
winehq-stable : Depends: wine-stable (= 3.0.4~bionic)
E: Unable to correct problems, you have held broken packages.][/code]

I tried installing the wine-stable dependency, but this only results in more dependencies listed. For example:

Code:
The following packages have unmet dependencies:
 wine-stable : Depends: wine-stable-amd64 (= 3.0.4~bionic) but it is not going to be installed
               Depends: wine-stable-i386 (= 3.0.4~bionic)
E: Unable to correct problems, you have held broken packages.]

[/code]

and when I try to install wine-stable-i386:

Code:
The following packages have unmet dependencies:
 wine-stable-i386:i386 : Depends: libasound2:i386 (>= 1.0.16)
                         Depends: libglib2.0-0:i386 (>= 2.12.0) but it is not going to be installed
                         Depends: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) but it is not going to be installed
                         Depends: libgstreamer1.0-0:i386 (>= 1.4.0) but it is not going to be installed
                         Depends: libopenal1:i386 (>= 1.14) but it is not going to be installed
                         Depends: libpulse0:i386 (>= 0.99.1) but it is not going to be installed
                         Depends: libasound2-plugins:i386 but it is not going to be installed
                         Depends: libncurses5:i386 but it is not going to be installed
                         Recommends: libncurses5:i386 (>= 6) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


I think the "but it is not going to be installed" means that I already installed it?


Top 
 Post Posted: Mon Dec 24, 2018 6:25 am 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12490
Katakis wrote:
Code:
The following packages have unmet dependencies:
 wine-stable-i386:i386 : Depends: libasound2:i386 (>= 1.0.16)
                         Depends: libglib2.0-0:i386 (>= 2.12.0) but it is not going to be installed
                         Depends: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) but it is not going to be installed
                         Depends: libgstreamer1.0-0:i386 (>= 1.4.0) but it is not going to be installed
                         Depends: libopenal1:i386 (>= 1.14) but it is not going to be installed
                         Depends: libpulse0:i386 (>= 0.99.1) but it is not going to be installed
                         Depends: libasound2-plugins:i386 but it is not going to be installed
                         Depends: libncurses5:i386 but it is not going to be installed
                         Recommends: libncurses5:i386 (>= 6) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


I think the "but it is not going to be installed" means that I already installed it?

Nope; it means the opposite. What you have to do now is try to install each of those packages to find out why they are not going to be installed.

Since they are all i386 packages, I will make one guess: did you enable 32 bit architecture on your system? You need to.


Top 
 Post Posted: Mon Dec 24, 2018 6:40 am 
Offline
Level 1
Level 1

Joined: Mon Dec 24, 2018 5:12 am
Posts: 5
> "Since they are all i386 packages, I will make one guess: did you enable 32 bit architecture on your system? You need to."

I did, but I got no message saying that it was successful. All it did was returned me to the prompt.


Top 
 Post Posted: Mon Dec 24, 2018 7:16 am 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12490
No message means it was successful, so the problem is something else. You just have to try installing each of those packages and see what your package manager tells you about why it can't be installed.


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 4 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 22 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: