WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 10 posts ] 



 
Author Message
 Post Posted: Mon Nov 26, 2018 4:27 am 
Offline
Level 1
Level 1

Joined: Mon Nov 26, 2018 4:15 am
Posts: 6
I have installed Wine 3.03 stable on mint 19
The test notepad works fine

Sonos 9.2 installs with no issues.
The program starts with a splash page .... then resolutely stays stuck on the splash.

Any help, tips gratefully received!

regards


Top 
 Post Posted: Mon Nov 26, 2018 7:58 am 
Offline
Level 5
Level 5

Joined: Thu Aug 14, 2014 10:10 am
Posts: 259
We don't have a crystal ball here, so it is difficult to tell what went wrong.
Can you post the terminal output, including the wine command you use?
https://wiki.winehq.org/Wine_User's_Gui ... mmand_line
https://wiki.winehq.org/FAQ#How_can_I_g ... tput.29.3F


Top 
 Post Posted: Mon Nov 26, 2018 9:10 am 
Offline
Level 1
Level 1

Joined: Mon Nov 26, 2018 4:15 am
Posts: 6
jkfloris wrote:
We don't have a crystal ball here, so it is difficult to tell what went wrong.
Can you post the terminal output, including the wine command you use?
https://wiki.winehq.org/Wine_User's_Gui ... mmand_line
https://wiki.winehq.org/FAQ#How_can_I_g ... tput.29.3F


Thanks for the reply.

I've obtained the terminal output by running the Sonos.exe from winefile (earlier I used the menu entry).
The output ends/sticks and has to be killed with control c.

Attached: SONOS-WINE


Top 
 Post Posted: Mon Nov 26, 2018 10:18 am 
Offline
Level 3
Level 3

Joined: Sun Jan 17, 2016 4:36 pm
Posts: 66
Location: Eindhoven de gekste!
Also worth to check in this case:

Run the app in a virtual desktop (in winecfg under graphics tab)

Sometimes a messagebox (that one has to click) is hidden behind a splash screen. Saw this a few times in other apps


Top 
 Post Posted: Mon Nov 26, 2018 11:01 am 
Offline
Level 1
Level 1

Joined: Mon Nov 26, 2018 4:15 am
Posts: 6
Thanks. The splash is a small square centre screen - it should simply clear and be replaced by the main screen after a few seconds.
I think it's a NET problem ...

ps: my posts are moderated so my replies can take hours to appear.


Top 
 Post Posted: Mon Nov 26, 2018 1:28 pm 
Offline
Level 3
Level 3

Joined: Sun Jan 17, 2016 4:36 pm
Posts: 66
Location: Eindhoven de gekste!
There is a bugreport for this app in bugzilla, i posted some info here:
https://www.winehq.org/pipermail/wine-b ... 03936.html


Top 
 Post Posted: Mon Nov 26, 2018 2:53 pm 
Offline
Level 1
Level 1

Joined: Mon Nov 26, 2018 4:15 am
Posts: 6
Oops - lost the attachment!

wine sonos.exe (splash on screen ad infinitum)

Here's the output

Code:
brian@mini2:~$ winefile

Unhandled Exception:
System.IO.FileNotFoundException: Could not load file or assembly 'PresentationFramework, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies.
File name: 'PresentationFramework, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'


Server stack trace:
  at System.AppDomain+Initializer.Initialize () [0x00000] in <1c90db0b17cb4b1e827d577d0607b212>:0
  at System.AppDomain.DoCallBack (System.CrossAppDomainDelegate callBackDelegate) [0x00003] in <1c90db0b17cb4b1e827d577d0607b212>:0
  at (wrapper remoting-invoke-with-check) System.AppDomain:DoCallBack (System.CrossAppDomainDelegate)
  at (wrapper xdomain-dispatch) System.AppDomain:DoCallBack (object,byte[]&,byte[]&)

Exception rethrown at [0]:
  at (wrapper xdomain-invoke) System.AppDomain:DoCallBack (System.CrossAppDomainDelegate)
  at (wrapper remoting-invoke-with-check) System.AppDomain:DoCallBack (System.CrossAppDomainDelegate)
  at System.AppDomain.CreateDomain (System.String friendlyName, System.Security.Policy.Evidence securityInfo, System.AppDomainSetup info) [0x00144] in <1c90db0b17cb4b1e827d577d0607b212>:0
  at Sonos.Controller.Desktop.Startup.Glue.WpfLauncher.DoAppDomainSetup (System.Object args) [0x00026] in <d08fd61812bc4256afbd8b9800213edf>:0
  at System.Threading.ThreadHelper.ThreadStart_Context (System.Object state) [0x00025] in <1c90db0b17cb4b1e827d577d0607b212>:0
  at System.Threading.ExecutionContext.RunInternal (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x00071] in <1c90db0b17cb4b1e827d577d0607b212>:0
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x00000] in <1c90db0b17cb4b1e827d577d0607b212>:0
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state) [0x0002b] in <1c90db0b17cb4b1e827d577d0607b212>:0
  at System.Threading.ThreadHelper.ThreadStart (System.Object obj) [0x0000f] in <1c90db0b17cb4b1e827d577d0607b212>:0
                                               


Top 
 Post Posted: Tue Nov 27, 2018 5:16 pm 
Offline
Level 3
Level 3

Joined: Sun Jan 17, 2016 4:36 pm
Posts: 66
Location: Eindhoven de gekste!
You should try using native dotnet40: winetricks dotnet40

When using Staging it starts fine for me (see bugreport)


Top 
 Post Posted: Tue Nov 27, 2018 5:48 pm 
Offline
Level 1
Level 1

Joined: Mon Nov 26, 2018 4:15 am
Posts: 6
qwertymnb wrote:
You should try using native dotnet40: winetricks dotnet40

When using Staging it starts fine for me (see bugreport)


I've got it working by using PlayonLinux to install and add dotnet40 - had to switch wine to Win 10, though.

Beats me why Sonos can't be bothered to release a linux controller ....

Thanks for your advice and help


Top 
 Post Posted: Wed Nov 28, 2018 5:17 pm 
Offline
Level 1
Level 1

Joined: Mon Nov 26, 2018 4:15 am
Posts: 6
Hmmmm ... got it working with win7 prefix and new controller 9.3.

But - there's a strange ainbow colour flash in the Queue frame heading - which clears usually to show the heading text, but occasionally causes the program to block

Grrrr


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 10 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: No registered users and 15 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: