mono msi is not detected

Questions about Wine on Linux
Post Reply
mahdi_an
Newbie
Newbie
Posts: 2
Joined: Thu Apr 11, 2019 8:33 am
Location: Iran

mono msi is not detected

Post by mahdi_an » Thu Apr 18, 2019 7:45 pm

I placed wine-mono-4.8.2.msi in /usr/share/wine/mono but wine still tries to download it. I had no problem for gecko.

Code: Select all

$ wine '/home/m/Downloads/Firefox Setup 66.0.3.exe' 
wine: created the configuration directory '/home/m/.wine'
0009:err:file:init_redirects cannot open L"C:\\windows" (c000000f)
0012:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0012:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0012:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0012:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0012:err:ole:get_local_server_stream Failed: 80004002
0014:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0014:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0014:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0014:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0014:err:ole:get_local_server_stream Failed: 80004002


tk421
Level 2
Level 2
Posts: 24
Joined: Wed Aug 09, 2017 7:19 am
Location: Australia

Re: mono msi is not detected

Post by tk421 » Tue Apr 23, 2019 4:12 pm

Mono is looking for a particular version, and it does not have to be the latest one.

It is currently working for me with wine-mono-4.8.1.msi, but you could also try with wine-mono-4.8.3.msi

Please check the available downloads at https://dl.winehq.org/wine/wine-mono/

User avatar
Bob Wya
Level 12
Level 12
Posts: 2777
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: mono msi is not detected

Post by Bob Wya » Tue Apr 23, 2019 4:27 pm

mahdi_an wrote:I placed wine-mono-4.8.2.msi in /usr/share/wine/mono but wine still tries to download it. I had no problem for gecko.
...
@mahdi_an

The wine-mono version you require is hard coded in whatever Wine version you are using...

E.g.:
  • Wine (Staging) 4.0 4.1 4.2 ......... wine-mono 4.7.5
  • Wine (Staging) 4.3 4.4 4.5 ......... wine-mono 4.8.0
  • Wine (Staging) 4.6 .................... wine-mono 4.8.1
  • Wine (Staging) master .............. wine-mono 4.8.3
You are at least putting the wine-mono package in the right system directory!

Bob

Post Reply