nvidia, wine, Sketchup Make

Questions about Wine on Linux
Post Reply
User avatar
olspookishmagus
Newbie
Newbie
Posts: 3
Joined: Fri Nov 16, 2018 5:17 pm
Location: Mutliverse
Contact:

nvidia, wine, Sketchup Make

Post by olspookishmagus » Fri Nov 16, 2018 6:23 pm

Hello.

I'm having some odd behaviour running SketchUp with nvidia driver.

What I'm experiencing is this:
Image

You're not supposed to be getting this black screen when you're selecting with rectangles.


X.Org server: X11R7
Nvidia driver: 390.77
XFCE: 4.12.4
XFWM: 4.12.5-1
wine: 3.0.3-2

Any ideas/insights as to why I'm getting this?

jkfloris
Level 6
Level 6
Posts: 663
Joined: Thu Aug 14, 2014 10:10 am

Re: nvidia, wine, Sketchup Make

Post by jkfloris » Sun Nov 18, 2018 5:00 am

Do the black screen also appear when you use the Winehq-devel version?

Are there any errors in the terminal output when the screen goes black?

User avatar
olspookishmagus
Newbie
Newbie
Posts: 3
Joined: Fri Nov 16, 2018 5:17 pm
Location: Mutliverse
Contact:

Re: nvidia, wine, Sketchup Make

Post by olspookishmagus » Wed Nov 21, 2018 4:48 pm

jkfloris wrote:Do the black screen also appear when you use the Winehq-devel version?

Are there any errors in the terminal output when the screen goes black?
Unfortunately, yes.

I don't see some output generated when I select and the screen goes black again.

But here is the entire terminal output:

Code: Select all

$ WINEPREFIX=~/.wine/prefixes/SketchUp/ wine "C:\Program Files\SketchUp\SketchUp 2014\SketchUp.exe"
0009:fixme:nls:GetThreadPreferredUILanguages 00000034, 0x32e6f0, 0x32e760 0x32e6f8
0009:fixme:nls:get_dummy_preferred_ui_language (0x34 0x32e6f0 0x32e760 0x32e6f8) returning a dummy value (current locale)
0009:fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
0009:fixme:msvcrt:type_info_name_internal_method type_info_node parameter ignored
0009:fixme:nls:GetThreadPreferredUILanguages 00000034, 0x32f79c, 0x32f80c 0x32f7a4
0009:fixme:nls:get_dummy_preferred_ui_language (0x34 0x32f79c 0x32f80c 0x32f7a4) returning a dummy value (current locale)

Intrinsic Alchemy v3.6 Beta-0709 (Dynamic/Release)
Built by <unknown> on Tue Jul 9 00:00:00 2013

0009:fixme:shell:InitNetworkAddressControl stub
0009:fixme:ieframe:PersistStreamInit_InitNew (0x2dd1258)
0009:fixme:ieframe:navigate_url Unsupported args (Flags 0x32ef18 {VT_I4: 4}; TargetFrameName 0x32ef28 {VT_BSTR: (null)})
0009:fixme:urlmon:InternetBindInfo_GetBindString not supported string type 20
0009:fixme:ieframe:navigate_url Unsupported args (Flags 0x32ef58 {VT_I4: 4}; TargetFrameName 0x32ef68 {VT_BSTR: (null)})
0009:fixme:urlmon:InternetBindInfo_GetBindString not supported string type 20
0009:fixme:urlmon:InternetBindInfo_GetBindString not supported string type 20
0009:fixme:urlmon:InternetBindInfo_GetBindString not supported string type 20
0009:fixme:urlmon:InternetBindInfo_GetBindString not supported string type 20
0009:fixme:urlmon:InternetBindInfo_GetBindString not supported string type 20
003a:fixme:wininet:create_cache_entry INTERNET_FLAG_NEED_FILE is not supported correctly
0009:fixme:urlmon:start_downloading Could not get cache file
0009:fixme:ieframe:handle_navigation_error Navigate to error page
0037:fixme:wininet:create_cache_entry INTERNET_FLAG_NEED_FILE is not supported correctly
0036:fixme:wininet:create_cache_entry INTERNET_FLAG_NEED_FILE is not supported correctly
0039:fixme:wininet:create_cache_entry INTERNET_FLAG_NEED_FILE is not supported correctly
003b:fixme:wininet:create_cache_entry INTERNET_FLAG_NEED_FILE is not supported correctly
003c:fixme:wininet:create_cache_entry INTERNET_FLAG_NEED_FILE is not supported correctly
Could not load wine-gecko. HTML rendering will be disabled.
0009:err:mshtml:create_document_object Failed to init Gecko, returning CLASS_E_CLASSNOTAVAILABLE
0009:fixme:ole:CoCreateInstanceEx no instance created for interface {00000000-0000-0000-c000-000000000046} of class {25336920-03f9-11cf-8fd0-00aa00686f13}, hres is 0x80040111
0009:fixme:ieframe:handle_navigation_error Navigate to error page
0009:err:mshtml:create_document_object Failed to init Gecko, returning CLASS_E_CLASSNOTAVAILABLE
0009:fixme:ole:CoCreateInstanceEx no instance created for interface {00000000-0000-0000-c000-000000000046} of class {25336920-03f9-11cf-8fd0-00aa00686f13}, hres is 0x80040111
0009:fixme:ieframe:handle_navigation_error Navigate to error page
0009:fixme:ieframe:WebBrowser_Stop (0x2dd1258)
0009:fixme:ieframe:OleInPlaceObject_InPlaceDeactivate (0x2dd1258)
0009:fixme:win:EnumDisplayDevicesW ((null),0,0x32de88,0x00000000), stub!
0009:fixme:dwmapi:DwmIsCompositionEnabled 0x32ef1c
0009:fixme:uxtheme:BufferedPaintInit Stub ()
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
<internal:gem_prelude>:1:in `require': cannot load such file -- rubygems.rb (LoadError)
	from <internal:gem_prelude>:1:in `<compiled>'
0009:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x32f83c 1 C) semi-stub
0009:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x32f61c 1 C) semi-stub
0009:fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 30000
0009:fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 30000
0009:fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 30000
0009:fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 30000
0009:fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 30000
0009:fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 30000
0009:fixme:uxtheme:BufferedPaintUnInit Stub ()
0009:fixme:msvcrt:__clean_type_info_names_internal (0x2a5755c) stub
0009:fixme:msvcrt:__clean_type_info_names_internal (0x3db5ec) stub
0009:fixme:msvcrt:__clean_type_info_names_internal (0x788b0e54) stub
0009:fixme:msvcrt:__clean_type_info_names_internal (0x2166614) stub
0009:fixme:msvcrt:__clean_type_info_names_internal (0x2267c84) stub
0009:fixme:msvcrt:__clean_type_info_names_internal (0x2616734) stub
0009:fixme:msvcrt:__clean_type_info_names_internal (0x2692f64) stub
0009:fixme:msvcrt:__clean_type_info_names_internal (0x275b7c4) stub
0009:fixme:msvcrt:__clean_type_info_names_internal (0x1fcb994) stub
0009:fixme:msvcrt:__clean_type_info_names_internal (0x1a5f47c) stub
0009:fixme:msvcrt:__clean_type_info_names_internal (0x37d1a4) stub
0009:fixme:msvcrt:__clean_type_info_names_internal (0x1bc6b6c) stub
0009:fixme:msvcrt:__clean_type_info_names_internal (0x3995b4) stub
0009:fixme:msvcrt:__clean_type_info_names_internal (0x1cca8cc) stub
0009:fixme:msvcrt:__clean_type_info_names_internal (0x1e47374) stub
0009:fixme:msvcrt:__clean_type_info_names_internal (0x1d6bfdc) stub
0009:fixme:msvcrt:__clean_type_info_names_internal (0x3a306c) stub
$
Any more ideas/insights as to what I could also try or what's going on?

User avatar
olspookishmagus
Newbie
Newbie
Posts: 3
Joined: Fri Nov 16, 2018 5:17 pm
Location: Mutliverse
Contact:

Re: nvidia, wine, Sketchup Make

Post by olspookishmagus » Sat Nov 24, 2018 2:53 pm

Just a quick update that what I'm experiencing still happens with:

nvidia driver: 390.87
wine: 3.20.0

And also I've checked with my laptop that uses Intel graphics where this does NOT happen.
Here is the log from my laptop:

Code: Select all

000f:err:service:process_send_command receiving command result timed out
0026:err:ntdll:RtlpWaitForCriticalSection section 0x7bcea700 "loader.c: loader_section" wait timed out in thread 0026, blocked by 0025, retrying (60 sec)

Intrinsic Alchemy v3.7 Beta-0403 (Dynamic/Release)
Built by <unknown> on Thu Apr 3 00:00:00 2014
Still no idea/clue on why I could be experiencing this.

Post Reply