WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 6 posts ] 



 
Author Message
 Post Posted: Sun Jul 23, 2017 8:32 pm 
Offline
Newbie
Newbie

Joined: Sun Jul 23, 2017 8:07 pm
Posts: 3
Strange behavior here: Trying to find an alternative to Ubuntu Unity, I installed Kubuntu with the following configuration:
kubuntu 17.04
KDE Plasma 5.10.2
KDE Framework 5.35.0
Qt Version: 5.7.1
Kernel: 4.10.0-28-generic
wine 2.12

The language setup is the following: fr_CA.UTF-8

When I launch Scrivener, everything seems fine, except it doesn't recognize the keyboard correctly. When I press the key corresponding to "e" acute, it produce the right character "é". Keying the combination of "grave" accent and "a" produce also a good "à". After that, if I key the combination of "grave" and the letter "e", it continues to produce (falsely) the character "à". Same thing with the circumflex accent. A combination of this accent and "a" character produce also (wrongly) the letter "à".

I know this could seems a very narrow problem affecting a very small community trying to use Scrivener on a distribution running KDE Plasma, but since this bug is the only thing preventing me to make the switch to Kubuntu, I felt responsible to report it...

Please note that I observed the same behavior with Linux Mint 18 (KDE Plasma version) and the problem is not present under Ubuntu 16.04 (UNITY version)

Thanks for any help you may provide

Pierre


Top 
 Post Posted: Thu Aug 03, 2017 8:35 am 
Offline
Newbie
Newbie

Joined: Thu Aug 03, 2017 8:11 am
Posts: 3
Do you know that a native Linux-Version of scrivener has been released?


Top 
 Post Posted: Thu Aug 03, 2017 6:18 pm 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2452
Location: Cambridge
Noebian wrote:
Do you know that a native Linux-Version of scrivener has been released?


@Pierre

It would be interesting to see if the native version of Scrivener has the same issues under Plasma 5... There are numerous Plasma 5 locale bugs open... Largely these appear to centre around very lackluster locale handling in the Qt 5.x libraries...

Maybe you could take a look at: Arch Wiki: Keyboard configuration in Xorg. Since you may be able to determine what faulty keyboard mapping X is set to use by Plasma 5...

Bob


Top 
 Post Posted: Thu Aug 03, 2017 8:52 pm 
Offline
Newbie
Newbie

Joined: Sun Jul 23, 2017 8:07 pm
Posts: 3
I will try to install the linux version of scrivener to see if the keyboard mapping problem is also present but I should have mention that I didn't notice that malfunction with other programs under Plasma 5. For instance, keyboard is perfectly set up for fr_CA with Libre Office. Even with terminal prompt. The only problems I found seems to rely on the combination of Wine/Scrivener/Plasma 5....

Thanks for your help

Pierre


Top 
 Post Posted: Fri Aug 04, 2017 7:04 am 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2452
Location: Cambridge
urobepi wrote:
I will try to install the linux version of scrivener to see if the keyboard mapping problem is also present but I should have mention that I didn't notice that malfunction with other programs under Plasma 5. For instance, keyboard is perfectly set up for fr_CA with Libre Office. Even with terminal prompt. The only problems I found seems to rely on the combination of Wine/Scrivener/Plasma 5....
...


Well uhmmm. Wine is pretty low level and talks directly to the standard X libraries.
To replicate the keyboard mapping issue in a native Linux application - you'd probably want to fire up an old skool x-term Window or something similar...

Bob


Top 
 Post Posted: Thu Nov 15, 2018 10:32 pm 
Offline
Newbie
Newbie

Joined: Sun Jul 23, 2017 8:07 pm
Posts: 3
After a lots of investigation I finaly found something. The keyboard mapping problem seems not being caused by Wine, KDE Plasma or Scrivener itself. I have reproduced the same behavior recently with Linux Mint 19, cinnamon flavor. I resolved it by installing "IBus" (which is not installed by default in Mint19). The command is "sudo apt-get install ibus". After that, I opened the language settings configuration and changed the "Keyboard input setting" value with "IBus". Reboot and... tadam! The keyboard mapping is now perfect in Scrivener (Wine).
Now, why this problem happend only with scrivener program? Frankly, I dont know. But the fact is, it works now.
Hope this could be of some help for people having a similar configuration than me.
Pierre


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 6 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: Bing [Bot] and 14 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: