Unable to launch through Steam since recent Steam update

Questions about Wine on Linux
Post Reply
Blaiz0r
Newbie
Newbie
Posts: 1
Joined: Sun Nov 11, 2018 11:44 am

Unable to launch through Steam since recent Steam update

Post by Blaiz0r » Sun Nov 11, 2018 11:59 am

Recently I've been playing a lot of Grim Dawn, over 100 hours, I haven't updated my system for at least a week (BTW I use Arch).

In the last 2 days the Windows Steam client updated at least once, and now I can no longer launch the game successfully, instead I get a black screen and can hear :( sound, but the game crashes within a few seconds.

I'm running Wine-staging 3.19

I have to date tried:
  • Reinstalling the game in a new prefix
  • Removing DLC and trying the vanilla version
  • Changing DLL overrides
  • Launching the game with DX9 mode instead of DX11
  • Changing Windows version through winecfg
  • Installing Samba due to an error received in the console (error no longer shows, but doesn't improve situation)
  • Tried with and without DXVK
  • Tried fresh prefixes
After focusing on trying to fix the issue by debugging the game, I'm now convinced that the issue is actually related to Steam.

Here is the log output that I think is relevant:

Code: Select all

~ WINEPREFIX=~/.wineprefixes/grim-dawn WINEDEBUG=fixme-all,+error,+trace DXVK_LOG_LEVEL=error wine .wine/drive_c/Program\ Files\ \(x86\)/Steam/Steam.exe
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2018-11-11 10:15:28] Startup - updater built Nov  8 2018 10:53:06
[2018-11-11 10:15:28] Verifying installation...
[2018-11-11 10:15:28] Verification complete
System page size: 4096
Could not find page for trampoline in +/- 2GB range of function to hook
Error allocating trampoline memory (no memory within +/-2gb? prior failures?)
System page size: 4096
Could not find page for trampoline in +/- 2GB range of function to hook
Error allocating trampoline memory (no memory within +/-2gb? prior failures?)
[1111/101529.256:INFO:crash_reporting.cc(216)] Crash reporting enabled for process: browser
[1111/101529.317:ERROR:network_change_notifier_win.cc(157)] WSALookupServiceBegin failed with: 8
IPC client is in my process, could/should be using an in-process pipe.[1111/101530.051:ERROR:browser_gpu_channel_host_factory.cc(119)] Failed to launch GPU process.
[2018-11-11 10:15:30] Background update loop checking for update. . .
[2018-11-11 10:15:30] Checking for available update...
[2018-11-11 10:15:30] Downloading manifest: client-download.steampowered.com/client/steam_client_win32
[2018-11-11 10:15:31] Download skipped: /client/steam_client_win32 version 1541710380, installed version 1541710380
[2018-11-11 10:15:31] Nothing to do
0009:err:ole:CoGetClassObject class {294935ce-f637-4e7c-a41b-ab255460b862} not registered
0009:err:ole:CoGetClassObject class {294935ce-f637-4e7c-a41b-ab255460b862} not registered
0009:err:ole:create_server class {294935ce-f637-4e7c-a41b-ab255460b862} not registered
0009:err:ole:CoGetClassObject no class object {294935ce-f637-4e7c-a41b-ab255460b862} could be created for context 0x17
IPC client is in my process, could/should be using an in-process pipe.[1111/101537.005:ERROR:browser_gpu_channel_host_factory.cc(119)] Failed to launch GPU process.
[1111/101537.191:ERROR:browser_gpu_channel_host_factory.cc(119)] Failed to launch GPU process.
[1111/101537.192:ERROR:gpu_process_transport_factory.cc(1026)] Lost UI shared context.
The following is from when I click 'Play' to launch the game:

Code: Select all

IPC client is in my process, could/should be using an in-process pipe.Initializing Theora Playback Library (1.1)
  - libtheora version: Xiph.Org libtheora 1.2.0alpha 20100924 (Ptalarbvorm)
  - libvorbis version: Xiph.Org libVorbis 1.3.4
------------------------------------
Setting breakpad minidump AppID = 219990
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561197968070373 [API loaded no]
Timed out waiting for game mapping!
0097:err:seh:setup_exception_record stack overflow 856 bytes in thread 0097 eip 7b43d6f6 esp 00240fd8 stack 0x240000-0x241000-0x340000
Any help or suggestions would be greatly appreciated.

Post Reply