WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 2 [ 26 posts ] Go to page 1, 2  Next



 
Author Message
 Post subject: GTA V not work at wine
 Post Posted: Sat Sep 29, 2018 3:22 pm 
Offline
Level 2
Level 2

Joined: Sat Sep 15, 2018 7:12 am
Posts: 15
I have this problem I have wine 2.22 64 bits and when I try to deaf gta v on play on linux gets such errors in the window I will add that my computer meets the requirements of the game only linux debian 9.5, uses a graphics integrated card or processor intel core i5 8th generation here there are errors.


Code:
Unhandled exception: page fault on write access to 0x005f0067 in 32-bit code (0x11d67ae5).
Register dump:
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:11d67ae5 ESP:0033f9ec EBP:0033fa04 EFLAGS:00010202(  R- --  I   - - - )
 EAX:00000001 EBX:00000000 ECX:005f0067 EDX:00159e00
 ESI:00159d50 EDI:00159db8
Stack dump:
0x0033f9ec:  11de6223 0016e888 0033fd08 00730067
0x0033f9fc:  005f0063 00159db8 0033fa14 11de092b
0x0033fa0c:  00000000 00000000 0033fb18 11ddf8ad
0x0033fa1c:  0e4ecb50 110f415e 0033fd08 001e9cb0
0x0033fa2c:  0033fd08 7bcb6f00 7cd1ec56 7ce42000
0x0033fa3c:  7bcef750 00000000 00000001 0033fae8
000c: sel=0067 base=00000000 limit=00000000 32-bit r-x
Backtrace:
=>0 0x11d67ae5 in libcef (+0x1d67ae5) (0x0033fa04)
  1 0x11de092b in libcef (+0x1de092a) (0x0033fa14)
  2 0x11ddf8ad in libcef (+0x1ddf8ac) (0x0033fb18)
  3 0x110f38aa in libcef (+0x10f38a9) (0x0033fbd0)
  4 0x10127fb8 in libcef (+0x127fb7) (0x0033fcc0)
  5 0x101277b2 in libcef (+0x1277b1) (0x0033fd44)
  6 0x1015017c in libcef (+0x15017b) (0x0033fd90)
  7 0x1015089d in libcef (+0x15089c) (0x0033fdb0)
  8 0x10127d70 in libcef (+0x127d6f) (0x0033fde0)
  9 0x100bd1d6 in libcef (+0xbd1d5) (0x0033fe04)
  10 0x100863e8 in libcef (+0x863e7) (0x0033fe14)
  11 0x0040e46d in subprocess (+0xe46c) (0x0033fe70)
  12 0x7b46e718 call_process_entry+0xb() in kernel32 (0x0033fe88)
  13 0x7b46f8f9 in kernel32 (+0x4f8f8) (0x0033fed8)
  14 0x7bc8cc7c call_thread_func_wrapper+0xb() in ntdll (0x0033feec)
  15 0x7bc90bee in ntdll (+0x80bed) (0x0033ffec)
  16 0x7bc8cc5a RtlRaiseException+0x49() in ntdll (0x0033ffec)
0x11d67ae5: lock xaddl   %eax,0x0(%ecx)
Modules:
Module   Address         Debug info   Name (138 modules)
PE     400000-  4d2000   Export          subprocess
PE   10000000-127d9000   Export          libcef
ELF   7b400000-7b7ff000   Dwarf           kernel32<elf>
  \-PE   7b420000-7b7ff000   \               kernel32
ELF   7bc00000-7bd0d000   Dwarf           ntdll<elf>
  \-PE   7bc10000-7bd0d000   \               ntdll
ELF   7c000000-7c003000   Deferred        <wine-loader>
ELF   7c48c000-7c500000   Deferred        setupapi<elf>
  \-PE   7c4a0000-7c500000   \               setupapi
ELF   7c98e000-7ca00000   Deferred        dwrite<elf>
  \-PE   7c990000-7ca00000   \               dwrite
ELF   7cba9000-7cc2e000   Deferred        libgcrypt.so.11
ELF   7cc2e000-7ccf7000   Deferred        libgnutls.so.26
ELF   7ccf7000-7ce45000   Deferred        libx11.so.6
ELF   7cedf000-7cf18000   Deferred        uxtheme<elf>
  \-PE   7cef0000-7cf18000   \               uxtheme
ELF   7cf18000-7cf1f000   Deferred        libxfixes.so.3
ELF   7cf1f000-7cf2b000   Deferred        libxcursor.so.1
ELF   7cf2b000-7cf3e000   Deferred        libxi.so.6
ELF   7cf3e000-7cf42000   Deferred        libxcomposite.so.1
ELF   7cf42000-7cf4f000   Deferred        libxrandr.so.2
ELF   7cf4f000-7cf5b000   Deferred        libxrender.so.1
ELF   7cf5b000-7cf62000   Deferred        libxxf86vm.so.1
ELF   7cf62000-7cf66000   Deferred        libxinerama.so.1
ELF   7cf66000-7cf82000   Deferred        libbsd.so.0
ELF   7cf82000-7cf89000   Deferred        libxdmcp.so.6
ELF   7cf89000-7cf8d000   Deferred        libxau.so.6
ELF   7cf8d000-7cfb9000   Deferred        libxcb.so.1
ELF   7cfb9000-7cfce000   Deferred        libxext.so.6
ELF   7cfce000-7d06d000   Deferred        winex11<elf>
  \-PE   7cfe0000-7d06d000   \               winex11
ELF   7d06d000-7d084000   Deferred        libgpg-error.so.0
ELF   7d084000-7d0fd000   Deferred        libpcre.so.3
ELF   7d0fd000-7d11b000   Deferred        libgcc_s.so.1
ELF   7d11b000-7d1ea000   Deferred        libgcrypt.so.20
ELF   7d1ea000-7d1fd000   Deferred        liblz4.so.1
ELF   7d1fd000-7d229000   Deferred        liblzma.so.5
ELF   7d229000-7d256000   Deferred        libselinux.so.1
ELF   7d256000-7d2e8000   Deferred        libsystemd.so.0
ELF   7d2e8000-7d2f1000   Deferred        libffi.so.6
ELF   7d2f1000-7d34d000   Deferred        libdbus-1.so.3
ELF   7d34d000-7d3db000   Deferred        libgmp.so.10
ELF   7d3db000-7d411000   Deferred        libhogweed.so.4
ELF   7d411000-7d44e000   Deferred        libnettle.so.6
ELF   7d44e000-7d463000   Deferred        libtasn1.so.6
ELF   7d463000-7d497000   Deferred        libidn.so.11
ELF   7d497000-7d4f9000   Deferred        libp11-kit.so.0
ELF   7d4f9000-7d4fe000   Deferred        libkeyutils.so.1
ELF   7d4fe000-7d50b000   Deferred        libkrb5support.so.0
ELF   7d50b000-7d510000   Deferred        libcom_err.so.2
ELF   7d510000-7d546000   Deferred        libk5crypto.so.3
ELF   7d546000-7d622000   Deferred        libkrb5.so.3
ELF   7d622000-7d636000   Deferred        libavahi-client.so.3
ELF   7d636000-7d645000   Deferred        libavahi-common.so.3
ELF   7d645000-7d80a000   Deferred        libgnutls.so.30
ELF   7d80a000-7d85c000   Deferred        libgssapi_krb5.so.2
ELF   7d85c000-7d8e9000   Deferred        libcups.so.2
ELF   7d8fe000-7d910000   Deferred        libtasn1.so.3
ELF   7d94e000-7d978000   Deferred        libexpat.so.1
ELF   7d978000-7d9bb000   Deferred        libfontconfig.so.1
ELF   7d9bb000-7d9f5000   Deferred        libpng16.so.16
ELF   7d9f5000-7daa9000   Deferred        libfreetype.so.6
ELF   7dad0000-7db20000   Deferred        usp10<elf>
  \-PE   7dae0000-7db20000   \               usp10
ELF   7db20000-7db82000   Deferred        oleacc<elf>
  \-PE   7db30000-7db82000   \               oleacc
ELF   7db82000-7dc68000   Deferred        crypt32<elf>
  \-PE   7db90000-7dc68000   \               crypt32
ELF   7dc68000-7dc80000   Deferred        libresolv.so.2
ELF   7dc81000-7dca7000   Deferred        imm32<elf>
  \-PE   7dc90000-7dca7000   \               imm32
ELF   7dca7000-7dcd4000   Deferred        iphlpapi<elf>
  \-PE   7dcb0000-7dcd4000   \               iphlpapi
ELF   7dcd4000-7dd06000   Deferred        netapi32<elf>
  \-PE   7dce0000-7dd06000   \               netapi32
ELF   7dd06000-7dd3e000   Deferred        secur32<elf>
  \-PE   7dd10000-7dd3e000   \               secur32
ELF   7dd3e000-7dd6b000   Deferred        msacm32<elf>
  \-PE   7dd40000-7dd6b000   \               msacm32
ELF   7dd6b000-7de2c000   Deferred        winmm<elf>
  \-PE   7dd70000-7de2c000   \               winmm
ELF   7de2c000-7de43000   Deferred        wtsapi32<elf>
  \-PE   7de30000-7de43000   \               wtsapi32
ELF   7de43000-7de82000   Deferred        ws2_32<elf>
  \-PE   7de50000-7de82000   \               ws2_32
ELF   7de82000-7deaa000   Deferred        mpr<elf>
  \-PE   7de90000-7deaa000   \               mpr
ELF   7deaa000-7dec5000   Deferred        libz.so.1
ELF   7ded7000-7deec000   Deferred        dhcpcsvc<elf>
  \-PE   7dee0000-7deec000   \               dhcpcsvc
ELF   7deec000-7df76000   Deferred        wininet<elf>
  \-PE   7df00000-7df76000   \               wininet
ELF   7df76000-7e022000   Deferred        urlmon<elf>
  \-PE   7df80000-7e022000   \               urlmon
ELF   7e022000-7e03a000   Deferred        userenv<elf>
  \-PE   7e030000-7e03a000   \               userenv
ELF   7e03a000-7e057000   Deferred        jsproxy<elf>
  \-PE   7e040000-7e057000   \               jsproxy
ELF   7e057000-7e09b000   Deferred        winhttp<elf>
  \-PE   7e060000-7e09b000   \               winhttp
ELF   7e09b000-7e1ee000   Deferred        oleaut32<elf>
  \-PE   7e0b0000-7e1ee000   \               oleaut32
ELF   7e1ee000-7e280000   Deferred        rpcrt4<elf>
  \-PE   7e200000-7e280000   \               rpcrt4
ELF   7e280000-7e3f9000   Deferred        ole32<elf>
  \-PE   7e2a0000-7e3f9000   \               ole32
ELF   7e3f9000-7e54c000   Deferred        comctl32<elf>
  \-PE   7e400000-7e54c000   \               comctl32
ELF   7e54c000-7e5c9000   Deferred        shlwapi<elf>
  \-PE   7e560000-7e5c9000   \               shlwapi
ELF   7e5c9000-7e834000   Deferred        shell32<elf>
  \-PE   7e5e0000-7e834000   \               shell32
ELF   7e834000-7e92e000   Deferred        comdlg32<elf>
  \-PE   7e840000-7e92e000   \               comdlg32
ELF   7e92e000-7e948000   Deferred        version<elf>
  \-PE   7e930000-7e948000   \               version
ELF   7e948000-7eb5f000   Deferred        user32<elf>
  \-PE   7e960000-7eb5f000   \               user32
ELF   7eb5f000-7eba6000   Deferred        winspool<elf>
  \-PE   7eb70000-7eba6000   \               winspool
ELF   7eba6000-7ecff000   Deferred        gdi32<elf>
  \-PE   7ebb0000-7ecff000   \               gdi32
ELF   7ecff000-7ed82000   Deferred        advapi32<elf>
  \-PE   7ed10000-7ed82000   \               advapi32
ELF   7ed82000-7ed95000   Deferred        psapi<elf>
  \-PE   7ed90000-7ed95000   \               psapi
ELF   7ed9c000-7edaf000   Deferred        libnss_files.so.2
ELF   7edaf000-7edbc000   Deferred        libnss_nis.so.2
ELF   7edbc000-7edd6000   Deferred        libnsl.so.1
ELF   7edd6000-7ede0000   Deferred        libnss_compat.so.2
ELF   7ef7b000-7efd0000   Deferred        libm.so.6
ELF   7efd0000-7efd9000   Deferred        librt.so.1
ELF   f73b6000-f73bb000   Deferred        libdl.so.2
ELF   f73bb000-f7572000   Deferred        libc.so.6
ELF   f7572000-f758f000   Deferred        libpthread.so.0
ELF   f75b6000-f776e000   Dwarf           libwine.so.1
ELF   f7771000-f7796000   Deferred        ld-linux.so.2
ELF   f7798000-f7799000   Deferred        [vdso].so
Threads:
process  tid      prio (all id:s are in hex)
0000000e services.exe
   00000022    0
   0000001c    0
   00000013    0
   00000010    0
   0000000f    0
00000011 winedevice.exe
   0000001f    0
   00000017    0
   00000016    0
   00000012    0
0000001a plugplay.exe
   0000001e    0
   0000001d    0
   0000001b    0
00000020 winedevice.exe
   00000024    0
   00000023    0
   00000021    0
00000054 GTAVLauncher.exe
   000000b9    0
   000000b8    0
   0000009c    0
   00000082    0
   00000069    0
   00000068    0
   00000065    0
   00000064    0
   00000063    0
   00000061    0
   00000060    0
   0000005f    0
   0000005e    0
   0000005c    0
   0000005b    0
   00000055    0
00000056 explorer.exe
   0000005a    0
   00000059    0
   00000058    0
   00000057    0
0000009d (D) C:\Program Files (x86)\Rockstar Games\Social Club\subprocess.exe
   000000cb    0
   000000ca    0
   000000bc    0
   000000b6    0
   000000b5    0
   000000b4    0
   000000b3    0
   000000b2    0
   000000b1    0
   000000b0    0
   000000af    0
   000000ae    0
   000000ad    0
   000000ac    0
   000000ab    0
   000000aa    0
   000000a9    0
   000000a8    0
   000000a7    0
   000000a6    0
   000000a5    0
   000000a4    0
   000000a3    0
   000000a2    0
   000000a1    0
   000000a0    0
   0000009f    0
   0000009e    0 <==
System information:
    Wine build: wine-2.22
    Platform: i386 (WOW64)
    Version: Windows 7
    Host system: Linux
    Host version: 4.9.0-7-amd64


Top 
 Post Posted: Sun Sep 30, 2018 9:08 am 
Offline
Level 5
Level 5

Joined: Thu Aug 14, 2014 10:10 am
Posts: 359
Quote:
Wine build: wine-2.22

Try again with the latest Wine Staging version.


Top 
 Post Posted: Sun Sep 30, 2018 9:23 am 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2452
Location: Cambridge
@tomi

PlayOnLinux isn't supported on this site.
See: WineHQ FAQ: 8.7 I used a third party application (PlayOnLinux, WineBottler, etc.) to install or manage applications in Wine and need help.
Frankly PlayOnLinux appears to be on life support anyway... The latest version is written in Java; which doesn't seem to be a terribly forward thinking move...
All the kool kids on the block appear to be using Lutris these days!

With Intel integrated graphics - your only (slim) hope of playing GTA V, under Wine, is using DXVK + Anv Vulkan driver.
This would be hard to setup on Debian, because it supplies stale (oops, I mean stable!) packages, not the bleeding edge stuff required for Wine+DXVK gaming.

What's the output from:
Code:
inxi -G

Just to check if your Intel iGP even supports Vulkan.

Ta
Bob


Top 
 Post Posted: Sun Sep 30, 2018 11:52 am 
Offline
Level 2
Level 2

Joined: Sat Sep 15, 2018 7:12 am
Posts: 15
Bob Wya wrote:
@tomi

PlayOnLinux isn't supported on this site.
See: WineHQ FAQ: 8.7 I used a third party application (PlayOnLinux, WineBottler, etc.) to install or manage applications in Wine and need help.
Frankly PlayOnLinux appears to be on life support anyway... The latest version is written in Java; which doesn't seem to be a terribly forward thinking move...
All the kool kids on the block appear to be using Lutris these days!

With Intel integrated graphics - your only (slim) hope of playing GTA V, under Wine, is using DXVK + Anv Vulkan driver.
This would be hard to setup on Debian, because it supplies stale (oops, I mean stable!) packages, not the bleeding edge stuff required for Wine+DXVK gaming.

What's the output from:
Code:
inxi -G

Just to check if your Intel iGP even supports Vulkan.

Ta
Bob

Graphics: Card-1: Intel Device 5917
Card-2: NVIDIA Device 174d
Display Server: X.Org 1.19.2 drivers: modesetting (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.01hz
GLX Renderer: Mesa DRI Intel Kabylake GT1.5 GLX Version: 3.0 Mesa 13.0.6


Top 
 Post Posted: Mon Oct 01, 2018 2:52 pm 
Offline
Level 5
Level 5

Joined: Thu Aug 14, 2014 10:10 am
Posts: 359
According to vulkan.gpuinfo.org the Intel Device 5917 (UHD Graphics 620) supports the Vulkan API. The second NVidia Device 174d (GeForce MX130) doesn't!

You could install newer Mesa packages (version 18.1.6) from the Debian backports repository [1].

[1] https://backports.debian.org/


Top 
 Post Posted: Tue Oct 02, 2018 9:34 am 
Offline
Level 2
Level 2

Joined: Sat Sep 15, 2018 7:12 am
Posts: 15
I hav pacpage mesa in vesrion 13.6 not hav in this debian nweers vesrion.


Top 
 Post Posted: Tue Oct 02, 2018 10:33 am 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2452
Location: Cambridge
tomi wrote:
I hav pacpage mesa in vesrion 13.6 not hav in this debian nweers vesrion.


Que? :?

Bob


Top 
 Post Posted: Tue Oct 02, 2018 11:14 am 
Offline
Level 2
Level 2

Joined: Sat Sep 15, 2018 7:12 am
Posts: 15
I have a messenger pack in version 13.6. There are no newer versions in my debut


Top 
 Post Posted: Tue Oct 02, 2018 1:25 pm 
Offline
Level 5
Level 5

Joined: Thu Aug 14, 2014 10:10 am
Posts: 359
Did you read the Instruction on the Debian backports site? You have to manually add an new repository
Quote:
For stretch add this line

deb http://ftp.debian.org/debian stretch-backports main
to your sources.list (or add a new file with the ".list" extension to /etc/apt/sources.list.d/) You can also find a list of other mirrors at https://www.debian.org/mirror/list


and use
Code:
apt-get -t stretch-backports install "package"

to install the packages


Top 
 Post Posted: Wed Oct 03, 2018 9:52 am 
Offline
Level 2
Level 2

Joined: Sat Sep 15, 2018 7:12 am
Posts: 15
I use this, but it not works a message appears, no package was found


Top 
 Post Posted: Wed Oct 03, 2018 3:20 pm 
Offline
Level 5
Level 5

Joined: Thu Aug 14, 2014 10:10 am
Posts: 359
Can you post the terminal with the command you tried and the response?


Top 
 Post Posted: Thu Oct 04, 2018 2:48 am 
Offline
Level 2
Level 2

Joined: Sat Sep 15, 2018 7:12 am
Posts: 15
Code:
apt-get -t stretch-backports install "mesa-18.1"                                                                                                                                                                                                       
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
E: Nie udało się odnaleźć pakietu mesa-18.1
E: Couldn't find any package by glob 'mesa-18.1'
E: Nie udało się znaleźć żadnego pakietu według wyrażenia regularnego "mesa-18.1"


Top 
 Post Posted: Thu Oct 04, 2018 10:10 am 
Offline
Level 5
Level 5

Joined: Thu Aug 14, 2014 10:10 am
Posts: 359
Unfortunately, that is not the name of the mesa package in Debian. You could try
Code:
apt-get -t stretch-backports install libglx-mesa0 mesa-vulkan-drivers


Top 
 Post Posted: Thu Oct 04, 2018 11:34 am 
Offline
Level 2
Level 2

Joined: Sat Sep 15, 2018 7:12 am
Posts: 15
I will give it a rest, bacause i got errors such how.

Code:
Następujące pakiety zostaną USUNIĘTE:
  apper bluedevil bluetooth bluez bumblebee caja colord dbus-user-session dolphin4 gvfs gvfs-backends gvfs-daemons hplip initramfs-tools initramfs-tools-core jovie juk k3b k3b-i18n kaccessible katepart kde-baseapps kde-baseapps-bin kde-plasma-desktop kde-runtime
  kde-standard kdeaccessibility kdeconnect kdelibs-bin kdelibs5-plugins kdepasswd kdesudo kdoctools kfind kinfocenter kmag kmousetool kmouth konq-plugins konqueror konqueror-nsplugins kopete kpart-webkit libgl1-mesa-glx libgl1-mesa-glx:i386 libgles2-mesa
  libglu1-mesa:i386 libglvnd0-nvidia libglvnd0-nvidia:i386 libk3b6 libkabc4 libkatepartinterfaces4 libkcddb4 libkcompactdisc4 libkde3support4 libkdewebkit5 libkemoticons4 libkfile4 libkhtml5 libkio5 libkmediaplayer4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4
  libkonq-common libkonq5abi1 libkonqsidebarplugin4a libkopete4 libkparts4 libkpimidentities4 libkpimtextedit4 libkpimutils4 libkprintutils4 libktexteditor4 libkxmlrpcclient4 libokularcore7 libopengl0-glvnd-nvidia libpam-systemd libplasma3 libreoffice-style-galaxy
  libsane libsolid4 libvdpau-va-gl1:i386 libwine:i386 linux-image-4.9.0-6-amd64 linux-image-4.9.0-7-amd64 mate-control-center mate-core mate-desktop-environment-core mate-panel mate-polkit mate-settings-daemon mesa-utils network-manager okular packagekit
  packagekit-tools plasma-desktop plasma-discover plasma-nm plasma-scriptengine-javascript plasma-widgets-addons plasma-workspace policykit-1 policykit-1-gnome polkit-kde-agent-1 primus primus-libs primus-libs:i386 primus-libs-ia32:i386 printer-driver-postscript-hp
  sane-utils sddm sweeper synaptic task-desktop task-kde-desktop udev udisks2 upower vdpau-driver-all:i386 vlc wine32:i386 xorg xsane xserver-xorg xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-libinput xserver-xorg-input-wacom xserver-xorg-video-all
  xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-fbdev xserver-xorg-video-intel xserver-xorg-video-nouveau xserver-xorg-video-qxl xserver-xorg-video-radeon xserver-xorg-video-vesa xserver-xorg-video-vmware
Zostaną zainstalowane następujące NOWE pakiety:


Top 
 Post Posted: Fri Oct 05, 2018 5:21 am 
Offline
Level 5
Level 5

Joined: Thu Aug 14, 2014 10:10 am
Posts: 359
No need to panic. Apt isn't a very smart program. Just some dependencies also need a update.
Code:
apt-get -t stretch-backports install libglx-mesa0 mesa-vulkan-drivers libgl1-mesa-glx libgl1-mesa-glx:i386 libgles2-mesa

I think this will be enough.


Top 
 Post Posted: Fri Oct 05, 2018 9:35 am 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2452
Location: Cambridge
jkfloris wrote:
No need to panic. Apt isn't a very smart program. ...


Wouldn't it be better to recommend:
Code:
apt-get install aptitude

aptitude does better package dependency resolution then apt, from my limited experience of Debian / Ubuntu.

Bob


Top 
 Post Posted: Fri Oct 05, 2018 9:36 am 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2452
Location: Cambridge
jkfloris wrote:
No need to panic. Apt isn't a very smart program. ...


Wouldn't it be better to recommend:
Code:
apt-get install aptitude

aptitude does better package dependency resolution then apt, from my limited experience of Debian / Ubuntu.

Bob


Top 
 Post Posted: Fri Oct 05, 2018 10:41 am 
Offline
Level 5
Level 5

Joined: Thu Aug 14, 2014 10:10 am
Posts: 359
I'm from the old times when aptitude gives weird solutions, so I never used it.


Top 
 Post Posted: Wed Oct 10, 2018 8:25 am 
Offline
Level 2
Level 2

Joined: Sat Sep 15, 2018 7:12 am
Posts: 15
jkfloris wrote:
No need to panic. Apt isn't a very smart program. Just some dependencies also need a update.
Code:
apt-get -t stretch-backports install libglx-mesa0 mesa-vulkan-drivers libgl1-mesa-glx libgl1-mesa-glx:i386 libgles2-mesa

I think this will be enough.

I made it operations and Xorg not work, bocause four packpage self have updated, now again installed debian 9.5


Top 
 Post Posted: Thu Oct 11, 2018 4:52 pm 
Offline
Level 5
Level 5

Joined: Thu Aug 14, 2014 10:10 am
Posts: 359
Quote:
now again installed debian 9.5

Maybe you could give Debian Testing (Buster) a try.


Top 
 Post Posted: Thu Oct 11, 2018 5:49 pm 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2452
Location: Cambridge
jkfloris wrote:
Quote:
now again installed debian 9.5

Maybe you could give Debian Testing (Buster) a try.


@tomi

Or another Linux distribution. E.g. Ubuntu 18.10 has good support for Wine and DXVK.
Debian Stable is what I might run on a server (in fact WineHQ AppDB runs on Debian 9).
It doesn't make a good gaming distribution (unless you want to play really old games).

Your Intel KabyLake CPU is pretty recent... But your software is not! :cry:

There is some hope you'll some games working via DXVK and the Intel ANV Vulkan driver (although it isn't as well supported the AMD RADV and Nvidia Vulkan drivers).
But you'll need at least Mesa 18.2.x and ideally native Linux Vulkan 1.1.84 to match the DXVK headers (although I don't believe most the newer Vulkan API calls are actually used at present, by DXVK).

Bob


Top 
 Post Posted: Fri Oct 12, 2018 10:06 am 
Offline
Level 2
Level 2

Joined: Sat Sep 15, 2018 7:12 am
Posts: 15
@Bob Wya
I not use ubuntu, bacause not support nvidia, but it was once, not know ho is now ?


Top 
 Post Posted: Fri Oct 12, 2018 5:08 pm 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2452
Location: Cambridge
tomi wrote:
@Bob Wya
I not use ubuntu, bacause not support nvidia, but it was once, not know ho is now ?


I don't use Debian or Ubuntu that much...
But I'd argue Debian isn't doing you any favours by offering a ancient version of Mesa: 13.0.6.
That version is so old, it was dropped from the tail of older Gentoo mesa packages, months ago.

There is this Proprietary Driver PPA:
Proprietary GPU Drivers.
I think this PPA is available/used in the Software Sources gui.

You'd want to get an up-to-date intel i965 graphics driver as well...

Bob


Top 
 Post Posted: Fri Oct 12, 2018 6:00 pm 
Offline
Level 2
Level 2

Joined: Sat Sep 15, 2018 7:12 am
Posts: 15
Bob Wya wrote:
tomi wrote:
@Bob Wya
I not use ubuntu, bacause not support nvidia, but it was once, not know ho is now ?


I don't use Debian or Ubuntu that much...
But I'd argue Debian isn't doing you any favours by offering a ancient version of Mesa: 13.0.6.
That version is so old, it was dropped from the tail of older Gentoo mesa packages, months ago.

There is this Proprietary Driver PPA:
Proprietary GPU Drivers.
I think this PPA is available/used in the Software Sources gui.

You'd want to get an up-to-date intel i965 graphics driver as well...

Bob

I will install myself kubuntu [url = https: //launchpad.net/~graphics-drivers/+archive/ubuntu/ppa] [b] [u] [color = # FF0000] Proprietary GPU Drivers [/ color] [/ u ] [/ b] [/ url]. is only for ubuntu if also debiian?


Top 
 Post Posted: Fri Oct 12, 2018 6:28 pm 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2452
Location: Cambridge
tomi wrote:
... Is it only for Ubuntu? What about Debian?


This method of using Ubuntu PPA's on Debian, looks rather neat, if it works!
Don't use the Ubuntu binary packages directly on Debian - you'll end up with a broken packaging state.

Bob


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 2 [ 26 posts ] Go to page 1, 2  Next




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: Google [Bot] and 9 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: