Wine-Mono TLS 1.2 support

Questions about Wine on Linux
Post Reply
Posts: 3
Joined: Fri Oct 12, 2018 4:57 pm

Wine-Mono TLS 1.2 support

Post by rgyorodi » Fri Oct 12, 2018 5:21 pm

I am developing a small self hosted Web API written in C# that needs to access old DBF files (FoxPro 2.6) under Linux. For this I tried several approaches and the most promising is using Wine with Wine-Mono and the Visual FoxPro ODBC driver.

Everything works ok, until I try to introduce authentication and authorization on the Web API and switching from HTTP to HTTPS.

Actually I reduced the problem to the TLS 1.2 support that seems missing from the Wine-Mono version used.

My setup is the following:
OpenSUSE 42.3
Wine 3.17
Wine Mono 4.7.3

I tried the approach suggested here: ... -on-ubuntu.
The exception that is thrown suggests that: "TLS Support not available" ... "No such TLS Provider: `btls'."

If I run the same example under mono (version installed is 5.16), the TLS test works ok.

Is there a way to enable TLS 1.2 support in Wine-Mono?

Post Reply