WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 2 posts ] 



 
Author Message
 Post Posted: Tue Oct 02, 2018 12:23 am 
Offline
Newbie
Newbie

Joined: Tue Oct 02, 2018 12:22 am
Posts: 1
Hey everyone!

I am relatively new to Linux, and I’ve been trying to install Battlenet.

I get to this step

$ sudo apt install --install-recommends winehq-staging

and it yields…

Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libsdl2-dev : Depends: libsdl2-2.0-0 (= 2.0.8+1) but 2.0.8+dfsg1-1ubuntu1.18.04.1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I tried…
$ sudo apt-get install libsdl2-2.0.8+dfsg1-1ubuntu1.18.04.1

but I get…

E: Unable to locate package libsdl2-2.0.08+dfsg1-1ubuntu1.18.04.1

:(


Top 
 Post Posted: Tue Oct 02, 2018 2:03 pm 
Offline
Level 5
Level 5

Joined: Thu Aug 14, 2014 10:10 am
Posts: 357
libsdl2-dev isn't a dependency of Wine.

Did you run a
Code:
sudo apt-get update
sudo apt-get upgrade

before installing?

and if you don't need libsdl2-dev you can remove it
Code:
sudo apt-get purge libsdl2-dev


And try to install Wine again.


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 2 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: No registered users and 17 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: