World of Warcraft 7.3.5 (most recent) not showing

Questions about Wine on Linux
Post Reply
Belph
Newbie
Newbie
Posts: 2
Joined: Sun Mar 25, 2018 10:54 am

World of Warcraft 7.3.5 (most recent) not showing

Post by Belph » Sun Mar 25, 2018 11:00 am

I am currently trying WINE for the first time therefore I have next to no knowledge. I installed WINE 3.4 Dev and installed the Corefont (read that it is needed for WOW) and set WINE to WIn10 in the cfg then I installed the Blizzard Client which gave me an error saying that the SystemService.exe stopped working but that doesn't seem to affect anything. I then installed WoW itself and up until now there was no problem. It finished the installation and I tried to start it: The game is visible in the System Monitor and in the Taskbar and actually even seems to be on my second monitor since my mouse disappears when I drag it over BUT it's not showing anything.

My System:
Linux Mint 18.3
i7 4790k
GTX 770

User avatar
Bob Wya
Level 12
Level 12
Posts: 2772
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: World of Warcraft 7.3.5 (most recent) not showing

Post by Bob Wya » Mon Mar 26, 2018 9:10 am

@Belph

Take a look at: WineHQ AppDB: Online (MMORPG) Games / World of Warcraft...

You might want to re-test with Wine Staging 3.4 - as many of the Wine bugs linked to this game are marked STAGED and the Blizzard Battle.net client had issues running under vanilla Wine (last time I tested it).

To install Wine Staging 3.4, on Linux Mint 18.3, use:

Code: Select all

cd
wget -nc https://repos.wine-staging.com/alesliehughes/Release.key
sudo apt-key add Release.key
sudo apt-add-repository https://repos.wine-staging.com/alesliehughes/ubuntu/
sudo apt-add-repository 'deb https://repos.wine-staging.com/alesliehughes/ubuntu/ xenial main'
sudo apt-get update
sudo apt-get install --install-recommends winehq-staging
If this (experimental Wine version) still doesn't work can you post the command used to launch WOW and the resulting terminal output.

See: WineHQ FAQ: 10.1.1 How can I get a debugging log (a.k.a. terminal output)?

If the log is short (<200 lines) then you can post inline using the forum Code:

Code: Select all

I AM CODE
tags!!

Otherwise please use an external Pastebin-esque service...
E.g. referring to: ROOT REPORT: 15 FREE Pastebin Alternatives You Can Use Right Away

Thanks
Bob

Belph
Newbie
Newbie
Posts: 2
Joined: Sun Mar 25, 2018 10:54 am

Re: World of Warcraft 7.3.5 (most recent) not showing

Post by Belph » Tue Mar 27, 2018 3:32 am

Okay, it seems like the staging version is working very well. I've not encountered any bug after installing it.

BUT! I tried to run a script I found to enable OpenGL rendering:

OpenGL script"

Code: Select all

#!/bin/sh

WINEDEBUG=-all wine "/home/belph/.wine/drive_c/Program Files (x86)/World of Warcraft/WoW.exe" -opengl
OpenGL script with threaded OpenGL performance optimization

Code: Select all

#!/bin/sh

WINEDEBUG=-all __GL_THREADED_OPTIMIZATIONS=1 wine "/home/YOURUSERNAME/.wine/drive_c/Program Files (x86)/World of Warcraft/WoW.exe" -opengl
I got the scripts from http://www.webupd8.org/2014/09/how-to-i ... ft-in.html

and in WOW itself it actually says "Custom" at Graphics API but the game is all white and flickerish. Was anyone able to get it to run with OpenGL rendering?

Flickerish WOW screenshot: https://i.imgur.com/usUwwrT.png

Additional Problem: My games (not only in WINE) always start on my second monitor even though it's not set as primary. I basically have to play everything in windowed mode and wanted to ask if there is a solution for that too?

User avatar
Bob Wya
Level 12
Level 12
Posts: 2772
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: World of Warcraft 7.3.5 (most recent) not showing

Post by Bob Wya » Tue Mar 27, 2018 10:26 am

@Belph

Yeah that guide is not dated 2014 for nothing! The WOW GL renderer has been reportedly broken for months now (if not years).
Full disclaimer: I don't play MMO's...

Wine's multi-monitor handling, with the Nvidia graphics driver, is bloody awful...
Nvidia just made up their own xrandr specification for newer versions of xrandr.
Hence all the terminal spam, with:

Code: Select all

Broken NVIDIA RandR detected, falling back to RandR 1.0. Please consider using the Nouveau driver instead.
I personally use a metamodes with my Nvidia Geforce GTX 970M card.
So I can disable my either my laptop's builtin monitor, or my external monitor, with a simple xrandr call:

Code: Select all

xrandr -s [1|2]
Generally this works OK - but it's a real pain...

Hopefully Wine will eventually get more SDL-2 support - including multi-monitor support. 8)

Bob

pga256
Level 2
Level 2
Posts: 24
Joined: Mon Aug 24, 2015 10:36 am

Re: World of Warcraft 7.3.5 (most recent) not showing

Post by pga256 » Tue Mar 27, 2018 11:21 am

OpenGL has not been supported in WoW for a long time now. Also, DX9 support is poor these days. However, WoW runs nicely using DX11 and wine-staging.
I am currently using a patched version of staging, wine-staging-pba-git-3.4 and the performance with DX11 is excellent.

https://github.com/acomminos/wine-pba/issues/15 has a list of repos with this patchset if you are interested, but it is very much experimental at the moment!

The pba patchset dramatically increases 3D GFX performance. Usually by 70 - 100%.
I would recommend that you set __GL_THREADED_OPTIMIZATIONS=0 and enable CSMT in the winecfg. Also ensure that WoW is set to use D3D11 in the Config.WTF

User avatar
Bob Wya
Level 12
Level 12
Posts: 2772
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: World of Warcraft 7.3.5 (most recent) not showing

Post by Bob Wya » Tue Mar 27, 2018 11:34 am

pga256 wrote:...
https://github.com/acomminos/wine-pba/issues/15 has a list of repos with this patchset if you are interested, but it is very much experimental at the moment!
Thanks, reminded me I've built a version of Wine Staging 3.4 - with the PBA patchset...
I've only tested it with a S.T.A.L.K.E.R. title (UE3 title) - has little effect on performance, but no obvious regressions.
Of course the developer of Wine PBA was specifically targetting poor WOW performance (under Wine) - so it makes sense to use it with this game.

@Belph

For the motivation for creating this patchset (and if you're interested in the gory details)...
See this blog post: Making Direct3D games faster in Wine using modern OpenGL.
Hopefully it will get mainlined at some point in the future... 8)

Bob

swedave
Level 2
Level 2
Posts: 10
Joined: Tue Jan 06, 2015 8:44 am

Re: World of Warcraft 7.3.5 (most recent) not showing

Post by swedave » Thu Mar 29, 2018 1:55 pm

Ill rekomend Lutris . That installs Wow with a pba patched wine . Works beautiful . https://lutris.net/

Post Reply