DotNet install failure

Questions about Wine on Linux
Locked
pdizzle
Level 2
Level 2
Posts: 16
Joined: Fri Dec 26, 2014 5:09 pm

DotNet install failure

Post by pdizzle » Mon Feb 02, 2015 12:48 pm

I am trying to help my friend to install sketchup on his computer running Ubuntu 14.04

I just successfully installed it on my computer running Arch. wine version 1.7.35-1

I was unable to get it to complete on his computer so I added the wine repository on winehq.org so that he could have the newest version.

Code: Select all

$ dpkg-query -l wine
reports that his version is 1:1.7.34-0ubuntu1~pp amd64

first I need to install dotnet45

in a 32bit wine prefix:

Code: Select all

$ winetricks dotnet45
Executing w_do_call dotnet45
Executing load_dotnet45
Executing w_do_call remove_mono
Executing load_remove_mono
------------------------------------------------------
Mono does not appear to be installed.
------------------------------------------------------
DELETE - HKLM\Software\Microsoft\NET Framework Setup\NDP\v4 (null) 0 0 1
Error: The system was unable to find the specified registry key or value
Executing rm -f /home/jakob/prefix32/dosdevices/c:/windows/system32/mscoree.dll
Executing w_do_call dotnet35
Executing load_dotnet35
------------------------------------------------------
dotnet35 does not yet fully work or install on wine.  Caveat emptor.
------------------------------------------------------
Executing w_do_call dotnet30sp1
Executing load_dotnet30sp1
------------------------------------------------------
dotnet30sp1 does not yet fully work or install on wine.  Caveat emptor.
------------------------------------------------------
Executing w_do_call dotnet30
Executing load_dotnet30
------------------------------------------------------
If install fails, set /proc/sys/kernel/yama/ptrace_scope to 0.  See http://bugs.winehq.org/show_bug.cgi?id=30410
------------------------------------------------------
Executing w_do_call dotnet20
Executing load_dotnet20
Executing w_do_call remove_mono
Executing load_remove_mono
------------------------------------------------------
Mono does not appear to be installed.
------------------------------------------------------
Executing w_do_call fontfix
Executing load_fontfix
Setting Windows version to win2k
Executing winetricks_early_wine regedit C:\windows\Temp\_dotnet20\set-winver.reg
Current wine does not have wine bug 30845, so not applying workaround
Executing wine dotnetfx.exe
fixme:advapi:DecryptFileA ("C:\\users\\jakob\\Temp\\IXP000.TMP\\", 00000000): stub
err:secur32:SECUR32_initSchannelSP TLS library not found, SSL connections will fail
fixme:advapi:LsaOpenPolicy ((null),0x33f2e4,0x00000001,0x33f2d0) stub
fixme:advapi:LsaClose (0xcafe) stub
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
------------------------------------------------------
Note: command 'wine dotnetfx.exe' returned status 84.  Aborting.
------------------------------------------------------
at the time of crash a window pops up that says:
"Installation package could not be opened. Contact the application vendor to verify that this is a valid Windows installer package."

I had read elsewhere that the TLS/SSL error is due to winbind, however i confirmed that this is installed.

Any suggestions?

User avatar
dimesio
Moderator
Moderator
Posts: 12865
Joined: Tue Mar 25, 2008 10:30 pm

Re: DotNet install failure

Post by dimesio » Mon Feb 02, 2015 7:58 pm

I had read elsewhere that the TLS/SSL error is due to winbind, however i confirmed that this is installed.
If the problem were winbind the "SECUR32_initSchannelSP TLS library not found" error would be immediately followed by

Code: Select all

err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
and it isn't. You are missing some other package, probably 32 bit libgnutls.

pdizzle
Level 2
Level 2
Posts: 16
Joined: Fri Dec 26, 2014 5:09 pm

Re: DotNet install failure

Post by pdizzle » Mon Feb 02, 2015 9:57 pm

Thanks for the response.

attempt to install with:

Code: Select all

$ sudo apt-get install libgnutls26:i386
returns that it is installed and is the latest version.

I also noticed that when creating the 32bit wine prefix, there is a line about wine-gecko not being installed and html rendering being disabled. I'm not sure if that is related.

User avatar
dimesio
Moderator
Moderator
Posts: 12865
Joined: Tue Mar 25, 2008 10:30 pm

Re: DotNet install failure

Post by dimesio » Tue Feb 03, 2015 7:44 am

Wine-gecko is a required part of Wine; install it.

If Wine was compiled without GnuTLS support, that would also produce that TLS library not found error message, but AFAIK the Ubuntu packages are compiled with it (no one else has reported this problem, and we have a lot of Ubuntu users).

pdizzle
Level 2
Level 2
Posts: 16
Joined: Fri Dec 26, 2014 5:09 pm

Re: DotNet install failure

Post by pdizzle » Tue Feb 03, 2015 9:13 pm

as far as I can tell, wine-gecko is installed.

Code: Select all

jakob@jakob-Satellite-L655:~$ dpkg-query -l wine-gecko2.21
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                           Version              Architecture         Description
+++-==============================-====================-====================-=================================================================
ii  wine-gecko2.21:amd64           2.21-0ubuntu1        amd64                Microsoft Windows compatibility layer (embedded web browser)
ii  wine-gecko2.21:i386            2.21-0ubuntu1        i386                 Microsoft Windows compatibility layer (embedded web browser)
jakob@jakob-Satellite-L655:~$ dpkg-query -l wine-gecko2.24
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                           Version              Architecture         Description
+++-==============================-====================-====================-=================================================================
ii  wine-gecko2.24:amd64           2.24-0ubuntu1~ppa1   amd64                Microsoft Windows compatibility layer (embedded web browser)
jakob@jakob-Satellite-L655:~$ 

the full output from creating a new 32 bit prefix follows:

Code: Select all

jakob@jakob-Satellite-L655:~$ WINEPREFIX="/home/jakob/prefix32" WINEARCH='win32' wine wineboot
wine: created the configuration directory '/home/jakob/prefix32'
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
fixme:storage:create_storagefile Storage share mode not implemented.
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 3 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 3 out of range
err:appwizcpl:install_file MsiInstallProduct failed: 1615
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
fixme:storage:create_storagefile Storage share mode not implemented.
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 3 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 3 out of range
err:appwizcpl:install_file MsiInstallProduct failed: 1615
Could not load wine-gecko. HTML rendering will be disabled.
wine: configuration in '/home/jakob/prefix32' has been updated.
jakob@jakob-Satellite-L655:~$ 

pdizzle
Level 2
Level 2
Posts: 16
Joined: Fri Dec 26, 2014 5:09 pm

Re: DotNet install failure

Post by pdizzle » Tue Feb 03, 2015 9:35 pm

I purged wine, winetricks, wine-gecko2.21 and reinstalled. The next wine prefix I created I was prompted to install wine-gecko from a dialog box. I selected yes, but it seemed that the install failed. Creating subsequent wine prefixes did not cause the dialog box to pop up prompting to install wine-gecko. Repeating the purge/reinstall and creating a new wine prefix also will not cause the dialog to reappear.

pdizzle
Level 2
Level 2
Posts: 16
Joined: Fri Dec 26, 2014 5:09 pm

Re: DotNet install failure

Post by pdizzle » Tue Feb 03, 2015 10:58 pm

I have successfully installed dotnet45 and sketchup.

I purged wine, wine-gecko, wine-mono, winetricks. I added the ppa from winehq.org. i installed wine1.7, wine-gecko2.34, wine-mono4.5.4, and winetricks.

creating a 32 bit wineprefix gave a different output, but seemed to complete successfully.

Code: Select all

jakob@jakob-Satellite-L655:~$ WINEPREFIX="/home/jakob/prefix32test" WINEARCH='win32' wine wineboot
wine: created the configuration directory '/home/jakob/prefix32test'
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
fixme:iphlpapi:NotifyAddrChange (Handle 0x177e7b0, overlapped 0x177e7bc): stub
wine: configuration in '/home/jakob/prefix32test' has been updated.
running

Code: Select all

 $ winetricks dotnet45 
inside the proper wine prefix/arch completed successfully. The only issue is at the installation of dotnet30, the one that creates a system tray icon / dialogue bubble, i couldnt make the window for the install open and was unable to complete the install. I eventually found that by running

Code: Select all

 $ killall setup.exe 
in a separate terminal window after I was very sure that the install had completed, I could get the dotnet45 script to continue and finish successfully.

Thanks again for all the help!

Locked