WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 19 posts ] 



 
Author Message
 Post Posted: Tue Nov 12, 2013 4:42 pm 
Offline
Level 1
Level 1

Joined: Tue Nov 12, 2013 2:08 pm
Posts: 8
Hi,

I installed MS Office 2007 in Ubuntu 13.10 using Wine 1.6.
I use to write in Spanish because is my native language. The Spanish keyboard have a dead-key after which the vowels are marked with a "tilde": á, é, í, ó, ú, ü. In a previous installation (Ubuntu 12.04, Wine 1.6), the dead-key works fine, but in 13.10 doesn't work. All the special characters are functional and in the right place (ñ, ¡, ¿), but when I type the dead-key and a vowel, the program shows no character at all.
It happens in Word, Excel and PowerPoint (Notepad works fine). The problem happens just in the working area: when I enter a character with the dead-key within the Options menu (i.e. in a text-box), it works as usual (tilde appears).
I reinstalled Office in clean 32 bit and 64 bit prefixes, and the problem persists. Also, I reinstalled Spanish language in Ubuntu with no success. The problem persists even if I use a different keyboard distribution (latinamerican): the special keys are in the right place, but the correspondent dead-key doesn't work.
Thankfully, I've founded a workaround: The combination Ctrl + ' and the vowel enters the characters I need. However, I would like to fix the problem because I can write faster with the standard dead-key because it's consistent with the rest of the system. Maybe someone else is having the same problem.
I appreciate any suggestion.


Top 
 Post Posted: Tue Nov 12, 2013 6:45 pm 
Offline
Level 8
Level 8

Joined: Fri Feb 29, 2008 2:54 am
Posts: 1020
Goghard I guess the dead key works with gedit(or equal) and libreoffice/openoffice writer native Linux program. If not your Linux keyboard map is wrong. Yes there have been a few cases of it working some of the time and it be keymap wrong.

Wine 1.6 should really perform the same no matter what. There are a few traps. Keyboard layout in wine is not as straight forwards one would hope. http://bugs.winehq.org/show_bug.cgi?id=30984#c11 keyboard map in wine Its locale dependant.

http://wiki.winehq.org/TestingLanguages

LC_ALL and LANG both effect wine keyboard mappings. So if you system is set like US english other language dead-keys are disabled. So do try
LANG=es_ES.UTF-8 wine [something ms office]
and
LC_ALL=es_ES.UTF-8 wine [something ms office]


Top 
 Post Posted: Fri Nov 15, 2013 8:39 am 
Offline
Level 1
Level 1

Joined: Tue Nov 12, 2013 2:08 pm
Posts: 8
Thank you very much!
I'm able to use the dead key again.
As you supposed, the dead key worked in gedit and LibreOffice as usual, so the problem was not the Linux keyboard map.
I ran ms word as you suggested. The command line I used was:

WINEPREFIX=~/.prefixpath LANG=ES_es. UTF-8 wine 'path to WINWORD.EXE'

Everything works fine now.

Thanks again


Top 
 Post Posted: Sat Nov 16, 2013 12:19 am 
Offline
Level 8
Level 8

Joined: Fri Feb 29, 2008 2:54 am
Posts: 1020
Goghard There is something with you systems LANG/locale setting upsetting wine. That is what we confirmed by LANG=ES_es.UTF-8 working.

I am not a master of internationalization. So it would be worth finding out your systems LANG setting.


Top 
 Post Posted: Sat Nov 16, 2013 4:56 pm 
Offline
Level 1
Level 1

Joined: Tue Nov 12, 2013 2:08 pm
Posts: 8
oiaohm, do you think it's necessary to configure the LANG/locale setting of my system? As I say before, the keyboard works fine for ms office with the parameter you recommended to me , and the rest of the system works fine too.
By the way, I checked the command I wrote before and I had a mistake: I wrote "ES_es" instead of "es_ES" (it is different because Linux is case sensitive). With the wrong command the keyboard works, but when I save a file with a tilde, the system doesn't recognize it (appears a ? sign instead of the tilde). The right command is as follow:

WINEPREFIX=~/.prefixpath LANG=es_ES.UTF-8 wine 'path to WINWORD.EXE'

It works to me, but if you have another suggestion I'll try it. Thanks again.


Top 
 Post Posted: Sat Nov 16, 2013 11:20 pm 
Offline
Level 8
Level 8

Joined: Fri Feb 29, 2008 2:54 am
Posts: 1020
Goghard main reason I suggested checking system/user LANG setting and reporting bug about what it is if it something near correct. Is so that .desktop file (the entries in start menu wine creates) can work correctly.

If you are willing to live with those menu entries broken no problems.

~ bit is a feature of posix shell. Not something you can use inside a Windows program.

It is possible to edit the .desktop/menu files to include the LANG value as well.

Goghard really I am not a multi-language person. It would be a intersting question for multi language users if it would be useful to have a flag on wine to tag LANG flags into .desktop files. Possibly something in prefix create. Since I am not a multi-language person I cannot bug/feature request this.


Top 
 Post Posted: Fri Nov 22, 2013 11:27 am 
Offline
Level 1
Level 1

Joined: Tue Nov 12, 2013 2:08 pm
Posts: 8
oiaohm, sorry, I was very busy this week and couldn't answer until today. I will report a bug or do a feature request as you suggest (I'll very glad, because it will be my first contribution to this community), but I'm not sure yet what causes the problem because the LANG (and LC_ALL) parameter doesn't appears to fix the problem anymore. I'm without tildes again.
As the problem reappears when I updated the system today, I supposed it could be a problem of Ubuntu. I tried to follow the Otto Kekäläinen instructions here http://askubuntu.com/questions/162391/h ... cale-issue, but with no success.
When I ran the "locale" command, the output was:
    LANG=en_US.UTF-8
    LANGUAGE=en_US:en
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC=es_CO.UTF-8
    LC_TIME=es_CO.UTF-8
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY=es_CO.UTF-8
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER=es_CO.UTF-8
    LC_NAME=es_CO.UTF-8
    LC_ADDRESS=es_CO.UTF-8
    LC_TELEPHONE=es_CO.UTF-8
    LC_MEASUREMENT=es_CO.UTF-8
    LC_IDENTIFICATION=es_CO.UTF-8
    LC_ALL=
Also, I ran
    sudo locale-gen es_ES.UTF-8
    sudo dpkg-reconfigure locales
But the problem persists.
As I say before, the tilde works for all native Linux programs; it's missing only in ms office and just in the workarea. I'm thinking again it's a Wine problem, but I don't know yet where I must look or how I can workaround it.
Thank you very much for your help.


Top 
 Post Posted: Fri Nov 22, 2013 11:45 am 
Offline
Level 1
Level 1

Joined: Tue Nov 12, 2013 2:08 pm
Posts: 8
A quick update: I found a workaround.
I changed an option of the "Language Support" dialog of Ubuntu: In "Keyboard input method system" I selected "none" instead of "IBus" and restarted the system. Now the tildes returns to ms office.
However, I noticed that the ctrl+shift+u shortcut (used to introduce Unicode characters) doesn't work now (I don't know if it was functional before).
Maybe that offers a clue about what's happening.
I appreciate any help.


Top 
 Post Posted: Thu Jan 02, 2014 3:17 pm 
Offline
Newbie
Newbie

Joined: Thu Jan 02, 2014 3:09 pm
Posts: 2
Having the same problem with wine 1.7.2-2.1 on opensuse 13.1 and office 2007.

A workaround I found was change the windows version on winecfg from windows XP to windows 7.

A downside is the save file dialog now crashes.

Att.


Top 
 Post Posted: Fri Jan 03, 2014 3:26 am 
Offline
Level 8
Level 8

Joined: Fri Feb 29, 2008 2:54 am
Posts: 1020
rafael_guarana Really your instructions are how to break MS Office 2007.

Its the language setting causing the problems. Windows 7 implements more UTF so closer to Linux. Problem is items like save dialogs in 2007 break.


Top 
 Post Posted: Wed Jan 08, 2014 1:13 pm 
Offline
Level 1
Level 1

Joined: Tue Nov 12, 2013 2:08 pm
Posts: 8
rafael_guarana wrote:
Having the same problem with wine 1.7.2-2.1 on opensuse 13.1 and office 2007.


Hello Rafael. If you have the same problem with OpenSuse, maybe it's not an Ubuntu or Wine related bug, as I thought before.
Now, as the tildes works when I disabled IBus, I guess the problem is related to this package.
May I ask you if you are using IBus too? If yes, which version have you installed?
In Ubuntu 13.10 I'm using IBus 1.5.3-6. (I installed Synaptic to check the version, but I don't know the OpenSuse equivalent).
If you are using IBus, please try to to disable it and check if the deadkeys works. If yes, probably the problem is it.
Please, tell me.
It could be related whit these bugs:
http://code.google.com/p/ibus/issues/detail?id=526
https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/923869
https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/335732


rafael_guarana wrote:
A workaround I found was change the windows version on winecfg from windows XP to windows 7.

A downside is the save file dialog now crashes.


Your workaround works for me exactly as you describe.
Thank you very much.


Top 
 Post Posted: Wed Jan 08, 2014 8:46 pm 
Offline
Level 8
Level 8

Joined: Fri Feb 29, 2008 2:54 am
Posts: 1020
Code:
unset XMODIFIERS

Doing the above before running wine is worth a shot. Goghard simpler than uninstalling.
Do remember to pass as directed wine the right language.

http://en.wikipedia.org/wiki/Unicode_in ... ariants.29
Sorry to day Unicode inputting on Linux/X11 systems is horrible there are 5 different methods and it depends on the X11 server and the application what one of the 5 works. Yes they appear to list 2 on the wikipedia but if you look closer is 5. Yes the second one with enter space shift ctrl are all independent methods. It is possible for none of them to be working. I really do recommend testing unicode in something native Linux and basic like a terminal.

So we now have three levels of nightmare.
    1 Wine own internal language setting(wrong deadkeys don't work)
    2 X11 XKB language setting(wrong X11 can be consuming the dead keys for something else)
    3 Ibus confusion(I eat deadkeys for lunch a lot)
Goghard the fact disabling or removing Ibus fixes I would say yes all 3 bugs you found are related.

Goghard when I say break do fear. Crashing MS Office 2007 in the save dialogue repeatedly can end up with normal.dot stuffed up to the point word will not start. So rafael_guarana work around is truly don't do this you are rolling a dice and it will break at some point.

Disabling ibus, setting language right both don't result in really bad outcomes.


Top 
 Post Posted: Tue Jan 14, 2014 4:29 pm 
Offline
Level 1
Level 1

Joined: Tue Nov 12, 2013 2:08 pm
Posts: 8
Oiaohm, really the problem seems like a nightmare! Now I think it exceeds my knowledge level, but I really appreciate your explanations. Thanks :)

I think rafael_guarana was clear about his workaround makes MS Office crash and I was just saying that it crashes the same way in my system. Anyway, you are right: it will break MS Office at some point.

Disabling iBus works for me, and I hope it works for someone else.


Top 
 Post Posted: Tue Feb 18, 2014 5:46 pm 
Offline
Newbie
Newbie

Joined: Thu Jan 02, 2014 3:09 pm
Posts: 2
oiaohm wrote:
Code:
unset XMODIFIERS

Doing the above before running wine is worth a shot. Goghard simpler than uninstalling.
Do remember to pass as directed wine the right language.

http://en.wikipedia.org/wiki/Unicode_in ... ariants.29
Sorry to day Unicode inputting on Linux/X11 systems is horrible there are 5 different methods and it depends on the X11 server and the application what one of the 5 works. Yes they appear to list 2 on the wikipedia but if you look closer is 5. Yes the second one with enter space shift ctrl are all independent methods. It is possible for none of them to be working. I really do recommend testing unicode in something native Linux and basic like a terminal.

So we now have three levels of nightmare.
    1 Wine own internal language setting(wrong deadkeys don't work)
    2 X11 XKB language setting(wrong X11 can be consuming the dead keys for something else)
    3 Ibus confusion(I eat deadkeys for lunch a lot)
Goghard the fact disabling or removing Ibus fixes I would say yes all 3 bugs you found are related.

Goghard when I say break do fear. Crashing MS Office 2007 in the save dialogue repeatedly can end up with normal.dot stuffed up to the point word will not start. So rafael_guarana work around is truly don't do this you are rolling a dice and it will break at some point.

Disabling ibus, setting language right both don't result in really bad outcomes.



It works!!!

Thanks oiaohm. I used this command above to launch word.

Code:
env XMODIFIERS='' WINEPREFIX="/home/rafael/.wine" wine "C:\Arquivos de programas\Microsoft Office\Office12\WINWORD.EXE"


Just change the path to winword.exe, as I am using pt-br version of word.

Goghard, I have ibus-1.5.4-8.1.x86_64 installed. Standard gnome opensuse installation.


Top 
 Post Posted: Sat Feb 22, 2014 7:08 pm 
Offline
Level 1
Level 1

Joined: Tue Nov 12, 2013 2:08 pm
Posts: 8
rafael_guarana wrote:

Code:
env XMODIFIERS='' WINEPREFIX="/home/rafael/.wine" wine "C:\Arquivos de programas\Microsoft Office\Office12\WINWORD.EXE"


Just change the path to winword.exe, as I am using pt-br version of word.

Goghard, I have ibus-1.5.4-8.1.x86_64 installed. Standard gnome opensuse installation.


I confirm it works in Ubuntu 13.10!!!
I have my iBus enabled again and can write tildes in MSO
Thank you Rafael_guarana, and thank you too Oiaohm.
FLOSS are awesome. :D


Top 
 Post Posted: Mon Apr 21, 2014 10:54 pm 
Offline
Newbie
Newbie

Joined: Mon Apr 21, 2014 9:51 pm
Posts: 1
Hi all,

Sorry for my bad english.
I have the same problem with Ubuntu 14.04, Wine 1.6.2 and ms office 2010. When I introduce the code:
env XMODIFIERS='' WINEPREFIX="/home/mac/.wine" wine "C:\Program Files\Microsoft Office\Office14\WINWORD.EXE", Word is launched automatically and you can enter the accents on vowels, but if you close Word and try openning with Wine a existing Word file, the problem arises again.
What should I do to fix the problem permanently?

Thanks


Top 
 Post Posted: Tue Apr 22, 2014 11:34 pm 
Offline
Level 8
Level 8

Joined: Fri Feb 29, 2008 2:54 am
Posts: 1020
Mac2. The fix listed here only fixes if you directly run wine with it.

To be able to click and open a .doc file or so on you will have to modify the file assocation.

~/.local/share/applications in this directory you will find wine-extension-doc.desktop and so on. You will see a exec= wine in these files. XMODIFIERS="" add and problem will be hidden better.

There is also the memu entries as well


Top 
 Post Posted: Sat Aug 30, 2014 9:45 am 
Offline
Newbie
Newbie

Joined: Sat Aug 30, 2014 9:35 am
Posts: 1
Quote:
Thanks oiaohm. I used this command above to launch word.

Code:
env XMODIFIERS='' WINEPREFIX="/home/rafael/.wine" wine "C:\Arquivos de programas\Microsoft Office\Office12\WINWORD.EXE"


Just change the path to winword.exe, as I am using pt-br version of word.

Goghard, I have ibus-1.5.4-8.1.x86_64 installed. Standard gnome opensuse installation.


I confirm it works in ubuntu 14.04, wine 1.7.25 and MS Office 2010.

I also modified all the MS Office .desktop files in
.local/share/applications
.local/share/applications/wine/Programs/Microsoft\ Office/Herramientas\ de\ Microsoft\ Office\ 2010/
.local/share/applications/wine/Programs/Microsoft\ Office/Microsoft\ Office\ 2010\ Tools/

and add XMODIFIERS='' to the Exec line

Thank you guys.


Top 
 Post Posted: Sun Aug 31, 2014 11:29 am 
Offline
Newbie
Newbie

Joined: Sun Aug 31, 2014 11:20 am
Posts: 1
I was having the same problem running PDFXChange Viewer 2.5 under Ubuntu 14.04 with a 32-bit Wine 1.6.2 prefix installed via Playonlinux.

Firing the program with
Code:
env XMODIFIERS='' WINEPREFIX="/home/rafael/PlayOnLinux's virtual drives/PDF_Viewer' wine "/home/rafael/PlayOnLinux's virtual drives/PDF_Viewer/drive_c/Program Files/Tracker Software/PDF Viewer/PDFXCview.exe"
solved the issue.

To incorporate the solution to my install, I've tweaked Playonlinux's options in the following way: in the prefix's options, I selected the "Miscellaneous" tab and in the field "Commands to exec before running the program" I entered
Code:
XMODIFIERS=''


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 19 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: No registered users and 9 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: