Font anti-aliasing does not work...

Questions about Wine on Linux
Locked
etwineb
Level 4
Level 4
Posts: 101
Joined: Wed Dec 10, 2008 12:05 pm

Font anti-aliasing does not work...

Post by etwineb » Tue Jul 30, 2013 6:58 am

In the whole system the fonts are antialiased and instead in wine they are sharp. Unfortunately my monitor is fairly bad showing sharp fonts and so it is really hard to read.

I tried winetricks fontsmooth=gray, but it seems having no effects.
I tried installing tahoma and liberation fonts as my system configuration should replace fonts with their metric equivalent free variants, the winecfg font DID change, but it is not antialiased.

It is a bug? I am missing something? What can I try?

User avatar
dimesio
Moderator
Moderator
Posts: 12671
Joined: Tue Mar 25, 2008 10:30 pm

Re: Font anti-aliasing does not work...

Post by dimesio » Tue Jul 30, 2013 8:34 am

Wine version? If it's not 1.6, upgrade. There have been changes to how Wine handles font smoothing since 1.4. If this is a problem in 1.6, you may be seeing one of these bugs:
http://bugs.winehq.org/show_bug.cgi?id=23097
http://bugs.winehq.org/show_bug.cgi?id=23114
http://bugs.winehq.org/show_bug.cgi?id=31393

etwineb
Level 4
Level 4
Posts: 101
Joined: Wed Dec 10, 2008 12:05 pm

Re: Font anti-aliasing does not work...

Post by etwineb » Tue Jul 30, 2013 10:34 am

I am using wine 1.6, and it looks like Bug 23114... oh well.

Edit:
Reading the comments it seems that

Code: Select all

xrdb -query | grep -vE 'Xft\.(anti|hint|rgba)' | xrdb
Solves the problem, I am not sure why yet...

Locked