Assassin's Creed 1 & Nouveau Drivers + Wine 1.5.3-Ubisoft2

Questions about Wine on Linux
Locked
touchez
Level 1
Level 1
Posts: 8
Joined: Sat Oct 16, 2010 4:55 am

Assassin's Creed 1 & Nouveau Drivers + Wine 1.5.3-Ubisoft2

Post by touchez » Mon Feb 18, 2013 12:43 pm

Hello all,

It does a couple of days that i search a solution.
My issue is why Assassin's Creed doesn't work ?
-> Intro = OK !
-> Setup menu = Loaded but no texture (all is "crypted" but i can see the shape of the elements).

DESCRIPTION OF MY SITUATION

Older hard drive with :
december 2011 Gentoo version
< 4 version of PlayonLinux & Wine 1.3.?-ubisoft
Nvidia drivers.

All my games work fine (All Half Life2's Mods, Age of Empire 2 & 3, Demigod, ... Assassin's Creed)

New hard drive :
All new and last ; Gentoo version, last stable kernel, Xorg and more ...
I have fallowed the handbook and specific how to for Xorg.

PROFILE :
Kernel -> 3.6.11-gentoo
GPU -> VGA compatible controller: NVIDIA Corporation G84 [GeForce 8600 GT]
Ennemy Territory true combat -> work fine !

$ eselect mesa list
64bit i915 (Intel 915, 945)
64bit i965 (Intel 965, G/Q3x, G/Q4x)
64bit r300 (Radeon R300-R500)
64bit r600 (Radeon R600-R700, Evergreen, Northern Islands)
64bit sw (Software renderer)
[1] classic
[2] gallium *
32bit i915 (Intel 915, 945)
[1] classic
[2] gallium *
32bit i965 (Intel 965, G/Q3x, G/Q4x)
[1] classic *
32bit r300 (Radeon R300-R500)
[1] gallium *
32bit r600 (Radeon R600-R700, Evergreen, Northern Islands)
[1] gallium *
32bit sw (Software renderer)
[1] classic
[2] gallium *

$ eselect opengl list
Available OpenGL implementations:
[1] xorg-x11 *
Here the log with the debug tool from PlayonLinux.

$ glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
...
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
...
OpenGL vendor string: nouveau
OpenGL renderer string: Gallium 0.4 on NV84
OpenGL version string: 3.0 Mesa 9.0.1
OpenGL shading language version string: 1.30
...

$ glxinfo | grep rend
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on NV84
GL_NV_conditional_render, GL_AMD_conservative_depth,



LOG FROM PLAYONLINUX

Code: Select all

ce_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
                                  ...
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:wininet:set_cookie persistent cookies not handled (L"expires=Sat, 18-Feb-2113 16:48:37 GMT; path=/")
fixme:wininet:set_cookie persistent cookies not handled (L"expires=Sat, 18-Feb-2113 16:48:37 GMT; path=/t, 18-Feb-2113 16:48:37 GMT; path=/")
[color=#804000]fixme:d3d:getColorBits Unsupported format WINED3DFMT_R16G16_UNORM.
fixme:d3d:getColorBits Unsupported format WINED3DFMT_R16G16B16A16_UNORM.
fixme:d3d:getColorBits Unsupported format WINED3DFMT_R16G16_UNORM.
fixme:d3d:getColorBits Unsupported format WINED3DFMT_R16G16B16A16_UNORM.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:getColorBits Unsupported format WINED3DFMT_R16G16_UNORM.
fixme:d3d:getColorBits Unsupported format WINED3DFMT_R16G16B16A16_UNORM.[/color]
fixme:dsound:IDirectSoundBufferImpl_AcquireResources (0x30557b0,00000000,0,(nil)): stub, faking success
fixme:dsound:IDirectSoundBufferImpl_AcquireResources (0x21ead0,00000000,0,(nil)): stub, faking success
fixme:dsound:IDirectSoundBufferImpl_AcquireResources (0x305f068,00000000,0,(nil)): stub, faking success
fixme:dsound:IDirectSoundBufferImpl_AcquireResources (0x305a408,00000000,0,(nil)): stub, faking success
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.

QUESTION 2 : my eselect mesa list doesnt' display Nvidia card !!! why ?

User avatar
dimesio
Moderator
Moderator
Posts: 12898
Joined: Tue Mar 25, 2008 10:30 pm

Re: Assassin's Creed 1 & Nouveau Drivers + Wine 1.5.3-Ubisof

Post by dimesio » Tue Feb 19, 2013 8:26 am

touchez wrote: QUESTION 2 : my eselect mesa list doesnt' display Nvidia card !!! why ?
Ask your distro. That's not a Wine question.

Try the Nvidia proprietary driver.

You are also using an old version of Wine. Upgrade to the latest development release of plain Wine--no PlayOnLinux.

touchez
Level 1
Level 1
Posts: 8
Joined: Sat Oct 16, 2010 4:55 am

Re: Assassin's Creed 1 & Nouveau Drivers + Wine 1.5.3-Ubisof

Post by touchez » Fri Feb 22, 2013 7:46 am

Thanks Dimesio,

Ask your distro. That's not a Wine question.
Ok it's logical.

Try the Nvidia proprietary driver.
About Nvidia drivers i suppose that is the solution, but i want to try to use 'Nouveau' driver with DirectX.
To use Nvidia drivers, i have to build all package with new gcc option and with new kernel option ...


You are also using an old version of Wine. Upgrade to the latest development release of plain Wine--no PlayOnLinux.
Ok but does the last wine version have directX and nouveau fix ?
To me it's the issue.
If i have the time i will try to install an other game and tell you what append, to know if the bug is between wine and directx the or only with "Assassin's creed game" *


*Enemy territory is a linux version full OpenGl compatible ...

User avatar
dimesio
Moderator
Moderator
Posts: 12898
Joined: Tue Mar 25, 2008 10:30 pm

Re: Assassin's Creed 1 & Nouveau Drivers + Wine 1.5.3-Ubisof

Post by dimesio » Fri Feb 22, 2013 9:03 am

There have been many directx patch committed since 1.5.3; the only way to find out whether any of them fix your problem is to test it. As for nouveau fixes, that's up to the nouveau developers. If you're really committed to using it you should be using their latest development release, too, and file bugs with them for any problems.

touchez
Level 1
Level 1
Posts: 8
Joined: Sat Oct 16, 2010 4:55 am

Re: Assassin's Creed 1 & Nouveau Drivers + Wine 1.5.3-Ubisof

Post by touchez » Sun Feb 24, 2013 8:42 am

I agree to contact my distro support and Nouveau too.
I have test 'Jedy Knight Academy' and it work very well, but it is not a game which use all new 3d technology.

Thx for yours answers and your time.

I will search again a solution and i will post it here.

Locked