Cannot install DotNet20

Questions about Wine on Linux
Locked
Slovenijakp
Level 1
Level 1
Posts: 7
Joined: Mon Jan 21, 2013 2:20 pm

Cannot install DotNet20

Post by Slovenijakp » Mon Jan 21, 2013 2:29 pm

I tried to install .NET Framework 2.0 (x64) and I get an error after accepting agreement.
[Microsoft .NET Framework 2.0 (x64) has encountered a problem during setup. Setup did not complete correctly.]

Here is terminal log:

Code: Select all

[slovenijakp@Slovenijakp-PC ~]$ bash winetricks dotnet20
Executing w_do_call dotnet20
Executing load_dotnet20
Executing w_do_call remove_mono
Executing load_remove_mono
------------------------------------------------------
Mono does not appear to be installed.
------------------------------------------------------
Executing w_do_call fontfix
Executing load_fontfix
Setting Windows version to win2k
Executing winetricks_early_wine regedit C:\windows\Temp\_dotnet20\set-winver.reg
Current wine does not have wine bug 10467, so not applying workaround
Current wine does not have wine bug 30845, so not applying workaround
------------------------------------------------------
Working around wine bug 30845 -- Using native fusion while installing...
------------------------------------------------------
Executing env WINEDLLOVERRIDES=mscoree,fusion=n wine dotnetfx.exe
fixme:advapi:DecryptFileA "C:\\users\\slovenijakp\\Temp\\IXP000.TMP\\" 00000000
p11-kit: couldn't load module: /usr/lib/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
fixme:heap:HeapSetInformation 0x2c4000 0 0x23fce0 4
fixme:heap:HeapSetInformation 0x54c000 0 0x23ee10 4
fixme:advapi:LsaOpenPolicy ((null),0x23eda0,0x00000001,0x23ed70) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:ntdll:NtFlushInstructionCache 0xffffffffffffffff 0x280fe0 22
fixme:ntdll:NtFlushInstructionCache 0xffffffffffffffff 0x280fe0 22
fixme:ntdll:NtFlushInstructionCache 0xffffffffffffffff 0x280fc0 22
fixme:ntdll:NtFlushInstructionCache 0xffffffffffffffff 0x280fc0 22
fixme:heap:HeapSetInformation 0x760000 0 0x23df20 4
fixme:ntdll:NtFlushInstructionCache 0xffffffffffffffff 0x280fa0 22
fixme:ntdll:NtFlushInstructionCache 0xffffffffffffffff 0x280fa0 22
fixme:ntdll:NtFlushInstructionCache 0xffffffffffffffff 0x280f80 22
fixme:ntdll:NtFlushInstructionCache 0xffffffffffffffff 0x280f60 22
fixme:ntdll:NtFlushInstructionCache 0xffffffffffffffff 0x280f60 22
fixme:ntdll:NtFlushInstructionCache 0xffffffffffffffff 0x280f40 22
fixme:ntdll:NtFlushInstructionCache 0xffffffffffffffff 0x280f40 22
fixme:ntdll:NtFlushInstructionCache 0xffffffffffffffff 0x280f20 22
fixme:storage:create_storagefile Storage share mode not implemented.
fixme:ntdll:NtFlushInstructionCache 0xffffffffffffffff 0x280f00 22
fixme:ntdll:NtFlushInstructionCache 0xffffffffffffffff 0x280f00 22
fixme:heap:HeapSetInformation 0x132c000 0 0x75d0b0 4
err:msi:ITERATE_Actions Execution halted, action L"CA_Check64OS.3643236F_FC70_11D3_A536_0090278A1BB8" returned 1603
fixme:imm:ImmDisableIME (-1): stub
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:richedit:ME_HandleMessage EM_SETMARGINS: stub
fixme:richedit:ME_HandleMessage EM_SETMARGINS: stub
err:ole:CoUninitialize Mismatched CoUninitialize
err:ole:CoUninitialize Mismatched CoUninitialize
------------------------------------------------------
Note: command 'env WINEDLLOVERRIDES=mscoree,fusion=n wine dotnetfx.exe' returned status 67.  Aborting.
------------------------------------------------------
If you look at the log, it says Mono not installed. In fact, it is installed.
I use Fedora 17 x64 and WINE 1.4.1.

I would be very happy if someone helped me.
Slovenijakp :)

User avatar
dimesio
Moderator
Moderator
Posts: 12898
Joined: Tue Mar 25, 2008 10:30 pm

Re: Cannot install DotNet20

Post by dimesio » Mon Jan 21, 2013 3:55 pm


Slovenijakp
Level 1
Level 1
Posts: 7
Joined: Mon Jan 21, 2013 2:20 pm

Re: Cannot install DotNet20

Post by Slovenijakp » Tue Jan 22, 2013 7:37 am

Okay, I see it's a bug present in old WINE version (still not fixed?).
Is there any workaround or I can't do nothing about it? :(

User avatar
dimesio
Moderator
Moderator
Posts: 12898
Joined: Tue Mar 25, 2008 10:30 pm

Re: Cannot install DotNet20

Post by dimesio » Tue Jan 22, 2013 7:57 am

Comment 7 in the bug report mentions
This does _not_ happen if the installer is directly started as 64-bit process
using 'wine64' (in shared WoW64).
You could try doing that.

Slovenijakp
Level 1
Level 1
Posts: 7
Joined: Mon Jan 21, 2013 2:20 pm

Re: Cannot install DotNet20

Post by Slovenijakp » Tue Jan 22, 2013 9:04 am

Thanks, I'll try it later.

Slovenijakp
Level 1
Level 1
Posts: 7
Joined: Mon Jan 21, 2013 2:20 pm

Re: Cannot install DotNet20

Post by Slovenijakp » Wed Jan 23, 2013 2:44 pm

If I run it in wine64, it says I need to download Wine Gecko. Downloaded Wine Gecko .msi...

Code: Select all

wine: Bad EXE format for Z:\home\slovenijakp\wine_gecko-1.9-x86.msi.
Tried to run it in wine64... It says Wine Gecko needs Wine Gecko for its installation.
-_-

User avatar
core
Level 3
Level 3
Posts: 84
Joined: Tue Oct 23, 2012 6:22 am

Re: Cannot install DotNet20

Post by core » Wed Jan 23, 2013 5:13 pm

Slovenijakp wrote:If I run it in wine64, it says I need to download Wine Gecko. Downloaded Wine Gecko .msi...

Code: Select all

wine: Bad EXE format for Z:\home\slovenijakp\wine_gecko-1.9-x86.msi.
Tried to run it in wine64... It says Wine Gecko needs Wine Gecko for its installation.
-_-
Maybe, because you should try to install this one - wine_gecko-1.9-x86_64.msi

Locked