Prevent Wine from Seeing My Network Drive

Questions about Wine on Linux
Locked
jakfish
Newbie
Newbie
Posts: 3
Joined: Fri Jan 18, 2013 7:27 am

Prevent Wine from Seeing My Network Drive

Post by jakfish » Fri Jan 18, 2013 8:04 am

Lubuntu 12.04LTS, Wine 1.4/Gecko on Lenovo S10-3t

Hello, All,

My XP shared directory is mounted via fstab, but when I disable my wifi (for battery savings) and then start Word 97, Word hangs on the splash screen until I reactivate wifi.

For a while, I thought this was a Gecko issue, but in Wine Config/Drives/Drive Mapping, I see my network share listed as E: /mnt/efile.

I can remove it, but Wine finds it again upon reboot.

How can I tell Wine to ignore all network drives?

Much obliged for any assistance,
Jake

User avatar
dimesio
Moderator
Moderator
Posts: 12898
Joined: Tue Mar 25, 2008 10:30 pm

Re: Prevent Wine from Seeing My Network Drive

Post by dimesio » Fri Jan 18, 2013 3:58 pm

You can delete the z: drive, either manually or with winetricks sandbox. Note this will make everything outside that wineprefix inaccessible to all apps in it, and some apps may not work properly.

jakfish
Newbie
Newbie
Posts: 3
Joined: Fri Jan 18, 2013 7:27 am

Re: Prevent Wine from Seeing My Network Drive

Post by jakfish » Sat Jan 19, 2013 2:27 am

Many thanks for your response. I did remove the z: drive, which--as you had warned--shut down a needed directory. So I put back the z: drive.

However, before this, for testing procedures, I also removed the drive of the network share. But removing z: and e: didn't prevent the freezing of Word 97's startup with the wifi turned off.

Do you think an fstab mounting of the network share transcends any handle-jiggling in winecfg? (I use an fstab mount so I don't have the hassle of doing the sudo mount in terminal.)

Thanks again for your help,
Jake

Locked