Running .net 4.0 VB application

Questions about Wine on Linux
Locked
timberwolf
Level 2
Level 2
Posts: 19
Joined: Sun Dec 30, 2012 1:01 pm

Running .net 4.0 VB application

Post by timberwolf » Thu Jan 17, 2013 6:05 pm

When I use the desktop file to run it it shows its loading for a few moments then nothing. When I use Konsole to run the command from the desktop file I get:
root@PAT-PC:~# env WINEPREFIX="/root/.wine" wine C:\\windows\\command\\start.exe /Unix /root/.wine/dosdevices/c:/users/Public/Desktop/Helpfulbatchfiles\ Download\ Manager.lnk
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
fixme:exec:SHELL_execute flags ignored: 0x00000100
err:exec:shellex_load_object_and_run failed to get data object
I have mono installed, I tried using "winetricks dotnet40" but that failed worse, producing more errors. What do I do?

timberwolf
Level 2
Level 2
Posts: 19
Joined: Sun Dec 30, 2012 1:01 pm

Re: Running .net 4.0 VB application

Post by timberwolf » Thu Jan 17, 2013 7:38 pm

Just tried "bash winetricks -q dotnet40" then running the application and got the same error but without the font warning.

User avatar
dimesio
Moderator
Moderator
Posts: 12894
Joined: Tue Mar 25, 2008 10:30 pm

Re: Running .net 4.0 VB application

Post by dimesio » Thu Jan 17, 2013 10:24 pm

timberwolf wrote:
root@PAT-PC:~# env WINEPREFIX="/root/.wine" wine C:\\windows\\command\\start.exe /Unix /root/.wine/dosdevices/c:/users/Public/Desktop/Helpfulbatchfiles\ Download\ Manager.lnk
Never run Wine as root. http://wiki.winehq.org/FAQ#run_as_root

As for .NET 4.0, it will sort of install with winetricks, but doesn't really work.

timberwolf
Level 2
Level 2
Posts: 19
Joined: Sun Dec 30, 2012 1:01 pm

Re: Running .net 4.0 VB application

Post by timberwolf » Fri Jan 18, 2013 6:58 pm

I only run what i know is not viruses. Such as EVE Online, a program that I helped make (The VB App I am trying to run), other mmo's. I use my root account, thats the point of linux - power over my OS. For me at least. What do you suggest I use to run my .NET 4.0 app?

timberwolf
Level 2
Level 2
Posts: 19
Joined: Sun Dec 30, 2012 1:01 pm

Re: Running .net 4.0 VB application

Post by timberwolf » Fri Jan 18, 2013 8:50 pm

bump

User avatar
dimesio
Moderator
Moderator
Posts: 12894
Joined: Tue Mar 25, 2008 10:30 pm

Re: Running .net 4.0 VB application

Post by dimesio » Fri Jan 18, 2013 10:07 pm

Retest as a normal user in a clean wineprefix in 1.5.22 with wine-mono installed following these instructions for running apps from the command line: http://wiki.winehq.org/FAQ#run_from_terminal.

timberwolf
Level 2
Level 2
Posts: 19
Joined: Sun Dec 30, 2012 1:01 pm

Re: Running .net 4.0 VB application

Post by timberwolf » Sat Jan 19, 2013 11:25 am

has the EVE bug been fixed in 1.5.22? Because EVE Online trumps this program.

timberwolf
Level 2
Level 2
Posts: 19
Joined: Sun Dec 30, 2012 1:01 pm

Re: Running .net 4.0 VB application

Post by timberwolf » Sat Jan 19, 2013 12:49 pm

Output of: wine "Program Name.exe"
http://pastebin.com/kh9CLcqM


tested on 1.5.22

timberwolf
Level 2
Level 2
Posts: 19
Joined: Sun Dec 30, 2012 1:01 pm

Re: Running .net 4.0 VB application

Post by timberwolf » Sat Jan 19, 2013 4:29 pm

bump

User avatar
dimesio
Moderator
Moderator
Posts: 12894
Joined: Tue Mar 25, 2008 10:30 pm

Re: Running .net 4.0 VB application

Post by dimesio » Sat Jan 19, 2013 7:38 pm

File a bug.

Locked