Wine 1.5.18 and Atmel AVR Studio.

Questions about Wine on Linux
Locked
darzur
Newbie
Newbie
Posts: 3
Joined: Fri Dec 14, 2012 5:57 am

Wine 1.5.18 and Atmel AVR Studio.

Post by darzur » Fri Dec 14, 2012 6:11 am

Hello to everyone,

It's my first post here. I'm total noob in wine (and in Linux too) so sorry if I post in wrong place. After latest update to Wine 1.5.19 my Atmel AVR Studio 4.19 stopped working. It shows following error on launch:

"framework class: error while connecting to ROT: (some number here)"

and then force closes. I've goggled a bit and it looks this problem is not necessarily related to Wine and it appears on Windows too. From what I found is related to XML which has been in some way changed/updated in 1.5.19. For now I returned back to 1.5.18 and everything works fine, but it will be good to know if there are some workaround to use latest Wine version.

My system is Mint 13 Mate 1.4 x86.

User avatar
dimesio
Moderator
Moderator
Posts: 12898
Joined: Tue Mar 25, 2008 10:30 pm

Re: Wine 1.5.18 and Atmel AVR Studio.

Post by dimesio » Fri Dec 14, 2012 9:47 am

What I get from googling is that this problem only occurs in Windows when the XML parser is missing or not configured properly, so if it is occurring in Wine, that suggests a deficiency in Wine's XML parser.

Run a regression test and file a bug. http://wiki.winehq.org/RegressionTesting

User avatar
André H.
Moderator
Moderator
Posts: 202
Joined: Sun Dec 07, 2008 8:33 am
Location: Germany
Contact:

Re: Wine 1.5.18 and Atmel AVR Studio.

Post by André H. » Sat Dec 15, 2012 4:22 pm

Yes, you should file a bug. A regression test is maybe not needed in case Nikolay finds the problem.

darzur
Newbie
Newbie
Posts: 3
Joined: Fri Dec 14, 2012 5:57 am

Re: Wine 1.5.18 and Atmel AVR Studio.

Post by darzur » Sun Dec 16, 2012 4:21 am

I've just submitted a bug without regression testing. I don't even know how to do it, so I hope it will not be necessary.

darzur
Newbie
Newbie
Posts: 3
Joined: Fri Dec 14, 2012 5:57 am

Re: Wine 1.5.18 and Atmel AVR Studio.

Post by darzur » Sun Dec 16, 2012 8:00 am

Problem solved. Cause of bug was missing mfc42.dll although it was not a problem in 1.5.18.

User avatar
André H.
Moderator
Moderator
Posts: 202
Joined: Sun Dec 07, 2008 8:33 am
Location: Germany
Contact:

Re: Wine 1.5.18 and Atmel AVR Studio.

Post by André H. » Sun Dec 16, 2012 9:20 am

The bug Url/Nr. would have been usefull here:
http://bugs.winehq.org/show_bug.cgi?id=32459

studyembedded
Newbie
Newbie
Posts: 1
Joined: Sun Feb 24, 2013 8:18 am

Re: Wine 1.5.18 and Atmel AVR Studio.

Post by studyembedded » Sun Feb 24, 2013 8:21 am

Just check this http://www.zembedded.com/ IT seems they have good tutorial on AVR and Linux

Locked