The Witcher Enchanced Edition missing characters' textures

Questions about Wine on Linux
Locked
shohart
Newbie
Newbie
Posts: 4
Joined: Tue Sep 11, 2012 7:55 am

The Witcher Enchanced Edition missing characters' textures

Post by shohart » Tue Sep 11, 2012 8:17 am

Hello everyone!
i installed TWEE using wine 1.5.11
game installs, runs, but in the game all the characters are invisible excrpt of their wearpoons and parts of faces.
restarting the game/rebootng makes no help.
i am using Nvidia 610M graphics for laptops, with latest nvidia proprietary drivers and bumblebee.
what am i doing wrong?

shohart
Newbie
Newbie
Posts: 4
Joined: Tue Sep 11, 2012 7:55 am

Re: The Witcher Enchanced Edition missing characters' textur

Post by shohart » Wed Sep 12, 2012 2:57 am

when i launch witcher, i got theese lines many times in console output:

fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
err:d3d:resource_unload Resource 0x2a95cb78 is being unloaded while mapped.

and this one single time

err:d3d:wined3d_wndproc Window 0x20022 is not registered with win
it is obviously a directX problem, but how to fix it?

Mateusz Stachowski
Level 3
Level 3
Posts: 71
Joined: Mon Apr 18, 2011 3:49 am

Re: The Witcher Enchanced Edition missing characters' textur

Post by Mateusz Stachowski » Wed Sep 12, 2012 12:57 pm

The Witcher needs d3dx9_36 dll override to work properly. You can install it with winetricks.

winetricks d3dx9_36

shohart
Newbie
Newbie
Posts: 4
Joined: Tue Sep 11, 2012 7:55 am

Re: The Witcher Enchanced Edition missing characters' textur

Post by shohart » Thu Sep 13, 2012 3:23 am

Mateusz Stachowski wrote:The Witcher needs d3dx9_36 dll override to work properly. You can install it with winetricks.

winetricks d3dx9_36
i have all the d3dx9_* dll's installed including d3dx9_36.
but thanx for answer.

shohart
Newbie
Newbie
Posts: 4
Joined: Tue Sep 11, 2012 7:55 am

Re: The Witcher Enchanced Edition missing characters' textur

Post by shohart » Sun Sep 16, 2012 6:57 am

so it seems that Linux Magic helped me.
first time i used console (guake to be precise) to run POL with optirun and got the discribed result. second time i used console again to run witcher directly with optirun and system wine. then i wroght a script
optirun wine "/home/shohart/.wine/drive_c/Program Files/The Witcher.Gold Edition/System/witcher.exe"
and run it with gmrun.
and it works! all the models appeared finally!
thanx everyone for help!

Locked