Darksiders II (Steam) for Wine 1.5.11 (patched)...it works!

Questions about Wine on Linux
Locked
rboxeur
Level 2
Level 2
Posts: 29
Joined: Sun Jul 15, 2012 3:23 pm
Contact:

Darksiders II (Steam) for Wine 1.5.11 (patched)...it works!

Post by rboxeur » Sun Sep 09, 2012 7:32 pm

Hi,

Since submitting a test for a game or a application must be done for a unmodified version of wine, I open this topic hoping it could be useful for NVIDIA users.

NOTICE: THE FOLLOWING NOTES APPLY FOR DARKSIDERS II PATCH #3

YOUTUBE VIDEO FOR PLAYABLE SETTINGS
==========================
Go to

http://youtu.be/F_gA7RmA3n8

WINE 1.5.11
============

Download Wine sources for 1.5.11 version

wget -q http://mirrors.ibiblio.org/wine/source/ ... 11.tar.bz2

Uncompress

tar xjf wine-1.5.11.tar.bz2

PATCHES FOR WINE
================

You weed to download/apply the following patches

- RawInput Patch so the game can start else the game can't start up.

- Crysis 2 Double Buffer Patch: Crysis Double Buffer patch. This is the magical patch so I could bypass the error for CODEREVIEW

cd wine-1.5.11
wget http://www.davidgis.fr/download/wine/patches/raw3.patch
wget http://www.davidgis.fr/download/wine/pa ... ffer.patch
patch -p1 < raw.patch
patch -p1 < double_buffer.patch
./tools/make_requests

Build and install as usual

./configure --prefix=/opt/wine/apps/DarkSiders_2
make
make install

WINETRICKS: Steam and DirectX
=============================
Configure Wine as you want (WINEPREFIX=......)

winecfg

Install prerequisites for Steam

winetricks liberation tahoma vcrun2005 corefonts

Install prerequisites for DirectX

winetricks d3dx11_43 d3dx9_36

INSTALL THE GAME (STEAM)
========================
Install Steam

Buy the game

Install the game. Let's Steam install it for you

lahmbi5678
Level 7
Level 7
Posts: 823
Joined: Thu Aug 27, 2009 6:23 am

Re: Darksiders II (Steam) for Wine 1.5.11 (patched)...it wor

Post by lahmbi5678 » Mon Sep 10, 2012 6:14 am

Hi,

you can still create an appdb entry, even if you need/prefer patched wine. If the game doesn't run with unpatched wine, rate the game as garbage, then add your description of how to patch wine in a comment below.

rboxeur
Level 2
Level 2
Posts: 29
Joined: Sun Jul 15, 2012 3:23 pm
Contact:

Re: Darksiders II (Steam) for Wine 1.5.11 (patched)...it wor

Post by rboxeur » Tue Sep 11, 2012 7:34 am

Hi,

Thanks for your suggestion but I don't feel like creating an appdb entry.

My original understanding was that "creating an appdb entry was a bit more usefull for any wine version (patched or unpatched"

But since I've been informed of system rating for unpatched wine version....I don't really approve this system. This is my fault! Got to read Wine documentation :)

No troll here for Wine/AppDB system...I just wanted to share my own feeling.

But thanks for your suggestion.

lahmbi5678
Level 7
Level 7
Posts: 823
Joined: Thu Aug 27, 2009 6:23 am

Re: Darksiders II (Steam) for Wine 1.5.11 (patched)...it wor

Post by lahmbi5678 » Tue Sep 11, 2012 8:28 am

The idea behind appdb is that average users should be able to look up how well a certain app or game will work with unpatched wine. Not every user will be able or willing to patch wine. On the other hand a lot of appdb entries have the typical "How to make it work" sections, ranging from simple winetricks commands to compiling/patching wine.

If you still dislike that approach, please consider contributing to playonlinux, they do exactly what you want, they try to build some kind of 'database' containing a lot of app/game-specific hacks.

rboxeur
Level 2
Level 2
Posts: 29
Joined: Sun Jul 15, 2012 3:23 pm
Contact:

Re: Darksiders II (Steam) for Wine 1.5.11 (patched)...it wor

Post by rboxeur » Tue Sep 11, 2012 10:21 am

Ok Thanks.

Locked