Wine in Linux: ulib module not found

Questions about Wine on Linux
Locked
Hickory420
Newbie
Newbie
Posts: 1
Joined: Fri Sep 07, 2012 4:50 am

Wine in Linux: ulib module not found

Post by Hickory420 » Fri Sep 07, 2012 4:52 am

Hello Everyone,

I'm just going to start with the meat of it:

Code: Select all

wine /path/to/my.exe
fixme:advapi:RegisterEventSourceA ((null),"MyExe 9.4.01.02 (R111)"): stub
fixme:advapi:RegisterEventSourceW (L"",L"MyExe 9.4.01.02 (R111)"): stub
fixme:advapi:ReportEventA (0xcafe4242,0x0001,0x0000,0x00000000,(nil),0x0006,0x00000000,0x3358d4,(nil)): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0001,0x0000,0x00000000,(nil),0x0006,0x00000000,0x111670,(nil)): stub
err:eventlog:ReportEventW L"\nFailed to load library."
err:eventlog:ReportEventW L"\n---------------------------------------------------------------------------------"
err:eventlog:ReportEventW L"\nProgram   : Z:\\path\\to\\my.exe"
err:eventlog:ReportEventW L"\nLibrary   : ulib"
err:eventlog:ReportEventW L"\nPath      : "
err:eventlog:ReportEventW L"\nError     : 126 – Module not found.\r"
fixme:advapi:DeregisterEventSource (0xcafe4242) stub
fixme:advapi:RegisterEventSourceA ((null),"MyExe 9.4.01.02 (R111)"): stub
fixme:advapi:RegisterEventSourceW (L"",L"MyExe 9.4.01.02 (R111)"): stub
fixme:advapi:ReportEventA (0xcafe4242,0x0001,0x0000,0x00000000,(nil),0x0006,0x00000000,0x33cf64,(nil)): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0001,0x0000,0x00000000,(nil),0x0006,0x00000000,0x111670,(nil)): stub
err:eventlog:ReportEventW L"\nFailed to load library."
err:eventlog:ReportEventW L"\n---------------------------------------------------------------------------------"
err:eventlog:ReportEventW L"\nProgram   : Z:\\path\\to\\my.exe"
err:eventlog:ReportEventW L"\nLibrary   : ulib"
err:eventlog:ReportEventW L"\nPath      : "
err:eventlog:ReportEventW L"\nError     : 126 – Module not found.\r"
fixme:advapi:DeregisterEventSource (0xcafe4242) stub
fixme:advapi:RegisterEventSourceA ((null),"MyExe 9.4.01.02 (R111)"): stub
fixme:advapi:RegisterEventSourceW (L"",L"MyExe 9.4.01.02 (R111)"): stub
fixme:advapi:ReportEventA (0xcafe4242,0x0001,0x0000,0x00000000,(nil),0x0006,0x00000000,0x33d468,(nil)): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0001,0x0000,0x00000000,(nil),0x0006,0x00000000,0x111670,(nil)): stub
err:eventlog:ReportEventW L"\nFailed to load library."
err:eventlog:ReportEventW L"\n---------------------------------------------------------------------------------"
err:eventlog:ReportEventW L"\nProgram   : Z:\\path\\to\\my.exe"
err:eventlog:ReportEventW L"\nLibrary   : ulib"
err:eventlog:ReportEventW L"\nPath      : "
err:eventlog:ReportEventW L"\nError     : 126 – Module not found.\r"
fixme:advapi:DeregisterEventSource (0xcafe4242) stub
Wine version
wine-1.5.12

compiled from source with:
./configure --without-mpg123 --without-gsm --without-openal --without-capi --without-v4l --without-ldap --without-coreaudio

running on:
Red Hat Enterprise Linux 5.5
2.6.18-194.el5

I know ulib.dll is a windows thing and I have even copied my ulib.dll to the "system32" of wine and still the same message....

Google is fruitless on this one...

Any thoughts would be much appreciated. Thank you in advance.

Hickory

User avatar
DanKegel
Moderator
Moderator
Posts: 1164
Joined: Wed May 14, 2008 11:44 am

Re: Wine in Linux: ulib module not found

Post by DanKegel » Fri Sep 07, 2012 11:09 am

I see someone else copied ulib.dll with success:
http://appdb.winehq.org/objectManager.p ... &iId=25783

Maybe you need the old windows xp ulib to make wine happy, who knows.
A +file,+module log might show why copying ulib.dll doesn't work, try
getting one and linking to it here.

Locked