missing keys in keyboard

Questions about Wine on Linux
Locked
marianojoey
Level 1
Level 1
Posts: 8
Joined: Sat Mar 03, 2012 8:00 pm

missing keys in keyboard

Post by marianojoey » Fri Aug 24, 2012 12:43 pm

Don't know if it's related to Wine, Steam or to Ubuntu, but some keys stopped working in some games (some, not all) even under Wine 1.4 since I upgraded from Lucid 64 to Precise 64.

Now, after growing tired by sound stopping after a couple hours in Wine from time to time and the need to restart the PC in order to get sound again under Wine (the rest of the apps weren't affected, only Wine), I decided to install Wine 1.5.x (.11 ATM), since I already knew that ALSA wasn't the sound controler anymore, but PulseAudio. :) Now, the games have the sound they should, and so far, the little I played didn't have the problems I had before... but in some games, some keys aren't recognized anymore (I can change them if the game has that possibility, but some keys aren't "mapped" and thus, I can't change them). It's not that the key doesn't work, but for Wine is like the key didn't even exist on my keyboard anymore. So far I found some symbol keys like tilde (~), L-Ctrl, R-Shift, Tab (which is a problem if I need to Alt-Tab from a crashing application to kill it). And NO, it's not related to keyboard mapping. Even if my native language is spanish (sorry for any gramatical errors I might have here), I run Ubuntu, Wine and every single program installed on my PC in english, and I use the keyboard mapping as a querty english keyboard (the most common of the common). "~" should be next to "1", but if I were using a spanish mapping, it would be between "P" and "Enter". No matter if I try to use one or the other, Wine acts as if I didn't press any keys.

Precise is up to date, my GTX 550 TI drivers also, and as far as I know, everything (but sound) worked pretty well under 1.4 (but seriously, playing CIV V without sound is annoying and boring, but FN:NV, Mass Effect, Skyrim and KOTOR are unplayable without it).

If anyone has any idea that might help, I'll appreciate. :)

marianojoey
Level 1
Level 1
Posts: 8
Joined: Sat Mar 03, 2012 8:00 pm

Re: missing keys in keyboard

Post by marianojoey » Sun Aug 26, 2012 10:43 pm

mmmmh, the problem is still there, I can't find anything to solve it. No one had anything to try...? I really don't want to go back to 1.4... :/

lahmbi5678
Level 7
Level 7
Posts: 823
Joined: Thu Aug 27, 2009 6:23 am

Re: missing keys in keyboard

Post by lahmbi5678 » Mon Aug 27, 2012 4:40 am


marianojoey
Level 1
Level 1
Posts: 8
Joined: Sat Mar 03, 2012 8:00 pm

Re: missing keys in keyboard

Post by marianojoey » Tue Aug 28, 2012 10:07 pm

Thanks, I've read them both. It's true that it seems the same bug. Too bad it works also in 1.5.11. I'll wait a couple more weeks to .12 and see if it's solved then, otherwise, I'll have to go back to 1.5.5 (since it seems the bug doesn't work in that one...). Worst case scenario: regression to 1.4. Anyway, thanks for the info. :)

lahmbi5678
Level 7
Level 7
Posts: 823
Joined: Thu Aug 27, 2009 6:23 am

Re: missing keys in keyboard

Post by lahmbi5678 » Wed Aug 29, 2012 2:04 pm

Hi,

you may add your experience to bug #30984 , sometimes it helps, if a bug get's a little bit more attention. In the bug report it is mentioned, that a console command like "setxkbmap us" helped, maybe you can try that, too.

marianojoey
Level 1
Level 1
Posts: 8
Joined: Sat Mar 03, 2012 8:00 pm

Re: missing keys in keyboard

Post by marianojoey » Wed Aug 29, 2012 2:36 pm

wow, that actually worked. L-Ctrl still doesn't work under Steam (it's still unrecognized), but Alt-Tab, Shif-Tab and ~ keys work again. :)

Wonder why I had to use the console command, since the keyboard was already set as US... :/

Anyway, thanks. :)

Locked