OpenGL renderer isn't recognized Radeon 7850 amd64 Mint 13

Questions about Wine on Linux
Locked
wvxvw
Level 2
Level 2
Posts: 10
Joined: Thu Aug 23, 2012 6:19 am

OpenGL renderer isn't recognized Radeon 7850 amd64 Mint 13

Post by wvxvw » Thu Aug 23, 2012 6:26 am

My problem may or may not be related to this topic: http://forum.winehq.org/viewtopic.php?f=8&t=16654
Unlike the author of the topic, I have proprietary AMD drivers installed. Below is the error message I'm seeing:

Code: Select all

err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly (using GL renderer "AMD Radeon HD 7800 Series ", version "1.4 (2.1 (4.2.11762 Compatibility Profile Context))").
X Error of failed request:  GLXBadRenderRequest
  Major opcode of failed request:  137 (GLX)
  Minor opcode of failed request:  1 (X_GLXRender)
  Serial number of failed request:  312
  Current serial number in output stream:  313
I have tried this with Wine 1.5.3 and 1.5.11 all to the same effect. The game used to run fine with an NVidia card. I've installed the game through PlayOnLinux, if that matters.

User avatar
dimesio
Moderator
Moderator
Posts: 12818
Joined: Tue Mar 25, 2008 10:30 pm

Re: OpenGL renderer isn't recognized Radeon 7850 amd64 Mint

Post by dimesio » Thu Aug 23, 2012 7:28 am

wvxvw wrote:

Code: Select all

err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly (using GL renderer "AMD Radeon HD 7800 Series ", version "1.4 (2.1 (4.2.11762 Compatibility Profile Context))").
The error message is pretty clear. Try reinstalling your graphics driver. If you're on 64 bit, make sure you have 32 bit OpenGL installed.

wvxvw
Level 2
Level 2
Posts: 10
Joined: Thu Aug 23, 2012 6:19 am

Re: OpenGL renderer isn't recognized Radeon 7850 amd64 Mint

Post by wvxvw » Thu Aug 23, 2012 9:16 am

Can you elaborate please? It's not as clear to me, because "AMD Radeon HD 7800 Series [...]" is a hardware OpenGL renderer Wine says it is "missing".
How would I make sure I have 32 bit support installed? The driver I'm using is this one: http://support.amd.com/us/gpudownload/l ... linux.aspx I've checked that the file /usr/lib32/dri/fglrx_dri.so exists and that the env. variable LIBGL_DRIVERS_PATH is set to "/usr/lib32/dri:/usr/lib/dri" (w/o quotes), what else should I do to check if the 32 bit OpenGL is installed?
Reinstalling the same driver consistently results in the same error message.

To elaborate further: I've tried installing opensource drivers instead - this got the game running, but the performance is disastrous. Most 2D objects are not rendered or rendered only some parts of them, in places where either textures or the surface would have a "hole" (a transparent area), the's a solid spot of some color etc. Some bitmap sprites are rendered, but others - don't.

User avatar
legluondunet
Level 2
Level 2
Posts: 34
Joined: Sun Aug 22, 2010 10:47 am

Re: OpenGL renderer isn't recognized Radeon 7850 amd64 Mint

Post by legluondunet » Fri Aug 24, 2012 4:14 am

You should reinstall your AMD catalyst drivers, I'm using a 7850 with the 12.8 catalyst drivers on Ubuntu 64 bits and it works fine! Launch the catalyst drivers install again and choose the option "make packages for your distribution".

wvxvw
Level 2
Level 2
Posts: 10
Joined: Thu Aug 23, 2012 6:19 am

Re: OpenGL renderer isn't recognized Radeon 7850 amd64 Mint

Post by wvxvw » Fri Aug 24, 2012 5:21 am

I will try it very soon, I'm now in the process of trying it with another display manager on a recent Fedora distro, but in the meantime, can you please confirm that the DirectX emulation through OpenGL by Wine is working?
I have certain concerns about it because of AMD drivers worked with no visual impediments with Linux 3D stuff rendered through OpenGL, such as desktop effects of Compiz or Cinnamon desktop of Linux Mint, but as soon as I try to run a game that requires DirectX in Wine, the display goes awry. By which I mean that translation from DirectX set of instructions into OpenGL is not supported or supported only some small % of it in the Wine versions that I've tried so far. However, if I try to run a game as if only DirectX 8 was available (this is something very old and very basic), then the overall performance is slightly better (at least the text and 2D sprites are rendered correctly), however the 3D is absolutely broken (no shaders, which means that most objects appear as solid blobs of paint rather then being rendered with textures and lighting effects.)

Thanks.

wvxvw
Level 2
Level 2
Posts: 10
Joined: Thu Aug 23, 2012 6:19 am

Re: OpenGL renderer isn't recognized Radeon 7850 amd64 Mint

Post by wvxvw » Fri Aug 24, 2012 10:29 am

Sorry, I don't seem to be able to edit my previous post. Here's a tiny update on the matter:
I have built the DEB packages from the AMD driver installer. After resolving all build dependencies (which mostly included building and packaging tools) I could build these files:
(NOTE! I was doing it on my old Ubuntu 10.04 32 bit because, frankly, I was afraid of screwing things up in my working system)

fglrx_8.982-0ubuntu1_i386.deb
fglrx-amdcccle_8.982-0ubuntu1_i386.deb
fglrx-dev_8.982-0ubuntu1_i386.deb
fglrx-installer_8.982-0ubuntu1_i386.changes
fglrx-modaliases_8.982-0ubuntu1_i386.deb

I then have all of these installed via dpkg -i [DEB]. The installation seems to go well, the machine rebooted w/o problems. Compiz effects, which require 3D hardware acceleration work well, but the game is broken.
The game will either run in with the -dx8 option, which sets it to use DirectX 8 - which renders all 3D unusable. Conversely, if run by default, the 3D looks good (so much I can see at the startup screen), but the text and 2D sprites are not rendered at all, likewise, much of other shaders aren't rendered too (flame, light, clouds aren't rendered).

User avatar
legluondunet
Level 2
Level 2
Posts: 34
Joined: Sun Aug 22, 2010 10:47 am

Re: OpenGL renderer isn't recognized Radeon 7850 amd64 Mint

Post by legluondunet » Fri Aug 24, 2012 11:15 am

after installed the AMD radeon catalyst package, did you launch this command in a root terminal:

$ aticonfig --initial

to write a default xorg.conf file.

Some game are not well supported when you use wine and a AMD radeon graphic card. Wich game are you trying to run on wine?

wvxvw
Level 2
Level 2
Posts: 10
Joined: Thu Aug 23, 2012 6:19 am

Re: OpenGL renderer isn't recognized Radeon 7850 amd64 Mint

Post by wvxvw » Fri Aug 24, 2012 11:56 am

Yes, I have a xorg.conf created with aticonfig. Catalyst drivers are working otherwise.

The game I'm trying to run is Guild Wars. I've been playing it before using NVidia card. This some times created problems to X-server as it would complain a lot about rendering errors, but it was still usable (I'd have to put a script on crontab for flushing Xsession errors log...).

More info. I've finally managed to install the latest AMD Catalyst drivers on Fedora 17, amd64, KDE system. I'm seeing the same error as before:

Code: Select all

err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly (using GL renderer "AMD Radeon HD 7800 Series ", version "1.4 (2.1 (4.2.11762 Compatibility Profile Context))").
This is certainly Wine error, because it doesn't even recognize that the direct rendering is enabled... however, I'm not sure if it's worth to continue to try, because if it will appear that OpenGL on AMD cards is unsupported, then it would defy the purpose of further attempts...

Below - just some more diagnostic information. I've read about it on ArchLinux wiki, but it seems relevalnt:

Code: Select all

$ LIBGL_DEBUG=verbose glxinfo > /dev/null
libGL: AtiGetClientDriverName: 8.98.2 fglrx (screen 0)
ukiDynamicMajor: found major device number 248
ukiDynamicMajor: found major device number 248
ukiOpenByBusid: Searching for BusID PCI:3:0:0
ukiOpenDevice: node name is /dev/ati/card0
ukiOpenDevice: open result is 6, (OK)
ukiOpenByBusid: ukiOpenMinor returns 6
ukiOpenByBusid: ukiGetBusid reports PCI:3:0:0

User avatar
legluondunet
Level 2
Level 2
Posts: 34
Joined: Sun Aug 22, 2010 10:47 am

Re: OpenGL renderer isn't recognized Radeon 7850 amd64 Mint

Post by legluondunet » Fri Aug 24, 2012 1:30 pm

could you give us the result of this command:
$ glxinfo |grep direct

wvxvw
Level 2
Level 2
Posts: 10
Joined: Thu Aug 23, 2012 6:19 am

Re: OpenGL renderer isn't recognized Radeon 7850 amd64 Mint

Post by wvxvw » Fri Aug 24, 2012 1:55 pm

Code: Select all

$ glxinfo | grep "direct"
direct rendering: Yes
    GL_AMD_multi_draw_indirect, GL_AMD_name_gen_delete, 
    GL_ARB_draw_elements_base_vertex, GL_ARB_draw_indirect, 
    GL_EXT_direct_state_access, GL_EXT_draw_buffers2, GL_EXT_draw_instanced, 
also glxgears sais it's enabled. But now i'm starting to think it must be missing 32-bit OpenGL libraries, but I don't know which they would be as I'm totally new to Fedora.

wvxvw
Level 2
Level 2
Posts: 10
Joined: Thu Aug 23, 2012 6:19 am

Re: OpenGL renderer isn't recognized Radeon 7850 amd64 Mint

Post by wvxvw » Fri Aug 24, 2012 3:20 pm

Some more updates:
I've found (purely by chance) this library: xorg-x11-drv-catalyst-libs.i686 in rpmfusion (which I also used to install kmod-catalyst). After installing it (or, perhaps just the additional reboot did it... :S) I could launch the game, with the exact same results: if run with defaults settings, no texts, no 2D sprites, but 3D looks very good (textures applied good, shaders, such as fire, air effects etc look very good, framerate is perfect). If I then try to run it with -dx8 switch (which means to use DirectX 8 ) the text renders well, the 2D sprites are also rendered well, but 3D is broken.
*sigh*

Unless there is some other option I should try, like, perhaps, there are some libraries which Wine needs to rendere texts and 2D graphics on modern AMD cards, I will try to return this card to the store :(

lahmbi5678
Level 7
Level 7
Posts: 823
Joined: Thu Aug 27, 2009 6:23 am

Re: OpenGL renderer isn't recognized Radeon 7850 amd64 Mint

Post by lahmbi5678 » Sat Aug 25, 2012 5:57 am

One last thing you could do is to make sure that you are not hit by that bug: https://bugs.launchpad.net/ubuntu/+sour ... bug/852811

wvxvw
Level 2
Level 2
Posts: 10
Joined: Thu Aug 23, 2012 6:19 am

Re: OpenGL renderer isn't recognized Radeon 7850 amd64 Mint

Post by wvxvw » Sat Aug 25, 2012 2:57 pm

Nah, that's definitely not my case, I never had mesa drivers installed. Besides, the game "can" launch, but the rendering inside the game is very bad. Just to make sure checked where the /usr/lib32/libGL.so links on my system, and it's the library inside /usr/lib32/fglrx, so this case is covered.

Perhaps the below will help identify the problem, although I don't have much hope as it looks like some major version mismatch or something that wasn't even expected to work:

Code: Select all

fixme:win:EnumDisplayDevicesW ((null),0,0x32ebbc,0x00000000), stub!
fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for bias -120, std (d/m/y): 23/09/2012, dlt (d/m/y): 30/03/2012
fixme:win:EnumDisplayDevicesW ((null),0,0x32da60,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32d9a0,0x00000000), stub!
fixme:ddraw:ddraw7_Initialize Ignoring guid {aeb2cdd4-6e41-43ea-941c-8361cc760781}.
fixme:devenum:DEVENUM_ICreateDevEnum_CreateClassEnumerator Category {33d9a760-90c8-11d0-bd43-00a0c911ce86} not found
fixme:devenum:DEVENUM_ICreateDevEnum_CreateClassEnumerator Category {33d9a761-90c8-11d0-bd43-00a0c911ce86} not found
fixme:winediag:AUDDRV_GetAudioEndpoint Winepulse is not officially supported by the wine project
fixme:winediag:AUDDRV_GetAudioEndpoint For sound related feedback and support, please visit http://ubuntuforums.org/showthread.php?t=1960599
fixme:devenum:DEVENUM_ICreateDevEnum_CreateClassEnumerator Category {cc7bfb41-f175-11d1-a392-00e0291f3959} not found
fixme:devenum:DEVENUM_ICreateDevEnum_CreateClassEnumerator Category {cc7bfb46-f175-11d1-a392-00e0291f3959} not found
fixme:win:EnumDisplayDevicesW ((null),0,0x33ebbc,0x00000000), stub!
fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for bias -120, std (d/m/y): 23/09/2012, dlt (d/m/y): 30/03/2012
fixme:win:EnumDisplayDevicesW ((null),0,0x33da60,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33d9a0,0x00000000), stub!
fixme:ddraw:ddraw7_Initialize Ignoring guid {aeb2cdd4-6e41-43ea-941c-8361cc760781}.
fixme:devenum:DEVENUM_ICreateDevEnum_CreateClassEnumerator Category {33d9a760-90c8-11d0-bd43-00a0c911ce86} not found
fixme:devenum:DEVENUM_ICreateDevEnum_CreateClassEnumerator Category {33d9a761-90c8-11d0-bd43-00a0c911ce86} not found
fixme:winediag:AUDDRV_GetAudioEndpoint Winepulse is not officially supported by the wine project
fixme:winediag:AUDDRV_GetAudioEndpoint For sound related feedback and support, please visit http://ubuntuforums.org/showthread.php?t=1960599
fixme:devenum:DEVENUM_ICreateDevEnum_CreateClassEnumerator Category {cc7bfb41-f175-11d1-a392-00e0291f3959} not found
fixme:devenum:DEVENUM_ICreateDevEnum_CreateClassEnumerator Category {cc7bfb46-f175-11d1-a392-00e0291f3959} not found
fixme:win:EnumDisplayDevicesW ((null),0,0x14dda44,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x14ddda0,0x00000000), stub!
fixme:heap:HeapSetInformation 0x1e3c000 0 0x14ddf90 4
fixme:thread:SetThreadStackGuarantee (0x214e9d0): stub
fixme:imm:ImmDisableTextFrameService Stub
fixme:d3d:wined3d_device_set_dialog_box_mode Dialogs cannot be disabled yet.
fixme:winsock:WS_getsockopt WS_SO_CONNECT_TIME - faking results
fixme:d3d:wined3d_device_set_dialog_box_mode Dialogs cannot be disabled yet.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
<<< repeated multiple times >>>
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
err:winediag:shader_generate_glsl_declarations The hardware does not support enough uniform components to run this shader, it may not render correctly.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
<<< repeated couple of hundred times >>>
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:keyboard:X11DRV_LoadKeyboardLayout L"00000409", 0000: stub!
fixme:keyboard:X11DRV_MapVirtualKeyEx keyboard layout (nil) is not supported
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
<<< repeated few dozens times >>>
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
err:wgl:glxdrv_SetPixelFormat Invalid operation on root_window
Actually, after some more googling I came about this bug report which is suspiciously similar to what I'm getting: http://bugs.winehq.org/show_bug.cgi?id=27350
However, I have serious doubts about GuildWars not supporting older shader models (perhaps even not supporting the newer ones!) whilst this bug is advertized as fixed in a much earlier version of Wine then I have, still there is a chance that I'm having a problem with the shader model. Now my question is: how would I diagnoze and perhaps change this setting?

Locked