VBA Emulator running at horribly high speeds

Questions about Wine on Linux
Locked
User avatar
Uikri
Newbie
Newbie
Posts: 2
Joined: Mon Aug 20, 2012 2:43 pm

VBA Emulator running at horribly high speeds

Post by Uikri » Mon Aug 20, 2012 2:58 pm

I've had this problem both on the Ubuntu version of VBA and the Windows version run in WINE. The first time I launched the program, everything was fine. Once it got to the title screen, I decided to put the program into fullscreen mode, and then the sound got really chopy and eventually stopped, and the program froze. Now, whenever I launch the program, it's automatically running at ~182%+ speed. I had hoped that, by using the Windows version of the emulator, I could avoid the problems that the Ubuntu version was giving me, so you can guess this is rather frustrating. So, how would I go about fixing this?

User avatar
Uikri
Newbie
Newbie
Posts: 2
Joined: Mon Aug 20, 2012 2:43 pm

Re: VBA Emulator running at horribly high speeds

Post by Uikri » Wed Aug 22, 2012 3:18 pm

Been 2 days. Hoping someone will try to help.

User avatar
dimesio
Moderator
Moderator
Posts: 12818
Joined: Tue Mar 25, 2008 10:30 pm

Re: VBA Emulator running at horribly high speeds

Post by dimesio » Wed Aug 22, 2012 11:19 pm

If the native Linux version has the same problem, it's a bug in the app, not a Wine issue.

lahmbi5678
Level 7
Level 7
Posts: 823
Joined: Thu Aug 27, 2009 6:23 am

Re: VBA Emulator running at horribly high speeds

Post by lahmbi5678 » Thu Aug 23, 2012 8:38 am

Maybe you'd need to limit cpu usage, that means that vba emulator should be restricted to e.g. one cpu core. I'm not an expert in that area, you may have to ask in a linux forum how to do that, one way to do it is described in https://bbs.archlinux.org/viewtopic.php?id=105280 .

Also you could try to avoid fullscreen and/or enable virtual desktop in winecfg (with a size smaller than fullscreen). Upgrade to latest wine, run from command line and post terminal output.

Locked