Call of Duty 4 : Modern warfare cannot patch to 1.6

Questions about Wine on Linux
Locked
lordmonkey
Newbie
Newbie
Posts: 1
Joined: Sat Aug 18, 2012 2:38 pm

Call of Duty 4 : Modern warfare cannot patch to 1.6

Post by lordmonkey » Sat Aug 18, 2012 2:50 pm

While running Ubuntu 12.04 (64 bit) I have installed Call of duty 4: modern warfare without any problems but when I try to patch to 1.7 (through 1.6) I get this error message :
The program CoD4MW-1.6-PatchSetup.exe has encountered a serious problem and needs to close. ....
This is the backtrace :
http://pastebin.com/WEh3j6vw

I also have problem launching the originally installed exe ( for multiplayer) - I get this error
DirectX encountered an unrecoverable error. For details please read the FAQ.


But I do have d3dx9 and directx9 installed with winetricks (while looking in the terminal)
$ winetricks d3dx9
Executing w_do_call d3dx9
d3dx9 already installed, skipping
but I do not have the overrides in the GUI
Image

I have also modified the registry (as stated here http://appdb.winehq.org/objectManager.p ... &iId=12804)just to check if that's the issue but this did not help either.

Locked