Office Professional Plus 2010 install fails

Questions about Wine on Linux
Locked
faelmc
Level 2
Level 2
Posts: 36
Joined: Wed Feb 29, 2012 7:35 pm

Office Professional Plus 2010 install fails

Post by faelmc » Thu Mar 22, 2012 9:33 am

Hello.

Knowing that many improvements have happened in the wine code to install the Office. I also want to install.

The version I'm using is Office Professional Plus 2010
using wine 1.5.0 on Debian Squeeze (i386).

I went to install, clean created new prefix wine, and open the setup, there I took which is not going to use, getting: Word, Excel, Access and PowerPoint. The installation starts normally, but gives an error in the middle and does not complete installation, this is the error that shows the end of the terminal:

err:module:import_dll Library sqdedev.DLL (which is needed by L"C:\\users\\hiphop\\Temp\\msiefe.tmp") not found
err:module:import_dll Library sqdedev.DLL (which is needed by L"C:\\users\\hiphop\\Temp\\msiefe.tmp") not found
err:msi:free_package_structures failed to delete L"C:\\users\\hiphop\\Temp\\msiefe.tmp" (32)

Following the instructions in: http://bugs.winehq.org/show_bug.cgi?id=28486
I copy the file "C:\\windows\\Microsoft.NET\\Framework\\v2.0.50727\\CONFIG\\machine.config" of a windows installation, but the log in the terminal remains the same.

I ask friends to help end the setup.

Thanks.
Faelmc

User avatar
dimesio
Moderator
Moderator
Posts: 12852
Joined: Tue Mar 25, 2008 10:30 pm

Re: Office Professional Plus 2010 install fails

Post by dimesio » Thu Mar 22, 2012 9:55 am

faelmc wrote:Hello.

Knowing that many improvements have happened in the wine code to install the Office. I also want to install.

The version I'm using is Office Professional Plus 2010
using wine 1.5.0 on Debian Squeeze (i386).

I went to install, clean created new prefix wine, and open the setup, there I took which is not going to use, getting: Word, Excel, Access and PowerPoint. The installation starts normally, but gives an error in the middle and does not complete installation, this is the error that shows the end of the terminal:

err:module:import_dll Library sqdedev.DLL (which is needed by L"C:\\users\\hiphop\\Temp\\msiefe.tmp") not found
err:module:import_dll Library sqdedev.DLL (which is needed by L"C:\\users\\hiphop\\Temp\\msiefe.tmp") not found
err:msi:free_package_structures failed to delete L"C:\\users\\hiphop\\Temp\\msiefe.tmp" (32)

Following the instructions in: http://bugs.winehq.org/show_bug.cgi?id=28486
I copy the file "C:\\windows\\Microsoft.NET\\Framework\\v2.0.50727\\CONFIG\\machine.config" of a windows installation, but the log in the terminal remains the same.
Once an Office 2010 install has failed for a given wineprefix, it will always fail. You need to delete the wineprefix and start fresh. The machine.config file cannot be copied from another machine--it is specific to the system. You need to either copy it from a Mono install on your system, or a .NET install to another wineprefix on the same system. You can also simply install .NET 2.0 to the wineprefix you are going to install Office to, but be aware that that will install a lot of other things as well, and if they cause problems, you are on your own.

faelmc
Level 2
Level 2
Posts: 36
Joined: Wed Feb 29, 2012 7:35 pm

Post by faelmc » Thu Mar 22, 2012 10:34 am

Thank dimesio, I exclude the wineprefix, and created another to try to machine.config, machine.config, was caught on my machine being, I have dual boot with windows xp and debian.
But still the same problem, I need to install mono?

I would like to test, because the announcement of wine 1.4, is there that you could use Office 2010, yes, I know it was purchases simpler versions of Office is not a plus.

User avatar
dimesio
Moderator
Moderator
Posts: 12852
Joined: Tue Mar 25, 2008 10:30 pm

Post by dimesio » Thu Mar 22, 2012 11:09 am

faelmc wrote:Thank dimesio, I exclude the wineprefix, and created another to try to machine.config, machine.config, was caught on my machine being, I have dual boot with windows xp and debian.
But still the same problem, I need to install mono?

I would like to test, because the announcement of wine 1.4, is there that you could use Office 2010, yes, I know it was purchases simpler versions of Office is not a plus.
Machine.config needs to be from the same system: your Linux install. I use machine.config from my native Linux Mono install and it's always worked.

faelmc
Level 2
Level 2
Posts: 36
Joined: Wed Feb 29, 2012 7:35 pm

Post by faelmc » Thu Mar 22, 2012 3:03 pm

I still can not resolve this error

I installed mono on linux, I copied the file "/etc/mono/2.0/machine.config" to "wineprefixes/office2010/drive_c/windows/Microsoft.NET/Framework/v2.0.50727/CONFIG" prefix in a clean, finished to create, but the same error happens.
I made a different attempt "winetricks dotnet20" and the same.

I tried using winetricks dotnet20 and replace the machine.config to "/etc/mono/2.0/machine.config" but the same error.

Another mistake that I see in the terminal:
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding

probably related to the problem.
All attempts were used prefixes wine clean and new.

dimesio, you have succeeded in setup, with which version of Office?
I ask this because the version "Professional Plus" to behave differently from the others.

thank you and ask for more help if possible

User avatar
dimesio
Moderator
Moderator
Posts: 12852
Joined: Tue Mar 25, 2008 10:30 pm

Post by dimesio » Thu Mar 22, 2012 6:04 pm

faelmc wrote: dimesio, you have succeeded in setup, with which version of Office?
I ask this because the version "Professional Plus" to behave differently from the others.
My version is Professional Plus. You are correct that it behaves differently--other versions don't require the machine.config file.
Another mistake that I see in the terminal:
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
That's not the problem. I get that too, and the installer succeeds. I just retested in 1.5.0, and it worked fine following the instructions in the AppDB.

Is your Windows version set to XP? It should be.

faelmc
Level 2
Level 2
Posts: 36
Joined: Wed Feb 29, 2012 7:35 pm

Post by faelmc » Thu Mar 22, 2012 6:36 pm

friend, I read the instructions appdb, and I did everything as it is there, clean wine prefix, I not changed the version of windows and I copied the file machine.config.

Perhaps this version I'm trying to install, has an update or something that installation stop.
I got this version in August 2011.

Is there something else I can try?

faelmc
Level 2
Level 2
Posts: 36
Joined: Wed Feb 29, 2012 7:35 pm

Post by faelmc » Thu Mar 22, 2012 7:24 pm

Well, I tried a different way, follow the steps of appbd, and before you install Office, the sqdedev.dll downloaded, copied it to system32 and put the wine as native in winecfg after that the install mode gave the same error but with sqlunirl . dll.

Then all over again, new prefix, a copy of machine.config, etc., and sent sqdedev.dll sqlunirl.dll in system32 and native in winecfg.

But even then the installation gives an error, I see no error in the terminal.

any suggestions?

User avatar
dimesio
Moderator
Moderator
Posts: 12852
Joined: Tue Mar 25, 2008 10:30 pm

Post by dimesio » Thu Mar 22, 2012 8:50 pm

faelmc wrote: Perhaps this version I'm trying to install, has an update or something that installation stop.
I got this version in August 2011.
If it includes SP1, that could be the reason; SP1 does not install.

faelmc
Level 2
Level 2
Posts: 36
Joined: Wed Feb 29, 2012 7:35 pm

Post by faelmc » Sat Mar 24, 2012 4:46 pm

dimesio right, I think it should be.

further ahead try to install.
thanks for help.

faelmc
Level 2
Level 2
Posts: 36
Joined: Wed Feb 29, 2012 7:35 pm

Re: Office Professional Plus 2010 install fails

Post by faelmc » Sat Sep 15, 2012 6:56 pm

As promised, I voted to say that now I have the office 2010 in wine, and running well, all that I need and do not need is working perfectly.

I upgrade to the new wine-1.5.12
To INSTALLING, I installed the package "winbind" on linux, and the installation went smoothly and everything works fine.

Thanks dimesio, and every wine community. 8)

Locked