WoW Play Button Not Working - Fix for Linux/Wine??

Questions about Wine on Linux
Locked
tashizzlet
Newbie
Newbie
Posts: 3
Joined: Fri Oct 28, 2011 3:16 pm
Contact:

WoW Play Button Not Working - Fix for Linux/Wine??

Post by tashizzlet » Fri Oct 28, 2011 3:35 pm

So this issue is quite common now in WoW launchers from all operating systems, and it's gone and happened to mine. When I open the shortcut on my desktop, the client opens, and when I click on the 'play' button, it closes and nothing comes up. I've read everywhere that if you start it from the WoW.exe link in World of Warcraft folder, it'll automatically open, but when I click on it, it just tries to open, then closes. There's a list of things you can try to make it work again posted on the site, but they're suggestions for Windows. I've tried all of the ones I could do, but nothing's worked yet. If anyone else has this problem, and is using Ubuntu, please let me know if you have any fixes that work. Thanks! :D

tparker
Level 5
Level 5
Posts: 354
Joined: Tue Feb 24, 2009 3:06 pm

WoW Play Button Not Working - Fix for Linux/Wine??

Post by tparker » Fri Oct 28, 2011 5:04 pm

On 10/28/2011 04:35 PM, tashizzlet wrote:
I've read everywhere that if you start it from the WoW.exe link in World of Warcraft folder, it'll automatically open, but when I click on it, it just tries to open, then closes.
Try starting the game from wow.exe using the command line. That should
give you some errors that you can post here so we can try to help you
find the problem.

tashizzlet
Newbie
Newbie
Posts: 3
Joined: Fri Oct 28, 2011 3:16 pm
Contact:

Post by tashizzlet » Fri Oct 28, 2011 5:41 pm

err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly
fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONNECT_TIMEOUT (3000): STUB
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT 3000
fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONNECT_TIMEOUT (3000): STUB
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT 3000
fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONNECT_TIMEOUT (3000): STUB
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT 3000
archive Data/Cache/SoundCache-1.MPQ opened
archive Data/Cache/SoundCache-2.MPQ opened
archive Data/Cache/SoundCache-3.MPQ opened
archive Data/Cache/SoundCache-0.MPQ opened
archive Data/Cache/enUS/SoundCache-enUS.MPQ opened
archive Data/wow-update-13164.MPQ opened
archive Data/Cache/patch-base-13164.MPQ opened
archive Data/Cache/enUS/patch-enUS-13164.MPQ opened
archive Data/Cache/SoundCache-patch-13164.MPQ opened
archive Data/Cache/enUS/SoundCache-patch-enUS-13164.MPQ opened
archive Data/wow-update-13205.MPQ opened
archive Data/Cache/patch-base-13205.MPQ opened
archive Data/Cache/enUS/patch-enUS-13205.MPQ opened
archive Data/Cache/SoundCache-patch-13205.MPQ opened
archive Data/Cache/enUS/SoundCache-patch-enUS-13205.MPQ opened
archive Data/wow-update-13287.MPQ opened
archive Data/Cache/patch-base-13287.MPQ opened
archive Data/Cache/enUS/patch-enUS-13287.MPQ opened
archive Data/Cache/SoundCache-patch-13287.MPQ opened
archive Data/Cache/enUS/SoundCache-patch-enUS-13287.MPQ opened
archive Data/wow-update-13329.MPQ opened
archive Data/Cache/patch-base-13329.MPQ opened
archive Data/Cache/enUS/patch-enUS-13329.MPQ opened
archive Data/Cache/SoundCache-patch-13329.MPQ opened
archive Data/Cache/enUS/SoundCache-patch-enUS-13329.MPQ opened
archive Data/wow-update-13596.MPQ opened
archive Data/Cache/patch-base-13596.MPQ opened
archive Data/Cache/enUS/patch-enUS-13596.MPQ opened
archive Data/Cache/SoundCache-patch-13596.MPQ opened
archive Data/Cache/enUS/SoundCache-patch-enUS-13596.MPQ opened
archive Data/wow-update-13623.MPQ opened
archive Data/Cache/patch-base-13623.MPQ opened
archive Data/Cache/enUS/patch-enUS-13623.MPQ opened
archive Data/Cache/SoundCache-patch-13623.MPQ opened
archive Data/Cache/enUS/SoundCache-patch-enUS-13623.MPQ opened
archive Data/wow-update-base-13914.MPQ opened
archive Data/enUS/wow-update-enUS-13914.MPQ opened
archive Data/Cache/patch-base-13914.MPQ opened
archive Data/Cache/enUS/patch-enUS-13914.MPQ opened
archive Data/Cache/SoundCache-patch-13914.MPQ opened
archive Data/Cache/enUS/SoundCache-patch-enUS-13914.MPQ opened
archive Data/wow-update-base-14007.MPQ opened
archive Data/enUS/wow-update-enUS-14007.MPQ opened
archive Data/Cache/patch-base-14007.MPQ opened
archive Data/Cache/enUS/patch-enUS-14007.MPQ opened
archive Data/Cache/SoundCache-patch-14007.MPQ opened
archive Data/Cache/enUS/SoundCache-patch-enUS-14007.MPQ opened
archive Data/wow-update-base-14333.MPQ opened
archive Data/enUS/wow-update-enUS-14333.MPQ opened
archive Data/Cache/patch-base-14333.MPQ opened
archive Data/Cache/enUS/patch-enUS-14333.MPQ opened
archive Data/Cache/SoundCache-patch-14333.MPQ opened
archive Data/Cache/enUS/SoundCache-patch-enUS-14333.MPQ opened
archive Data/wow-update-base-14480.MPQ opened
archive Data/enUS/wow-update-enUS-14480.MPQ opened
archive Data/Cache/patch-base-14480.MPQ opened
archive Data/Cache/enUS/patch-enUS-14480.MPQ opened
archive Data/Cache/SoundCache-patch-14480.MPQ opened
archive Data/Cache/enUS/SoundCache-patch-enUS-14480.MPQ opened
archive Data/wow-update-base-14545.MPQ opened
archive Data/enUS/wow-update-enUS-14545.MPQ opened
archive Data/Cache/patch-base-14545.MPQ opened
archive Data/Cache/enUS/patch-enUS-14545.MPQ opened
archive Data/Cache/SoundCache-patch-14545.MPQ opened
archive Data/Cache/enUS/SoundCache-patch-enUS-14545.MPQ opened
archive Data\enUS\speech-enUS.MPQ opened
archive Data\enUS\locale-enUS.MPQ opened
archive Data\sound.MPQ opened
archive Data\world.MPQ opened
archive Data\art.MPQ opened
fixme:win:EnumDisplayDevicesW ((null),0,0x32eccc,0x00000000), stub!
fixme:d3d_caps:wined3d_guess_card No card selector available for GL vendor 4 and card vendor 0000.
X Error of failed request: GLXBadRenderRequest
Major opcode of failed request: 155 (GLX)
Minor opcode of failed request: 1 (X_GLXRender)
Serial number of failed request: 1160
Current serial number in output stream: 1161

Here's what I got

tparker
Level 5
Level 5
Posts: 354
Joined: Tue Feb 24, 2009 3:06 pm

WoW Play Button Not Working - Fix for Linux/Wine??

Post by tparker » Fri Oct 28, 2011 6:06 pm

On 10/28/2011 06:41 PM, tashizzlet wrote:
err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly
That first part is what the problem is. It looks like you are using the
open source driver for your video card and you need to change that to
the proprietary driver. The open source ones can't handle some of the 3d
games.

tashizzlet
Newbie
Newbie
Posts: 3
Joined: Fri Oct 28, 2011 3:16 pm
Contact:

Post by tashizzlet » Fri Oct 28, 2011 10:41 pm

OMG THANK YOU SO MUCH!!!! YOU'RE A LIFE-SAVER. :mrgreen:

Locked