can't wine after upgrade to ubuntu oneiric 11.10

Questions about Wine on Linux
Locked
SwaJime
Level 1
Level 1
Posts: 9
Joined: Sun Oct 23, 2011 8:46 pm

can't wine after upgrade to ubuntu oneiric 11.10

Post by SwaJime » Sun Oct 23, 2011 8:59 pm

I just upgraded to Ubuntu 11.10 and now I've lost all wine functionality.

How can I get wine working again?

This is what I've tried:

john@desktop:~$ sudo aptitude search wine
p gnome-wine-icon-theme - red variation of the GNOME-Colors icon theme
p libkwineffects1abi2 - library used by effects for the KDE window manager
p libkwineffects1abi2-gles - library used by effects for the KDE window manager - Open GL ES
p q4wine - Qt4 GUI for wine (W.I.N.E)
p shiki-wine-theme - red variation of the Shiki-Colors theme
p wine - Microsoft Windows Compatibility Layer (meta package)
v wine-dev -
v wine-dev -
p wine1.2 - Microsoft Windows Compatibility Layer (Binary Emulator and Libra
p wine1.2-dbg - Microsoft Windows Compatibility Layer (debugging symbols)
p wine1.2-dev - Microsoft Windows Compatibility Layer (Development files)
p wine1.2-gecko - Microsoft Windows Compatibility Layer (Web Browser)
p wine1.3 - Microsoft Windows Compatibility Layer (Binary Emulator and Libra
p wine1.3-dbg - Microsoft Windows Compatibility Layer (debugging symbols)
p wine1.3-dev - Microsoft Windows Compatibility Layer (Development files)
p wine1.3-gecko - Microsoft Windows Compatibility Layer (Web Browser)
p winefish - LaTeX Editor based on Bluefish
i winetricks - Microsoft Windows Compatibility Layer (winetricks)

john@desktop:~$ sudo aptitude reinstall wine
The following packages will be REINSTALLED:
wine
0 packages upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/3,592 B of archives. After unpacking 0 B will be used.
(Reading database ... 327181 files and directories currently installed.)
Preparing to replace wine 1.2.3-0ubuntu1 (using .../wine_1.2.3-0ubuntu1_amd64.deb) ...
Unpacking replacement wine ...
Setting up wine (1.2.3-0ubuntu1) ...

john@desktop:~$ wine cmd
bash: /usr/bin/wine: No such file or directory


john@desktop:~$ sudo aptitude show wine
Package: wine
New: yes
State: installed
Automatically installed: no
Version: 1.2.3-0ubuntu1
Priority: optional
Section: universe/otherosfs
Maintainer: Scott Ritchie <scottritchie@ubuntu.com>
Uncompressed Size: 69.6 k
Depends: wine1.3, ia32-libs (>= 1.6), lib32asound2 (> 1.0.14), libc6-i386 (>= 2.6-1), lib32nss-mdns (>= 0.10-3)
Conflicts: wine
Provided by: wine1.2, wine1.3
Description: Microsoft Windows Compatibility Layer (meta package)
Wine is a compatibility layer for running Windows applications on Linux. Applications are run at full speed without the
need of cpu emulation. Wine does not require Microsoft Windows, however it can use native system dll files in place of its
own if they are available.

This meta-package always depends on the latest version of Wine.
Homepage: http://www.winehq.org/

john@desktop:~$

vitamin
Moderator
Moderator
Posts: 6605
Joined: Sat Feb 23, 2008 2:29 pm

Re: can't wine after upgrade to ubuntu oneiric 11.10

Post by vitamin » Sun Oct 23, 2011 10:32 pm

SwaJime wrote:I just upgraded to Ubuntu 11.10 and now I've lost all wine functionality.
Doesn't look like anything related to Wine. Ask your distro forum with help on how to properly install/upgrade software.

SwaJime
Level 1
Level 1
Posts: 9
Joined: Sun Oct 23, 2011 8:46 pm

Post by SwaJime » Sun Oct 23, 2011 11:26 pm

Thanx vitamin ... I opened a bug report at https://bugs.launchpad.net/ubuntu/+bug/880640

I'm sure if it happens to somebody else they are likely to look here too.

john

ischou
Level 4
Level 4
Posts: 109
Joined: Sun Nov 28, 2010 7:22 pm

Post by ischou » Mon Oct 24, 2011 9:35 am

The "wine" meta-package seems to be incorrectly created. Do you need both wine 1.2 and 1.3, and the dev packages, and the debugging packages? Have you tried just installing wine-1.3?

SwaJime
Level 1
Level 1
Posts: 9
Joined: Sun Oct 23, 2011 8:46 pm

Post by SwaJime » Mon Oct 24, 2011 10:13 am

ischou wrote:The "wine" meta-package seems to be incorrectly created. Do you need both wine 1.2 and 1.3, and the dev packages, and the debugging packages? Have you tried just installing wine-1.3?
I didn't think it had installed all of that ... but just to be sure, I purged the wine apps and tried again:

Code: Select all

root@desktop:~# ls -la /usr/bin/wine
ls: cannot access /usr/bin/wine: No such file or directory

root@desktop:~# aptitude install wine1.3
The following NEW packages will be installed:
  gnome-exe-thumbnailer{a} icoutils{a} wine1.3 wine1.3-gecko{a} winetricks{a} 
0 packages upgraded, 5 newly installed, 0 to remove and 87 not upgraded.
Need to get 0 B/48.4 MB of archives. After unpacking 145 MB will be used.
Do you want to continue? [Y/n/?] y
Preconfiguring packages ...              
Selecting previously deselected package wine1.3.
(Reading database ... 326109 files and directories currently installed.)
Unpacking wine1.3 (from .../wine1.3_1.3.28-0ubuntu1_amd64.deb) ...
Selecting previously deselected package wine1.3-gecko.
Unpacking wine1.3-gecko (from .../wine1.3-gecko_1.3.0+1_amd64.deb) ...
Selecting previously deselected package winetricks.
Unpacking winetricks (from .../winetricks_0.0+20110629_amd64.deb) ...
Selecting previously deselected package icoutils.
Unpacking icoutils (from .../icoutils_0.29.1-1_amd64.deb) ...
Selecting previously deselected package gnome-exe-thumbnailer.
Unpacking gnome-exe-thumbnailer (from .../gnome-exe-thumbnailer_0.8-0ubuntu1_all.deb) ...
Processing triggers for man-db ...
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for hicolor-icon-theme ...
Processing triggers for gconf2 ...
Setting up wine1.3 (1.3.28-0ubuntu1) ...
procps stop/waiting
Setting up wine1.3-gecko (1.3.0+1) ...
Setting up winetricks (0.0+20110629) ...
Setting up icoutils (0.29.1-1) ...
Setting up gnome-exe-thumbnailer (0.8-0ubuntu1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
                                         
root@desktop:~# ls -la /usr/bin/wine
-rwxr-xr-x 1 root root 9688 2011-09-15 23:49 /usr/bin/wine

root@desktop:~# /usr/bin/wine cmd
-su: /usr/bin/wine: No such file or directory

jjmckenzie
Moderator
Moderator
Posts: 1153
Joined: Wed Apr 27, 2011 11:01 pm

can't wine after upgrade to ubuntu oneiric 11.10

Post by jjmckenzie » Mon Oct 24, 2011 10:24 am

On Mon, Oct 24, 2011 at 8:13 AM, SwaJime <wineforum-user@winehq.org> wrote:
ischou wrote:
The "wine" meta-package seems to be incorrectly created.  Do you need both wine 1.2 and 1.3, and the dev packages, and the debugging packages?  Have you tried just installing wine-1.3?
I didn't think it had installed all of that ... but just to be sure, I purged the wine apps and tried again:


Code:
root@desktop:~# ls -la /usr/bin/wine
ls: cannot access /usr/bin/wine: No such file or directory
One thing I noticed right here is that you are running Wine as ROOT.
Please try to do so as a regular user. There is a FAQ on why this
should not be done (issues appear when running as root that don't as a
regular user.)

James

SwaJime
Level 1
Level 1
Posts: 9
Joined: Sun Oct 23, 2011 8:46 pm

Re: can't wine after upgrade to ubuntu oneiric 11.10

Post by SwaJime » Mon Oct 24, 2011 10:49 am

[quote="jjmckenzie"]On Mon, Oct 24, 2011 at 8:13 AM, SwaJime <wineforum-user@winehq.org> wrote:
[quote]
ischou wrote:
[quote]The "wine" meta-package seems to be incorrectly created.  Do you need both wine 1.2 and 1.3, and the dev packages, and the debugging packages?  Have you tried just installing wine-1.3?
[/quote]

I didn't think it had installed all of that ... but just to be sure, I purged the wine apps and tried again:


Code:
root@desktop:~# ls -la /usr/bin/wine
ls: cannot access /usr/bin/wine: No such file or directory
[/quote]One thing I noticed right here is that you are running Wine as ROOT.
Please try to do so as a regular user. There is a FAQ on why this
should not be done (issues appear when running as root that don't as a
regular user.)

James[/quote]

Okay, but the results are the same:
[code]john@desktop:~$ wine cmd
bash: /usr/bin/wine: No such file or directory
john@desktop:~$ [/code]

SwaJime
Level 1
Level 1
Posts: 9
Joined: Sun Oct 23, 2011 8:46 pm

Re: can't wine after upgrade to ubuntu oneiric 11.10

Post by SwaJime » Mon Oct 24, 2011 11:22 am

jjmckenzie wrote:On Mon, Oct 24, 2011 at 8:13 AM, SwaJime <wineforum-user@winehq.org> wrote:
ischou wrote:
The "wine" meta-package seems to be incorrectly created.  Do you need both wine 1.2 and 1.3, and the dev packages, and the debugging packages?  Have you tried just installing wine-1.3?
I didn't think it had installed all of that ... but just to be sure, I purged the wine apps and tried again:


Code:
root@desktop:~# ls -la /usr/bin/wine
ls: cannot access /usr/bin/wine: No such file or directory
One thing I noticed right here is that you are running Wine as ROOT.
Please try to do so as a regular user. There is a FAQ on why this
should not be done (issues appear when running as root that don't as a
regular user.)

James
Okay, but the results are the same:

Code: Select all

john@desktop:~$ wine cmd
bash: /usr/bin/wine: No such file or directory
john@desktop:~$ 

jjmckenzie
Moderator
Moderator
Posts: 1153
Joined: Wed Apr 27, 2011 11:01 pm

can't wine after upgrade to ubuntu oneiric 11.10

Post by jjmckenzie » Mon Oct 24, 2011 1:22 pm

On Mon, Oct 24, 2011 at 9:22 AM, SwaJime <wineforum-user@winehq.org> wrote:
jjmckenzie wrote:
On Mon, Oct 24, 2011 at 8:13 AM, SwaJime <wineforum-user@winehq.org> wrote:
ischou wrote:
I didn't think it had installed all of that ... but just to be sure, I purged the wine apps and tried again:


Code:
root@desktop:~# ls -la /usr/bin/wine
ls: cannot access /usr/bin/wine: No such file or directory
One thing I noticed right here is that you are running Wine as ROOT.
Please try to do so as a regular user.  There is a FAQ on why this
should not be done (issues appear when running as root that don't as a
regular user.)

James
Okay, but the results are the same:

Code:
john@desktop:~$ wine cmd
bash: /usr/bin/wine: No such file or directory
john@desktop:~$
You stated you removed all of the wine packages, correct? If so, this
file or link should not exist.

Can you try installing just the wine-devel or wine-development package
and run this command again?

Thank you.

James

SwaJime
Level 1
Level 1
Posts: 9
Joined: Sun Oct 23, 2011 8:46 pm

Re: can't wine after upgrade to ubuntu oneiric 11.10

Post by SwaJime » Mon Oct 24, 2011 2:40 pm

jjmckenzie wrote:You stated you removed all of the wine packages, correct? If so, this
file or link should not exist.

Can you try installing just the wine-devel or wine-development package
and run this command again?

Thank you.

James
According to Steve Langasek I should have used apt-get instead of aptitude. So, here I am using apt-get.

Okay, here are the results (with no improvement):

Code: Select all

john@desktop:~$ sudo apt-get install wine1.3-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  gnome-exe-thumbnailer icoutils wine1.3 wine1.3-gecko winetricks
Suggested packages:
  libterm-readline-gnu-perl libterm-readline-perl-perl
The following NEW packages will be installed:
  gnome-exe-thumbnailer icoutils wine1.3 wine1.3-dev wine1.3-gecko winetricks
0 upgraded, 6 newly installed, 0 to remove and 92 not upgraded.
Need to get 1,756 kB/50.2 MB of archives.
After this operation, 166 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://us.archive.ubuntu.com/ubuntu/ oneiric/universe wine1.3-dev amd64 1.3.28-0ubuntu1 [1,756 kB]
Fetched 1,756 kB in 7s (223 kB/s)                                                                                                            
Preconfiguring packages ...
Selecting previously deselected package wine1.3.
(Reading database ... 326109 files and directories currently installed.)
Unpacking wine1.3 (from .../wine1.3_1.3.28-0ubuntu1_amd64.deb) ...
Selecting previously deselected package wine1.3-dev.
Unpacking wine1.3-dev (from .../wine1.3-dev_1.3.28-0ubuntu1_amd64.deb) ...
Selecting previously deselected package wine1.3-gecko.
Unpacking wine1.3-gecko (from .../wine1.3-gecko_1.3.0+1_amd64.deb) ...
Selecting previously deselected package winetricks.
Unpacking winetricks (from .../winetricks_0.0+20110629_amd64.deb) ...
Selecting previously deselected package icoutils.
Unpacking icoutils (from .../icoutils_0.29.1-1_amd64.deb) ...
Selecting previously deselected package gnome-exe-thumbnailer.
Unpacking gnome-exe-thumbnailer (from .../gnome-exe-thumbnailer_0.8-0ubuntu1_all.deb) ...
Processing triggers for man-db ...
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for hicolor-icon-theme ...
Processing triggers for gconf2 ...
Setting up wine1.3 (1.3.28-0ubuntu1) ...
procps stop/waiting
Setting up wine1.3-dev (1.3.28-0ubuntu1) ...
Setting up wine1.3-gecko (1.3.0+1) ...
Setting up winetricks (0.0+20110629) ...
Setting up icoutils (0.29.1-1) ...
Setting up gnome-exe-thumbnailer (0.8-0ubuntu1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

john@desktop:~$ wine cmd
bash: /usr/bin/wine: No such file or directory

john@desktop:~$ ls -la /usr/bin/wine
-rwxr-xr-x 1 root root 9688 2011-09-15 23:49 /usr/bin/wine

john@desktop:~$ 

jjmckenzie
Moderator
Moderator
Posts: 1153
Joined: Wed Apr 27, 2011 11:01 pm

can't wine after upgrade to ubuntu oneiric 11.10

Post by jjmckenzie » Mon Oct 24, 2011 9:57 pm

On Mon, Oct 24, 2011 at 12:40 PM, SwaJime <wineforum-user@winehq.org> wrote:
john@desktop:~$ wine cmd
bash: /usr/bin/wine: No such file or directory

john@desktop:~$ ls -la /usr/bin/wine
-rwxr-xr-x 1 root root 9688 2011-09-15 23:49 /usr/bin/wine
What do you get with the following commands:

which wine
file /usr/bin/wine

Something is not correct here.

James

jjmckenzie
Moderator
Moderator
Posts: 1153
Joined: Wed Apr 27, 2011 11:01 pm

can't wine after upgrade to ubuntu oneiric 11.10

Post by jjmckenzie » Mon Oct 24, 2011 9:57 pm

On Mon, Oct 24, 2011 at 12:40 PM, SwaJime <wineforum-user@winehq.org> wrote:
john@desktop:~$ wine cmd
bash: /usr/bin/wine: No such file or directory

john@desktop:~$ ls -la /usr/bin/wine
-rwxr-xr-x 1 root root 9688 2011-09-15 23:49 /usr/bin/wine
What do you get with the following commands:

which wine
file /usr/bin/wine

Something is not correct here.

James

SwaJime
Level 1
Level 1
Posts: 9
Joined: Sun Oct 23, 2011 8:46 pm

Re: can't wine after upgrade to ubuntu oneiric 11.10

Post by SwaJime » Mon Oct 24, 2011 11:20 pm

jjmckenzie wrote:On Mon, Oct 24, 2011 at 12:40 PM, SwaJime <wineforum-user@winehq.org> wrote:
john@desktop:~$ wine cmd
bash: /usr/bin/wine: No such file or directory

john@desktop:~$ ls -la /usr/bin/wine
-rwxr-xr-x 1 root root 9688 2011-09-15 23:49 /usr/bin/wine
What do you get with the following commands:

which wine
file /usr/bin/wine

Something is not correct here.

James
Update from bugs/880640:
Steve Langasek steve.langasek@canonical.com to john

show details 2:46 PM (8 hours ago)

*** This bug is a duplicate of bug 852101 ***
https://bugs.launchpad.net/bugs/852101

You need to run 'sudo apt-get install --reinstall libc6-i386'.

** This bug has been marked a duplicate of bug 852101
32-bit applications do not start on 64
I did as Steve suggested, and I have progress.
So I undid the wine-dev install, redid the wine install ...
Now I'm still trying to get the one application that I use wine for to run.

So ...

Code: Select all

john@desktop:~$ sudo apt-get install wine1.3-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  gnome-exe-thumbnailer icoutils wine1.3 wine1.3-gecko winetricks
Suggested packages:
  libterm-readline-gnu-perl libterm-readline-perl-perl
The following NEW packages will be installed:
  gnome-exe-thumbnailer icoutils wine1.3 wine1.3-dev wine1.3-gecko winetricks
0 upgraded, 6 newly installed, 0 to remove and 92 not upgraded.
Need to get 0 B/50.2 MB of archives.
After this operation, 166 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Preconfiguring packages ...
Selecting previously deselected package wine1.3.
(Reading database ... 326110 files and directories currently installed.)
Unpacking wine1.3 (from .../wine1.3_1.3.28-0ubuntu1_amd64.deb) ...
Selecting previously deselected package wine1.3-dev.
Unpacking wine1.3-dev (from .../wine1.3-dev_1.3.28-0ubuntu1_amd64.deb) ...
Selecting previously deselected package wine1.3-gecko.
Unpacking wine1.3-gecko (from .../wine1.3-gecko_1.3.0+1_amd64.deb) ...
Selecting previously deselected package winetricks.
Unpacking winetricks (from .../winetricks_0.0+20110629_amd64.deb) ...
Selecting previously deselected package icoutils.
Unpacking icoutils (from .../icoutils_0.29.1-1_amd64.deb) ...
Selecting previously deselected package gnome-exe-thumbnailer.
Unpacking gnome-exe-thumbnailer (from .../gnome-exe-thumbnailer_0.8-0ubuntu1_all.deb) ...
Processing triggers for man-db ...
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for hicolor-icon-theme ...
Processing triggers for gconf2 ...
Setting up wine1.3 (1.3.28-0ubuntu1) ...
procps stop/waiting
Setting up wine1.3-dev (1.3.28-0ubuntu1) ...
Setting up wine1.3-gecko (1.3.0+1) ...
Setting up winetricks (0.0+20110629) ...
Setting up icoutils (0.29.1-1) ...
Setting up gnome-exe-thumbnailer (0.8-0ubuntu1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

john@desktop:~$ wine cmd
CMD Version 1.3.28

Z:\home\john>
At this point, I launch my app from the menu, and this shows up in that terminal:

Code: Select all

fixme:exec:SHELL_execute flags ignored: 0x00000100
fixme:exec:SHELL_execute flags ignored: 0x00004100
wine: Call from 0x7ed5b639 to unimplemented function msvcp90.dll.??0?$basic_string@GU?$char_traits@G@std@@V?$allocator@G@2@@std@@QAE@XZ, aborting
err:module:attach_process_dlls "wtutil23u.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\Watchtower\\Watchtower Library 2010\\E\\WTLibrary.exe" failed, status 80000100


SwaJime
Level 1
Level 1
Posts: 9
Joined: Sun Oct 23, 2011 8:46 pm

Re: can't wine after upgrade to ubuntu oneiric 11.10

Post by SwaJime » Mon Oct 24, 2011 11:47 pm

Continuing further ... this is an attempt to launch the program from the command line:

Code: Select all

C:\Program Files\Watchtower\MEPS Platform 2.3>C:\\Program Files\\Watchtower\\Watchtower Library 2010\\E\\WTLibrary.exe
wine: Call from 0x7ed5b639 to unimplemented function msvcp90.dll.??0?$basic_string@GU?$char_traits@G@std@@V?$allocator@G@2@@std@@QAE@XZ, aborting
err:module:attach_process_dlls "wtutil23u.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\Watchtower\\Watchtower Library 2010\\E\\WTLibrary.exe" failed, status 80000100

C:\Program Files\Watchtower\MEPS Platform 2.3>

Frédéric Delanoy

can't wine after upgrade to ubuntu oneiric 11.10

Post by Frédéric Delanoy » Tue Oct 25, 2011 7:24 am

On Tue, Oct 25, 2011 at 06:47, SwaJime <wineforum-user@winehq.org> wrote:
Continuing further ... this is an attempt to launch the program from the command line:

Code:
C:\Program Files\Watchtower\MEPS Platform 2.3>C:\\Program Files\\Watchtower\\Watchtower Library 2010\\E\\WTLibrary.exe
wine: Call from 0x7ed5b639 to unimplemented function msvcp90.dll.??0?$basic_string@GU?$char_traits@G@std@@V?$allocator@G@2@@std@@QAE@XZ, aborting
err:module:attach_process_dlls "wtutil23u.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\Watchtower\\Watchtower Library 2010\\E\\WTLibrary.exe" failed, status 80000100

C:\Program Files\Watchtower\MEPS Platform 2.3>
Looks similar to http://bugs.winehq.org/show_bug.cgi?id=28541
Maybe you should comment on this bug, or enter a new bug

SwaJime
Level 1
Level 1
Posts: 9
Joined: Sun Oct 23, 2011 8:46 pm

Re: can't wine after upgrade to ubuntu oneiric 11.10

Post by SwaJime » Tue Oct 25, 2011 10:55 am

Frédéric Delanoy wrote:On Tue, Oct 25, 2011 at 06:47, SwaJime <wineforum-user@winehq.org> wrote:
Continuing further ... this is an attempt to launch the program from the command line:

Code:
C:\Program Files\Watchtower\MEPS Platform 2.3>C:\\Program Files\\Watchtower\\Watchtower Library 2010\\E\\WTLibrary.exe
wine: Call from 0x7ed5b639 to unimplemented function msvcp90.dll.??0?$basic_string@GU?$char_traits@G@std@@V?$allocator@G@2@@std@@QAE@XZ, aborting
err:module:attach_process_dlls "wtutil23u.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\Watchtower\\Watchtower Library 2010\\E\\WTLibrary.exe" failed, status 80000100

C:\Program Files\Watchtower\MEPS Platform 2.3>
Looks similar to http://bugs.winehq.org/show_bug.cgi?id=28541
Maybe you should comment on this bug, or enter a new bug
OK, I finally got it working now by installing vcrun2008 via winetricks.
Thank you for all of your help. Your help has been very much appreciated. :-)

Locked