cant play after updating to ubunto 11.10

Questions about Wine on Linux
Locked
madmaxfh
Level 1
Level 1
Posts: 8
Joined: Tue Oct 18, 2011 6:38 pm
Location: Portugal

cant play after updating to ubunto 11.10

Post by madmaxfh » Tue Oct 18, 2011 6:48 pm

I recently updated my Ubunto from 11.04 to 11.10 and I can no longer play windows games via wine.
However I can still launch and use Steam, but I cant play any of the games there, Steam shows the "preparing to launch..." message but the game never launches.
Also with World of Warcraft the game launcher opens up, I can see the news and all, but when I push the play button the launcher closes and the game doesn't show up.

I was wondering if anyone had a similar issue on using wine on ubunto after updating and if they found a work around it :P

tparker
Level 5
Level 5
Posts: 354
Joined: Tue Feb 24, 2009 3:06 pm

cant play after updating to ubunto 11.10

Post by tparker » Tue Oct 18, 2011 7:14 pm

On 10/18/2011 07:48 PM, madmaxfh wrote:
Also with World of Warcraft the game launcher opens up, I can see the news and all, but when I push the play button the launcher closes and the game doesn't show up.
This happens very often with WoW. The work around for the issue is to
run Wow.exe instead of launcher.exe. You will still need to start up the
launcher occasionally for the program to patch when needed, after
patching completes close the launcher and go back to using Wow.exe to play.

madmaxfh
Level 1
Level 1
Posts: 8
Joined: Tue Oct 18, 2011 6:38 pm
Location: Portugal

Post by madmaxfh » Tue Oct 18, 2011 7:28 pm

Thanks for the tip, Launching via wow.exe worked :) however I find it strange that I used to be able to play via launcher before :S

And I still cant play on steam :(

JuanPabloCuervo
Level 2
Level 2
Posts: 26
Joined: Wed Aug 31, 2011 4:39 pm

Post by JuanPabloCuervo » Wed Oct 19, 2011 1:05 am

madmaxfh wrote:Thanks for the tip, Launching via wow.exe worked :) however I find it strange that I used to be able to play via launcher before :S

And I still cant play on steam :(
Oneric its a nightmare LOL

the only people having good experience with Oneric
are Microsoft workers hired to "update" Ubuntu. LOL

http://ubuntuforums.org/forumdisplay.ph ... e7b1&f=103

Frédéric Delanoy

cant play after updating to ubunto 11.10

Post by Frédéric Delanoy » Wed Oct 19, 2011 2:16 am

On Wed, Oct 19, 2011 at 08:05, JuanPabloCuervo
<wineforum-user@winehq.org> wrote:
madmaxfh wrote:
Thanks for the tip, Launching via wow.exe worked :) however I find it strange that I used to be able to play via launcher before :S

And I still cant play on steam :(
Oneric its a nightmare LOL

the only people having good experience with Oneric
are Microsoft workers hired to "update" Ubuntu. LOL

http://ubuntuforums.org/forumdisplay.ph ... e7b1&f=103
Unity is a nightmare IMNSHO.
You should probably try using XFCE or gnome-classic (by installing
gnome-classic-fallback IIRC)

madmaxfh
Level 1
Level 1
Posts: 8
Joined: Tue Oct 18, 2011 6:38 pm
Location: Portugal

Post by madmaxfh » Fri Oct 21, 2011 8:19 am

I tried gnome classic and it made everything worse, now I cant even play WoW using the wow.exe and the launcher doesn't launches.

Steam still opens but cant play anything there.

tparker
Level 5
Level 5
Posts: 354
Joined: Tue Feb 24, 2009 3:06 pm

cant play after updating to ubunto 11.10

Post by tparker » Fri Oct 21, 2011 8:59 am

On 10/21/2011 09:19 AM, madmaxfh wrote:
I tried gnome classic and it made everything worse, now I cant even play WoW using the wow.exe and the launcher doesn't launches.

Steam still opens but cant play anything there.
Did you reinstall your video driver after updating your OS?

madmaxfh
Level 1
Level 1
Posts: 8
Joined: Tue Oct 18, 2011 6:38 pm
Location: Portugal

Post by madmaxfh » Fri Oct 21, 2011 6:53 pm

Well I had nvidea driver 270 before update and after I got 280 so I'm guessing ubunto updated it automatically during the update.

deckoff
Level 1
Level 1
Posts: 7
Joined: Sun Aug 28, 2011 7:46 am

Post by deckoff » Sat Oct 22, 2011 1:34 am

I seem to have the same problem - I cant start a game different than Civ2. Really old games - Caesar3, Zeus crash. I run unity 2D, the driver was updated and the video is intel 8xx - famous for having stability issues. Any suggestions, I will try with Kubuntu now and report :) 11.04 worked for me

deckoff
Level 1
Level 1
Posts: 7
Joined: Sun Aug 28, 2011 7:46 am

Post by deckoff » Sat Oct 22, 2011 3:48 pm

Same results with both Kubuntu and ubuntu - no of my games will run the way they used to...

User avatar
dimesio
Moderator
Moderator
Posts: 12656
Joined: Tue Mar 25, 2008 10:30 pm

Post by dimesio » Sat Oct 22, 2011 7:33 pm

Have any of you folks with problems after upgrading Ubuntu tried renaming ~/.wine and reinstalling all your apps to a clean wineprefix?

vitamin
Moderator
Moderator
Posts: 6605
Joined: Sat Feb 23, 2008 2:29 pm

Re: cant play after updating to ubunto 11.10

Post by vitamin » Sat Oct 22, 2011 8:26 pm

madmaxfh wrote:I recently updated my Ubunto from 11.04 to 11.10 and I can no longer play windows games via wine.
Please check what gcc version Wine compiled with for your distro. If it' gcc 4.6 then it's the known problem with gcc4.6. Add -fno-omit-frame-pointer -fno-asynchronous-unwind-tables to CC options then recompile Wine manually.

Locked