Anyone using Oneric suddenly having Wine/OpenGL problems?

Questions about Wine on Linux
Locked
3vi1
Level 4
Level 4
Posts: 125
Joined: Sun Feb 24, 2008 8:24 pm

Anyone using Oneric suddenly having Wine/OpenGL problems?

Post by 3vi1 » Sat Sep 17, 2011 11:04 am

So last night I try to start L4D2 (which previously worked), and am seeing this dreaded message as the first in the console:

Code: Select all

err:wgl:X11DRV_WineGL_InitOpenglInfo  couldn't initialize OpenGL, expect problems
This is happening both with the latest Wine from git and from the prebuilt 1.3 package in the Oneiric repos. It was all working fine when I last tested (using my git build) a few weeks back, and I haven't done anything peculiar with my graphics stack since then.

All other non-wine 3D apps, like Nexuiz and the Unity desktop w/compiz are happily working.

I don't think this is a Wine problem per se (could even be specific to my system), but it's odd that Wine is the only thing being affected. Could this have something to do with the recent Ubuntu switch to multiarch?

I tried uninstalling/reinstalling the nvidia-current-updates package (and rebooting afterwards), and manually running ldconfig, but it had no effect.

Code: Select all

evil@saturn:~$ glxinfo | grep 'direct rendering\| string'
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 560 Ti/PCI/SSE2
OpenGL version string: 4.1.0 NVIDIA 280.13
OpenGL shading language version string: 4.10 NVIDIA via Cg compiler

evil@saturn:~$ cat /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf 
/usr/lib/nvidia-current-updates
/usr/lib32/nvidia-current-updates
If anyone has ideas of further things I could look at, I'd really appreciate hearing them. I'm trying to investigate all avenues before I re-install the OS (as I suspect this might have something to do with this being a Natty install that I've updated all through the alphas).

Thanks in advance!

steffie
Newbie
Newbie
Posts: 4
Joined: Sat Sep 17, 2011 2:23 pm

Re: Anyone using Oneric suddenly having Wine/OpenGL problems

Post by steffie » Sat Sep 17, 2011 2:31 pm

Code: Select all

err:wgl:X11DRV_WineGL_InitOpenglInfo  couldn't initialize OpenGL, expect problems
I am also infectet, using an old installation of ubuntu natty about this prob

there is an thread in launchpad about this, but they can solve that prob cause they have publish oneiric in time

think prob will be solved in a week or so...

cu, stephan

3vi1
Level 4
Level 4
Posts: 125
Joined: Sun Feb 24, 2008 8:24 pm

Post by 3vi1 » Sat Sep 17, 2011 3:37 pm

I figured out the issue - somehow Wine's trying to load the wrong libGL.so. I went in and changed the links like so.

Code: Select all

sudo rm /usr/lib/x86_64-linux-gnu/libGL.so 
sudo ln -s /usr/lib/nvidia-current-updates/libGL.so /usr/lib/x86_64-linux-gnu/libGL.so
and now my git build runs fine (the package from the repos still threw an exception, oddly - though it didn't have the GL error any longer).

It may be possible to get around this by just using a preload. I had tried it earlier, but without success.

Steffie - Can you direct me to the discussion on launchpad so that I can see if I can do anything to help them troubleshoot? I went looking for it, but was unable to find it.

qwest
Level 2
Level 2
Posts: 11
Joined: Sat Sep 17, 2011 8:27 pm

Post by qwest » Sat Sep 17, 2011 8:37 pm

Code: Select all

***@***:~$ wine --version
wine-1.3.28-308-gae80430

***@****:~$ glxinfo | grep 'direct rendering\| string'
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 580/PCI/SSE2
OpenGL version string: 4.1.0 NVIDIA 280.13
OpenGL shading language version string: 4.10 NVIDIA via Cg compiler

***@****:~$ cat /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf
/usr/lib/nvidia-current-updates
/usr/lib32/nvidia-current-updates

***@****:~$ ls -l /usr/lib/x86_64-linux-gnu/libGL.so
lrwxrwxrwx 1 root root 40 2011-09-17 20:00 /usr/lib/x86_64-linux-gnu/libGL.so -> /usr/lib/nvidia-current-updates/libGL.so
I still have the original issue when trying to run 3D applications. I am curious if you may have done something else when tinkering around that could have contributed to fixing the problem.

steffie
Newbie
Newbie
Posts: 4
Joined: Sat Sep 17, 2011 2:23 pm

Post by steffie » Sun Sep 18, 2011 8:44 am

3vi1 wrote:I figured out the issue - somehow Wine's trying to load the wrong libGL.so. I went in and changed the links like so.

Code: Select all

sudo rm /usr/lib/x86_64-linux-gnu/libGL.so 
sudo ln -s /usr/lib/nvidia-current-updates/libGL.so /usr/lib/x86_64-linux-gnu/libGL.so
and now my git build runs fine (the package from the repos still threw an exception, oddly - though it didn't have the GL error any longer).

It may be possible to get around this by just using a preload. I had tried it earlier, but without success.

Steffie - Can you direct me to the discussion on launchpad so that I can see if I can do anything to help them troubleshoot? I went looking for it, but was unable to find it.
shure, have a look @ https://bugs.launchpad.net/ubuntu/+sour ... bug/852101 and more others ...

dardack
Level 3
Level 3
Posts: 98
Joined: Mon Sep 05, 2011 3:24 pm

Anyone using Oneric suddenly having Wine/OpenGL problems?

Post by dardack » Sun Sep 18, 2011 10:20 am

I had this issue. I had to uninstall nvidia-* stuff (except nvidia-common
since it's needed by Ubuntu-desktop?). Anyways, my dmesg's were showing
that version 260 nvidia libraries were being loaded but 285 was installed (i
use the 285 from nvidia directly). So once I was able to uninstall the
nvidia libraries from ubuntu, I've been fine.

On Sun, Sep 18, 2011 at 9:44 AM, steffie <wineforum-user@winehq.org> wrote:
3vi1 wrote:
I figured out the issue - somehow Wine's trying to load the wrong
libGL.so. I went in and changed the links like so.

Code:
sudo rm /usr/lib/x86_64-linux-gnu/libGL.so
sudo ln -s /usr/lib/nvidia-current-updates/libGL.so
/usr/lib/x86_64-linux-gnu/libGL.so



and now my git build runs fine (the package from the repos still threw an
exception, oddly - though it didn't have the GL error any longer).
It may be possible to get around this by just using a preload. I had
tried it earlier, but without success.
Steffie - Can you direct me to the discussion on launchpad so that I can
see if I can do anything to help them troubleshoot? I went looking for it,
but was unable to find it.


shure, have a look @
https://bugs.launchpad.net/ubuntu/+sour ... bug/852101 and more
others ...





--
Sincerely,

MacNean C. Tyrrell
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.winehq.org/pipermail/wine-us ... hment.html>

3vi1
Level 4
Level 4
Posts: 125
Joined: Sun Feb 24, 2008 8:24 pm

Post by 3vi1 » Mon Sep 19, 2011 6:16 am

steffie wrote:shure, have a look @ https://bugs.launchpad.net/ubuntu/+sour ... bug/852101 and more others ...
That bug doesn't seem to have anything to do with OpenGL or any symptom I was seeing.

3vi1
Level 4
Level 4
Posts: 125
Joined: Sun Feb 24, 2008 8:24 pm

Re: Anyone using Oneric suddenly having Wine/OpenGL problems

Post by 3vi1 » Mon Sep 19, 2011 6:22 am

dardack wrote:I had this issue.
I think you had a different issue than what I've been describing, dardack. When you have kernel/driver version mismatches, other OpenGL applications generally do not continue to work.

3vi1
Level 4
Level 4
Posts: 125
Joined: Sun Feb 24, 2008 8:24 pm

Post by 3vi1 » Mon Sep 19, 2011 6:23 am

At any rate, I've found a corresponding launchpad report:

https://bugs.launchpad.net/ubuntu/+sour ... bug/852873

steffie
Newbie
Newbie
Posts: 4
Joined: Sat Sep 17, 2011 2:23 pm

Post by steffie » Mon Sep 19, 2011 8:35 am

3vi1 wrote:At any rate, I've found a corresponding launchpad report:

https://bugs.launchpad.net/ubuntu/+sour ... bug/852873
Using LD_PRELOAD=/usr/lib32/fglrx/libGL.so.1 wine ..... does fix the problem.

dardack
Level 3
Level 3
Posts: 98
Joined: Mon Sep 05, 2011 3:24 pm

Anyone using Oneric suddenly having Wine/OpenGL problems?

Post by dardack » Mon Sep 19, 2011 9:17 am

On Mon, Sep 19, 2011 at 7:22 AM, 3vi1 <wineforum-user@winehq.org> wrote:
dardack wrote:
I had this issue.
I think you had a different issue than what I've been describing, dardack.
When you have kernel/driver version mismatches, other OpenGL applications
generally do not continue to work.




I got this same exact error:
Code:
err:wgl:X11DRV_WineGL_InitOpenglInfo couldn't initialize OpenGL, expect
problems

Just saying what fixed it for me is all.



--
Sincerely,

MacNean C. Tyrrell
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.winehq.org/pipermail/wine-us ... hment.html>

Locked