cardfile.exe quit launching after wine-staging-6.5

Questions about Wine on Linux
Post Reply
mpurtell
Level 2
Level 2
Posts: 15
Joined: Sun Jan 31, 2016 9:35 am

cardfile.exe quit launching after wine-staging-6.5

Post by mpurtell » Tue Jun 01, 2021 6:15 pm

I've kept cardfile.exe running on my MX Linux (debian based) distribution using wine-staging since release 1.9 and up until release 6.6. Releases 6.6, 6.7, 6.8 & 6.9 produce this error and my trusty cardfile will not launch.

Code: Select all

00c8:err:plugplay:try_add_device Building report descriptor failed, removing device
00c8:err:plugplay:try_add_device Building report descriptor failed, removing device
014c:err:module:import_dll Loading library krnl386.exe16 (which is needed by L"C:\\windows\\system32\\winevdm.exe") failed (error c0000131).
014c:err:module:LdrInitializeThunk Importing dlls for L"C:\\windows\\system32\\winevdm.exe" failed, status c0000135
I am using wine-staging from the winehq repository and running MX19 64 bit which is based on buster and I've created a 32 bit prefix using

Code: Select all

WINEARCH=win32 WINEPREFIX=~/.wine winecfg
to execute cardfile.exe from.

I have seen several releases in the previous 5.nn series where this problem was also present but eventually winehq put out a 5.nn build where it started working again.

If this isn't the correct forum for this, please let me know where I should post.

thanks - mike

spoon0042
Level 6
Level 6
Posts: 532
Joined: Thu Dec 24, 2009 11:00 am

Re: cardfile.exe quit launching after wine-staging-6.5

Post by spoon0042 » Mon Jul 26, 2021 1:55 pm

Someone else has reported (presumably) the same problem here: viewtopic.php?f=8&t=35476

I'd offer the same advice, report a bug and if you're able to build wine yourself you could track down whatever change is causing your problem.

I did find a cardfile.exe from Windows 3.1 but it appears to work for me so I can't help you there. Do you know what version you have?

spoon0042
Level 6
Level 6
Posts: 532
Joined: Thu Dec 24, 2009 11:00 am

Re: cardfile.exe quit launching after wine-staging-6.5

Post by spoon0042 » Sat Aug 07, 2021 11:38 am

A bug has been filed for this issue: https://bugs.winehq.org/show_bug.cgi?id=51564

Post Reply