Libraries missing on Ubuntu 64bit

Questions about Wine on Linux
Post Reply
Teodore
Level 1
Level 1
Posts: 6
Joined: Thu Jun 24, 2021 1:51 am

Libraries missing on Ubuntu 64bit

Post by Teodore » Thu Jun 24, 2021 1:54 am

Here on Ubuntu 21.04, latest wine git:

Code: Select all

./configure --enable-win64
[...]
configure: creating ./config.status
config.status: creating Make.tmp
config.status: creating include/config.h
config.status: include/config.h is unchanged
config.status: linking tools/winewrapper to wine
config.status: linking tools/winewrapper to wine64
config.status: executing include/stamp-h commands
config.status: executing tools/makedep commands
config.status: executing Makefile commands

configure: libhal 64-bit development files not found, no legacy dynamic device support.
configure: OSS sound system found but too old (OSSv4 needed), OSS won't be supported.
configure: jxrlib 64-bit development files not found, JPEG-XR won't be supported.
configure: vkd3d 64-bit development files not found (or too old), Direct3D 12 won't be supported.

configure: Finished.  Do 'make' to compile Wine.
What's the deal with this? Do I just compile it?

User avatar
dimesio
Moderator
Moderator
Posts: 12979
Joined: Tue Mar 25, 2008 10:30 pm

Re: Libraries missing on Ubuntu 64bit

Post by dimesio » Thu Jun 24, 2021 6:08 am

Teodore wrote:
Thu Jun 24, 2021 1:54 am

Code: Select all

configure: libhal 64-bit development files not found, no legacy dynamic device support.
configure: OSS sound system found but too old (OSSv4 needed), OSS won't be supported.
configure: jxrlib 64-bit development files not found, JPEG-XR won't be supported.
configure: vkd3d 64-bit development files not found (or too old), Direct3D 12 won't be supported.
The first two are not needed on modern Linux distros.

Ubuntu does have a 64-bit libjxr-dev package in universe, but not a 32 bit one. FYI, the WineHQ Ubuntu packages are built without jxrlib support because of this and no one has noticed, so I don't think many apps need it. https://packages.ubuntu.com/hirsute/libjxr-dev

Current Wine requires vkd3d 1.2 and Ubuntu only provides 1.1. If you don't have any apps/games that need Direct3D 12, you don't need it. If you do, Cybermax's PPA has vkd3d 1.2 packages. (Note they are not supported here.) https://launchpad.net/~cybermax-dexter/ ... untu/vkd3d

Teodore
Level 1
Level 1
Posts: 6
Joined: Thu Jun 24, 2021 1:51 am

Re: Libraries missing on Ubuntu 64bit

Post by Teodore » Thu Jun 24, 2021 1:59 pm

So what's the difference between Ubuntu and Debian then? Is it better just to use Devian, does it have more dev packages of what is best to test wine development?

User avatar
dimesio
Moderator
Moderator
Posts: 12979
Joined: Tue Mar 25, 2008 10:30 pm

Re: Libraries missing on Ubuntu 64bit

Post by dimesio » Thu Jun 24, 2021 6:19 pm

Debian does provide 32 bit jxrlib, but their version of vkd3d is just as outdated as Ubuntu's.

Post Reply