No images in U-Center

Questions about Wine on Linux
Post Reply
fll-freak
Newbie
Newbie
Posts: 3
Joined: Sat Jun 19, 2021 12:29 pm

No images in U-Center

Post by fll-freak » Sat Jun 19, 2021 12:55 pm

I am trying to use u-blox U-Center application to interface with their GPS modules. In keeping with the WineApp database, the bulk of the application seems to work flawlessly. I have found that trying to bring up an image in the "map view" fails. No error or warning from U-Center, but the area where the image should appear stays white. This feature of the program works fine in Win10.

I have poked around and read this might be an issue if image support was not compiled in, but I see no such error in the console. I am hoping someone might have an idea to try.

I hope the following details might shed some light on the issue.

Details:
Wine 6.0.1
U-Center 21.05
Linux Ubuntu 20.04.2 LTS
Console output from starting the application:

Code: Select all

$wine u-center
015c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
015c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0164:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0164:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
016c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
016c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
015c:fixme:ntdll:EtwRegisterTraceGuidsW (008138F9, 00000000, {f7b697a3-4db5-4d3b-be71-c4d284e6592f}, 7, 00ACB260, (null), (null), 00AF9350): stub
015c:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {72b14a7d-704c-423e-92f8-7e6d64bcb92a}
015c:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {e2091f8a-1e0a-4731-84a2-0dd57c8a5261}
015c:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {e8a3bf1f-a86b-4390-9c60-5390b969d22c}
015c:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {5727a00f-50be-4519-8256-f7699871fecb}
015c:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {7e854ec7-cdc4-405a-b5b2-aaf7c9e7d40c}
015c:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {79a60dc6-5fc8-4952-a41c-1163aeec5eb8}
015c:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {2718d25b-5bf5-4479-8e88-babc64bdbfca}
015c:fixme:heap:GetNumaHighestNodeNumber semi-stub: 0031FC70
015c:err:ole:com_get_class_object class {e5b8e079-ee6d-4e33-a438-c87f2e959254} not registered
015c:err:ole:com_get_class_object class {e5b8e079-ee6d-4e33-a438-c87f2e959254} not registered
015c:err:ole:create_server class {e5b8e079-ee6d-4e33-a438-c87f2e959254} not registered
015c:fixme:ole:com_get_class_object CLSCTX_REMOTE_SERVER not supported
015c:err:ole:com_get_class_object no class object {e5b8e079-ee6d-4e33-a438-c87f2e959254} could be created for context 0x17
015c:err:ole:com_get_class_object class {77a1c827-fcd2-4689-8915-9d613cc5fa3e} not registered
015c:err:ole:com_get_class_object class {77a1c827-fcd2-4689-8915-9d613cc5fa3e} not registered
015c:err:ole:create_server class {77a1c827-fcd2-4689-8915-9d613cc5fa3e} not registered
015c:fixme:ole:com_get_class_object CLSCTX_REMOTE_SERVER not supported
015c:err:ole:com_get_class_object no class object {77a1c827-fcd2-4689-8915-9d613cc5fa3e} could be created for context 0x17
015c:err:ole:com_get_class_object class {79c43adb-a429-469f-aa39-2f2b74b75937} not registered
015c:err:ole:com_get_class_object class {79c43adb-a429-469f-aa39-2f2b74b75937} not registered
015c:err:ole:create_server class {79c43adb-a429-469f-aa39-2f2b74b75937} not registered
015c:fixme:ole:com_get_class_object CLSCTX_REMOTE_SERVER not supported
015c:err:ole:com_get_class_object no class object {79c43adb-a429-469f-aa39-2f2b74b75937} could be created for context 0x17
015c:err:ole:com_get_class_object class {e5b8e079-ee6d-4e33-a438-c87f2e959254} not registered
015c:err:ole:com_get_class_object class {e5b8e079-ee6d-4e33-a438-c87f2e959254} not registered
015c:err:ole:create_server class {e5b8e079-ee6d-4e33-a438-c87f2e959254} not registered
015c:fixme:ole:com_get_class_object CLSCTX_REMOTE_SERVER not supported
015c:err:ole:com_get_class_object no class object {e5b8e079-ee6d-4e33-a438-c87f2e959254} could be created for context 0x17
015c:err:ole:com_get_class_object class {77a1c827-fcd2-4689-8915-9d613cc5fa3e} not registered
015c:err:ole:com_get_class_object class {77a1c827-fcd2-4689-8915-9d613cc5fa3e} not registered
015c:err:ole:create_server class {77a1c827-fcd2-4689-8915-9d613cc5fa3e} not registered
015c:fixme:ole:com_get_class_object CLSCTX_REMOTE_SERVER not supported
015c:err:ole:com_get_class_object no class object {77a1c827-fcd2-4689-8915-9d613cc5fa3e} could be created for context 0x17
015c:err:ole:com_get_class_object class {79c43adb-a429-469f-aa39-2f2b74b75937} not registered
015c:err:ole:com_get_class_object class {79c43adb-a429-469f-aa39-2f2b74b75937} not registered
015c:err:ole:create_server class {79c43adb-a429-469f-aa39-2f2b74b75937} not registered
015c:fixme:ole:com_get_class_object CLSCTX_REMOTE_SERVER not supported
015c:err:ole:com_get_class_object no class object {79c43adb-a429-469f-aa39-2f2b74b75937} could be created for context 0x17
015c:fixme:font:freetype_set_outline_text_metrics failed to read full_nameW for font L"Ani"!
015c:err:ole:com_get_class_object class {e5b8e079-ee6d-4e33-a438-c87f2e959254} not registered
015c:err:ole:com_get_class_object class {e5b8e079-ee6d-4e33-a438-c87f2e959254} not registered
015c:err:ole:create_server class {e5b8e079-ee6d-4e33-a438-c87f2e959254} not registered
015c:fixme:ole:com_get_class_object CLSCTX_REMOTE_SERVER not supported
015c:err:ole:com_get_class_object no class object {e5b8e079-ee6d-4e33-a438-c87f2e959254} could be created for context 0x17
015c:err:ole:com_get_class_object class {77a1c827-fcd2-4689-8915-9d613cc5fa3e} not registered
015c:err:ole:com_get_class_object class {77a1c827-fcd2-4689-8915-9d613cc5fa3e} not registered
015c:err:ole:create_server class {77a1c827-fcd2-4689-8915-9d613cc5fa3e} not registered
015c:fixme:ole:com_get_class_object CLSCTX_REMOTE_SERVER not supported
015c:err:ole:com_get_class_object no class object {77a1c827-fcd2-4689-8915-9d613cc5fa3e} could be created for context 0x17
015c:err:ole:com_get_class_object class {79c43adb-a429-469f-aa39-2f2b74b75937} not registered
015c:err:ole:com_get_class_object class {79c43adb-a429-469f-aa39-2f2b74b75937} not registered
015c:err:ole:create_server class {79c43adb-a429-469f-aa39-2f2b74b75937} not registered
015c:fixme:ole:com_get_class_object CLSCTX_REMOTE_SERVER not supported
015c:err:ole:com_get_class_object no class object {79c43adb-a429-469f-aa39-2f2b74b75937} could be created for context 0x17
015c:err:ole:com_get_class_object class {e5b8e079-ee6d-4e33-a438-c87f2e959254} not registered
015c:err:ole:com_get_class_object class {e5b8e079-ee6d-4e33-a438-c87f2e959254} not registered
015c:err:ole:create_server class {e5b8e079-ee6d-4e33-a438-c87f2e959254} not registered
015c:fixme:ole:com_get_class_object CLSCTX_REMOTE_SERVER not supported
015c:err:ole:com_get_class_object no class object {e5b8e079-ee6d-4e33-a438-c87f2e959254} could be created for context 0x17
015c:err:ole:com_get_class_object class {77a1c827-fcd2-4689-8915-9d613cc5fa3e} not registered
015c:err:ole:com_get_class_object class {77a1c827-fcd2-4689-8915-9d613cc5fa3e} not registered
015c:err:ole:create_server class {77a1c827-fcd2-4689-8915-9d613cc5fa3e} not registered
015c:fixme:ole:com_get_class_object CLSCTX_REMOTE_SERVER not supported
015c:err:ole:com_get_class_object no class object {77a1c827-fcd2-4689-8915-9d613cc5fa3e} could be created for context 0x17
015c:err:ole:com_get_class_object class {79c43adb-a429-469f-aa39-2f2b74b75937} not registered
015c:err:ole:com_get_class_object class {79c43adb-a429-469f-aa39-2f2b74b75937} not registered
015c:err:ole:create_server class {79c43adb-a429-469f-aa39-2f2b74b75937} not registered
015c:fixme:ole:com_get_class_object CLSCTX_REMOTE_SERVER not supported
015c:err:ole:com_get_class_object no class object {79c43adb-a429-469f-aa39-2f2b74b75937} could be created for context 0x17
0194:fixme:virtual:NtFlushProcessWriteBuffers stub
015c:fixme:nls:RtlGetThreadPreferredUILanguages 00000038, 0031EC80, 0031EC90 0031EC84
015c:fixme:nls:get_dummy_preferred_ui_language (0x38 0031EC80 0031EC90 0031EC84) returning a dummy value (current locale)
015c:fixme:nls:RtlGetThreadPreferredUILanguages 00000038, 0031EC80, 0031EC90 0031EC84
015c:fixme:nls:get_dummy_preferred_ui_language (0x38 0031EC80 0031EC90 0031EC84) returning a dummy value (current locale)
015c:fixme:nls:RtlGetThreadPreferredUILanguages 00000038, 0031EC80, 0031EC90 0031EC84
015c:fixme:nls:get_dummy_preferred_ui_language (0x38 0031EC80 0031EC90 0031EC84) returning a dummy value (current locale)
01a8:fixme:ver:GetCurrentPackageId (0FC9FF20 00000000): stub
015c:fixme:gdi:GetColorAdjustment stub
015c:fixme:shell:InitNetworkAddressControl stub
015c:fixme:comm:set_queue_size insize 32768 outsize 4096 unimplemented stub


Extra console output when trying to load the image. In this case its a PNG:

Code: Select all

015c:fixme:gdi:GetColorAdjustment stub
015c:fixme:commdlg:IServiceProvider_fnQueryService Interface {e07010ec-bc17-44c0-97b0-46c7c95b9edc} requested from unknown service {e07010ec-bc17-44c0-97b0-46c7c95b9edc}
015c:fixme:shell:ViewModeToListStyle ViewMode 0 not implemented
015c:fixme:shell:IShellBrowser_fnSendControlMsg stub, 0x372f5e0 (2, 1026, a003, 0, 0x31d89c)
015c:fixme:shell:IShellBrowser_fnSendControlMsg stub, 0x372f5e0 (2, 1026, a004, 0, 0x31d89c)
015c:fixme:shell:IShellBrowser_fnSendControlMsg stub, 0x372f5e0 (2, 1025, a003, 1, 0x31d89c)
015c:fixme:shell:IShellBrowser_fnSendControlMsg stub, 0x372f5e0 (2, 1025, a004, 1, 0x31d89c)
015c:fixme:nstc:NSTC2_fnSetControlStyle2 mask & style (0x00000004) contains unsupported style(s): 0x00000004
015c:fixme:shell:IShellBrowser_fnOnViewWindowActive stub, 0x372f5e0 (0x372a060)
015c:fixme:commdlg:IFileDialog2_fnQueryInterface Unknown interface requested: {84bccd23-5fde-4cdb-aea4-af64b83d78ab}.
015c:fixme:gdi:GetColorAdjustment stub
Thank you in advance for reading.

fargodwe

Re: No images in U-Center

Post by fargodwe » Mon Jun 21, 2021 3:28 am

I know nothing about this, but if you can tell me if they have a free download for evaluation, etc., and don't need some kind of account with someone or a specific piece of hardware, I'd be more than happy to download it and see if I can see anything when I try it here.

But first a question: did you use winetricks and install at least .NET40?

fll-freak
Newbie
Newbie
Posts: 3
Joined: Sat Jun 19, 2021 12:29 pm

Re: No images in U-Center

Post by fll-freak » Mon Jun 21, 2021 6:51 am

It is a free application with no registration needed. Here is a link to the download zip file: https://www.u-blox.com/sites/default/fi ... 02.exe.zip

Once installed, you need to click of the icon of a map on the toolbar. From there click the open folder button on that dialogs status bar. From there pick a png file. At this point it should display the map for you to calibrate. Normally the image would be a map, but any image file is enough to show the issue.

I did not install winetricks, or .NET40. I am running a very stock Wine. Things I read said not to expect help if you did. And since this is my first time, I figured I might need the help!

fargodwe

Re: No images in U-Center

Post by fargodwe » Mon Jun 21, 2021 9:50 pm

So, I downloaded the zip and ran the installer to a 64-bit prefix. When I run the program, click on "View" and on "Map View" a window comes up. I then I right-click in that window and select "Open Map" and select a JPG file (I didn't have a PNG file handy but it should make no difference) it does ask about creating the calibration file so I just went ahead and my JPG shows in the window fine and has cross hairs that move with the mouse. I didn't install anything extra but as normal I did let it install mono when creating the prefix. I'm running linux Mint 20 which according to the OS you specified should be the same repository. One difference I noted is you listed U-Center 21.05 while the zip to download you pointed to is 21.02. If I should be trying to open a map in a different way to get it to fail please let me know. I did notice the "boxes" on the right of the screen are non-clickable - I don't know if that's a problem or not.

fargodwe

Re: No images in U-Center

Post by fargodwe » Tue Jun 22, 2021 2:48 am

I also forgot to mention I am running wine 6.11 staging. Perhaps you'll need to upgrade wine to a higher version.

fll-freak
Newbie
Newbie
Posts: 3
Joined: Sat Jun 19, 2021 12:29 pm

Re: No images in U-Center

Post by fll-freak » Tue Jun 22, 2021 6:40 am

I am most thankful for you having taken the time to look into this. You have given me a couple of clues. Could I ask you to explain a bit more "and ran the installer to a 64-bit prefix". My steps were to simple install Wine, then I ran "wine u-centersetup_V21.xx.exe". Should I have started the install process differently?

fargodwe

Re: No images in U-Center

Post by fargodwe » Thu Jun 24, 2021 11:15 pm

A prefix can be thought of as an instance of Windows, a bottle. If you did not specify WINEPREFIX=xxxx then your bottle is in the hidden folder .wine in your home folder. Similarly, 64-bit is the architecture - like saying 64-bit windows. You can run 32-bit apps in 64-bit architecture - but there are some that require certain functions, such as provided by dll's, that will run only in 32-bit or only in 64-bit architecture. Since you also did not specify WINEARCH=yyyy (win32 or win64) it defaulted to win64, 64-bit Windows. If there is a problem with architecture you will normally know it from the app's requirements. Prefix's, on the other hand, are something you can control. Say you install Windows apps A & B but did not specify a prefix - everything for both apps is in .wine. Now suppose something happens and you need to start over with app A. The easiest way in a lot of cases using wine is just to delete the prefix ( bottle) and start over. But in this given scenario deleting the prefix because of problems with app A would also delete app B. There is not that much overhead in just creating separate prefixes to avoid this problem. You might install app A adding the argument WINEPREFIX=APPB and install app B adding the argument WINEPREFIX=APPB. Now they are separated. For more information you might want to read:

https://wiki.winehq.org/FAQ#Wineprefixes

User avatar
Bob Wya
Level 12
Level 12
Posts: 3037
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland
Contact:

Re: No images in U-Center

Post by Bob Wya » Fri Jun 25, 2021 11:33 am

@fll-freak

A WINEPREFIX is like a self-contained "Windows installation".
By default this is created in the directory:

Code: Select all

"${HOME}/.wine"
and all subsequent calls to wine will reference this "virtual Windows installation".

You can change the currently referenced / specified WINEPREFIX - by changing the env variable, e.g.:

Code: Select all

export WINEPREFIX="/mnt/external-drive/wineprefixes/steam64"
Any valid directory, writable by your stock Linux user, is OK.
Note: the specified WINEPREFIX directory must either be empty or be an pre-existing WINEPREFIX.

On a 64-bit Linux OS you can create a 64-bit WINEPREFIX (the default):

Code: Select all

WINEPREFIX="${HOME}/.wine-custom"
wineboot -u
This is equivalent to a self-contained 64-bit MS Windows OS installation.

On any Linux OS (32-bit or 64-bit) you can create a 32-bit WINEPREFIX (the default):

Code: Select all

WINEPREFIX="${HOME}/.wine-custom"
WINEARCH=win32 wineboot -u
This is equivalent to a self-contained 32-bit MS Windows OS installation.
Note: you won't be able to run 64-bit executables in this WINEPREFIX.

Note: you can compile/build a pure 64-bit Wine i.e. this has no 32-bit component(s) - but this is not officially supported and has no MS Windows equivalent.
All Windows installers are 32-bit. So these won't be executable, when using a pure 64-bit Wine.

Bob

Post Reply