problem with installing wine

Open forum for end-user questions about Wine. Before asking questions, check out the Wiki as a first step.
Forum Rules
hgabor84
Level 2
Level 2
Posts: 42
Joined: Mon Nov 27, 2017 5:06 pm

problem with installing wine

Post by hgabor84 » Sun Mar 07, 2021 8:18 am

Hello!

I followed the official instruction (https://wiki.winehq.org/Debian) to install winehq-staging on Debian 10 but it was the error message:

"Néhány csomagot nem lehetett telepíteni. Ez azt jelentheti, hogy
egy lehetetlen állapotot kért, vagy ha az unstable disztribúciót
használja, akkor néhány igényelt csomag még nem készült el vagy ki
lett mozdítva az Incoming-ból.
Az alábbi információk segíthetnek megoldani a problémát:

Az alábbi csomagoknak teljesítetlen függőségei vannak:
winehq-staging : Függ ettől: wine-staging (= 6.3~buster-1)
E: A problémák nem javíthatók, sérült csomagokat fogott vissza."

I tried to repair with some popular commands but nothing helped yet:

sudo apt-get --fix-broken install

sudo apt-get install --fix-broken

sudo apt update --fix-missing

sudo apt install -f

Please help!

jkfloris
Level 9
Level 9
Posts: 1429
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 07, 2021 12:44 pm

Did you install the libfaudio0 packages?

Code: Select all

echo 'deb http://deb.debian.org/debian buster-backports main' > buster-backports.list
sudo mkdir -p /etc/apt/sources.list.d
sudo mv -i buster-backports.list /etc/apt/sources.list.d/buster-backports.list
sudo apt update
sudo apt install libfaudio0/buster-backports libfaudio0:i386/buster-backports

hgabor84
Level 2
Level 2
Posts: 42
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 07, 2021 12:51 pm

~$ sudo apt install libfaudio0/buster-backports libfaudio0:i386/buster-backports
Csomaglisták olvasása... Kész
Függőségi fa építése
Állapotinformációk olvasása... Kész
libfaudio0 már a legújabb verzió (21.02-1~bpo10+1).
libfaudio0:i386 már a legújabb verzió (21.02-1~bpo10+1).
„21.02-1~bpo10+1” (Debian Backports:buster-backports [amd64]) verzió lett kijelölve ehhez: „libfaudio0”
„21.02-1~bpo10+1” (Debian Backports:buster-backports [i386]) verzió lett kijelölve ehhez: „libfaudio0:i386”
0 frissített, 0 újonnan telepített, 0 eltávolítandó és 0 nem frissített.

libfaudio0 - its already the newest version as I can see.

jkfloris
Level 9
Level 9
Posts: 1429
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 07, 2021 1:33 pm

Try to install wine-staging-i386

Code: Select all

sudo apt install --install-recommends wine-staging-i386:i386
Most likely, another package will now be blamed. Then try to install that package, just as long as you have found the culprit.
Last edited by jkfloris on Sun Mar 07, 2021 1:39 pm, edited 1 time in total.

hgabor84
Level 2
Level 2
Posts: 42
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 07, 2021 1:36 pm

sudo apt install --install-recommends wine-staging-i386:i386
Csomaglisták olvasása... Kész
Függőségi fa építése
Állapotinformációk olvasása... Kész
wine-staging-i386:i386 már a legújabb verzió (6.3~buster-1).
wine-staging-i386:i386 kézi telepítésűre állítva.
0 frissített, 0 újonnan telepített, 0 eltávolítandó és 0 nem frissített.

Its already the newest version as I can see.

jkfloris
Level 9
Level 9
Posts: 1429
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 07, 2021 1:39 pm

What do you get when you try to install wine-staging-amd64?

Code: Select all

sudo apt install --install-recommends wine-staging-amd64

hgabor84
Level 2
Level 2
Posts: 42
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 07, 2021 1:40 pm

$ sudo apt install --install-recommends wine-staging-amd64
Csomaglisták olvasása... Kész
Függőségi fa építése
Állapotinformációk olvasása... Kész
wine-staging-amd64 már a legújabb verzió (6.3~buster-1).
0 frissített, 0 újonnan telepített, 0 eltávolítandó és 0 nem frissített.

Its the newest version.
Last edited by hgabor84 on Sun Mar 07, 2021 1:42 pm, edited 1 time in total.

jkfloris
Level 9
Level 9
Posts: 1429
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 07, 2021 1:42 pm

What do you get when you try to install wine-staging?

Code: Select all

sudo apt install wine-staging
Last edited by jkfloris on Sun Mar 07, 2021 1:45 pm, edited 1 time in total.

hgabor84
Level 2
Level 2
Posts: 42
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 07, 2021 1:43 pm

Yes, sorry it was the your previous command in my clipboard. :) Please see my edited post previously.

jkfloris
Level 9
Level 9
Posts: 1429
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 07, 2021 1:52 pm

I have also modified the question :)

hgabor84
Level 2
Level 2
Posts: 42
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 07, 2021 2:00 pm

Thats tricky. :)

$ sudo apt install wine-staging
[sudo] hgabor84 jelszava:
Csomaglisták olvasása... Kész
Függőségi fa építése
Állapotinformációk olvasása... Kész
wine-staging már a legújabb verzió (6.3~buster-1).
wine-staging kézi telepítésűre állítva.
0 frissített, 0 újonnan telepített, 0 eltávolítandó és 0 nem frissített.

jkfloris
Level 9
Level 9
Posts: 1429
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 07, 2021 2:25 pm

It looks like Wine staging is completely installed.
You should be able to run wine-staging with:

Code: Select all

WINEPREFIX=~/wine-staging /opt/wine-staging/bin/wine winecfg
Do you have any other Wine versions installed?

hgabor84
Level 2
Level 2
Posts: 42
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 07, 2021 2:58 pm

Its ok now, thanks. No, there is not another wine versions. Mainly it was important for Lutris in order to run Vulkan with games like Crysis but Vulkan is still not working now because of this error message:

"$ vulkaninfo
The NVIDIA driver was unable to open 'libnvidia-glvkspirv.so.460.39'. This library is required at run time.

WARNING: [Loader Message] Code 0 : terminator_CreateInstance: Failed to CreateInstance in ICD 0. Skipping ICD.
The NVIDIA driver was unable to open 'libnvidia-glvkspirv.so.460.39'. This library is required at run time.

WARNING: [Loader Message] Code 0 : terminator_CreateInstance: Failed to CreateInstance in ICD 1. Skipping ICD.
Cannot create Vulkan instance.
/build/vulkan-tools-6bmpQy/vulkan-tools-1.1.97+dfsg1/vulkaninfo/vulkaninfo.c:918: failed with VK_ERROR_INCOMPATIBLE_DRIVER"

jkfloris
Level 9
Level 9
Posts: 1429
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 07, 2021 4:15 pm

'libnvidia-glvkspirv.so.460.39' is in the libnvidia-glvkspirv package from Debian backports.

hgabor84
Level 2
Level 2
Posts: 42
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 07, 2021 4:21 pm

Now it sends this:

"$ vulkaninfo
Cannot create Vulkan instance.
/build/vulkan-tools-6bmpQy/vulkan-tools-1.1.97+dfsg1/vulkaninfo/vulkaninfo.c:918: failed with VK_ERROR_INCOMPATIBLE_DRIVER"

I installed my nvidia driver (460.39) from debian backports repository using this tutorial: https://wiki.debian.org/NvidiaGraphicsD ... ckports.29 and it works without any problem.

Interestingly on the same machine with Linux Mint it works well (nvidia + vulkan) with the same versions from the same tutorials (apt install vulkan-utils).

jkfloris
Level 9
Level 9
Posts: 1429
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 07, 2021 5:05 pm

Did you also installed the nvidia-vulkan-icd package from backports?

hgabor84
Level 2
Level 2
Posts: 42
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 07, 2021 5:15 pm

sudo apt-get install nvidia-vulkan-icd
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-vulkan-icd : Depends: libglx-nvidia0 (= 418.181.07-1) but 460.39-1~bpo10+1 is to be installed
Recommends: libnvidia-cbl (= 418.181.07-1) but it is not going to be installed
Recommends: libnvidia-rtcore (= 418.181.07-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

jkfloris
Level 9
Level 9
Posts: 1429
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 07, 2021 5:24 pm

You forgot to specify the backports repo

Code: Select all

sudo apt install -t buster-backports nvidia-vulkan-icd

hgabor84
Level 2
Level 2
Posts: 42
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 07, 2021 5:28 pm

You are genius! Thanks for all your help now vulkan works with games like Crysis! :)

jkfloris
Level 9
Level 9
Posts: 1429
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 07, 2021 5:30 pm

No problem! And have fun :D

hgabor84
Level 2
Level 2
Posts: 42
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 07, 2021 5:36 pm

Thank you! :)

hgabor84
Level 2
Level 2
Posts: 42
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 14, 2021 5:34 am

Hi again!

I've tried to install wine to some of my other computers but I always stuck at here:

Code: Select all

winecfg
it looks like wine32 is missing, you should install it.
as root, please execute "apt-get install wine32"

Code: Select all

sudo apt-get install wine32
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine32:i386 : Depends: libwine:i386 (= 4.0-2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Code: Select all

sudo apt-get install libwine:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwine:i386 : Depends: libgphoto2-6:i386 (>= 2.5.10) but it is not going to be installed
                Depends: libgphoto2-port12:i386 (>= 2.5.10) but it is not going to be installed
                Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is not going to be installed
                Depends: libudev1:i386 (>= 183) but it is not going to be installed
                Recommends: libcups2:i386 (>= 1.4.0) but it is not going to be installed
                Recommends: libgl1:i386 but it is not going to be installed
                Recommends: libglu1-mesa:i386 but it is not going to be installed or
                            libglu1:i386
                Recommends: libgssapi-krb5-2:i386 (>= 1.6.dfsg.2) but it is not going to be installed
                Recommends: libkrb5-3:i386 (>= 1.6.dfsg.2) but it is not going to be installed
                Recommends: libtiff5:i386 (>= 4.0.3) but it is not going to be installed
                Recommends: libgl1-mesa-dri:i386 but it is not going to be installed
                Recommends: libasound2-plugins:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Thanks for help!

jkfloris
Level 9
Level 9
Posts: 1429
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 14, 2021 11:38 am

It looks like winecfg is linked to the Debian Wine version.
You can remove the Debian Wine packages and try to install the winehq-staging package.

hgabor84
Level 2
Level 2
Posts: 42
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 14, 2021 11:50 am

Its the same - I've already tried installing winehq-staging from winehq website before installed wine package from debian repository. I also took care of installing libfaudio0 package too.

jkfloris
Level 9
Level 9
Posts: 1429
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 14, 2021 12:22 pm

Which wine packages have you installed?

Code: Select all

dpkg -l | grep wine

Post Reply