problem with installing wine

Open forum for end-user questions about Wine. Before asking questions, check out the Wiki as a first step.
Forum Rules
hgabor84
Level 2
Level 2
Posts: 41
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 14, 2021 12:25 pm

Code: Select all

dpkg -l | grep wine
ii  fonts-wine                                4.0-2                               all          Windows API implementation - fonts
ii  libwine:amd64                             4.0-2                               amd64        Windows API implementation - library
ii  libwine:i386                              4.0-2                               i386         Windows API implementation - library
ii  libwine-development:amd64                 4.2-4+b1                            amd64        Windows API implementation - library
ii  wine-staging                              6.3~buster-1                        amd64        WINE Is Not An Emulator - runs MS Windows programs
ii  wine-staging-amd64                        6.3~buster-1                        amd64        WINE Is Not An Emulator - runs MS Windows programs
ii  wine-staging-i386:i386                    6.3~buster-1                        i386         WINE Is Not An Emulator - runs MS Windows programs
ii  wine32:i386                               4.0-2                               i386         Windows API implementation - 32-bit binary loader
ii  wine64                                    4.0-2                               amd64        Windows API implementation - 64-bit binary loader
ii  winehq-staging                            6.3~buster-1                        amd64        WINE Is Not An Emulator - runs MS Windows programs
ii  winetricks                                0.0+20181203-3                      all          simple tool to work around common problems in Wine
Interestingly you can see some packages like libwine:i386 and wine32:i386 installed but the error messages are still the same with them.

jkfloris
Level 9
Level 9
Posts: 1419
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 14, 2021 12:43 pm

Does anything change when you remove libwine-development:amd64?

Code: Select all

sudo apt purge libwine-development

hgabor84
Level 2
Level 2
Posts: 41
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 14, 2021 12:52 pm

It seems that was the problem on my second computer! Wine started to work now there. Thanks for your help again! :)

My third computer shows me this now:

Code: Select all

dpkg -l | grep wine
ii  fonts-wine                              4.0-2                               all          Windows API implementation - fonts
ii  libwine:amd64                           4.0-2                               amd64        Windows API implementation - library
ii  wine                                    4.0-2                               all          Windows API implementation - standard suite
ii  wine-staging-amd64                      6.3~buster-1                        amd64        WINE Is Not An Emulator - runs MS Windows programs
ii  wine64                                  4.0-2                               amd64        Windows API implementation - 64-bit binary loader
What should I do now?

jkfloris
Level 9
Level 9
Posts: 1419
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 14, 2021 1:29 pm

Make sure you have enabled the i386 architecture.

Code: Select all

sudo dpkg --add-architecture i386
You can remove fonts-wine, libwine:amd64, wine and wine64

Code: Select all

sudo apt purge fonts-wine libwine wine wine64
(Install the libfaudio0 packages from backports)
And install winehq-staging, wine-staging and wine-staging-i386

Code: Select all

sudo apt install --install-recommends winehq-staging wine-staging wine-staging-i386:i386

hgabor84
Level 2
Level 2
Posts: 41
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 14, 2021 1:33 pm

Code: Select all

sudo apt install --install-recommends winehq-staging wine-staging wine-staging-i386:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-staging-i386:i386 : Depends: libgphoto2-6:i386 (>= 2.5.10) but it is not going to be installed
                          Depends: libgphoto2-port12:i386 (>= 2.5.10) but it is not going to be installed
                          Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is not going to be installed
                          Depends: libudev1:i386 (>= 183) but it is not going to be installed
                          Depends: libusb-1.0-0:i386 (>= 2:1.0.21) but it is not going to be installed
                          Depends: libasound2-plugins:i386 but it is not going to be installed
                          Recommends: libcups2:i386 but it is not going to be installed
                          Recommends: libglu1-mesa:i386 but it is not going to be installed or
                                      libglu1:i386
                          Recommends: libgssapi-krb5-2:i386 but it is not going to be installed
                          Recommends: libgtk-3-0:i386 but it is not going to be installed
                          Recommends: libkrb5-3:i386 but it is not going to be installed
                          Recommends: libsane:i386 but it is not going to be installed or
                                      libsane1:i386
                          Recommends: libtiff5:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

jkfloris
Level 9
Level 9
Posts: 1419
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 14, 2021 1:58 pm

Strange. What version of libc6 is installed?

Code: Select all

dpkg -l | grep libc6
# and
apt policy libc6 libc6:i386

hgabor84
Level 2
Level 2
Posts: 41
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 14, 2021 2:03 pm

Code: Select all

dpkg -l | grep libc6
ii  libc6:amd64                             2.28-10                             amd64        GNU C Library: Shared libraries
ii  libc6:i386                              2.28-10                             i386         GNU C Library: Shared libraries
ii  libc6-dev:amd64                         2.28-10                             amd64        GNU C Library: Development Libraries and Header Files

Code: Select all

apt policy libc6 libc6:i386
libc6:
  Installed: 2.28-10
  Candidate: 2.28-10
  Version table:
 *** 2.28-10 500
        500 http://ftp.hu.debian.org/debian buster/main amd64 Packages
        500 http://ftp.de.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
libc6:i386:
  Installed: 2.28-10
  Candidate: 2.28-10
  Version table:
 *** 2.28-10 500
        500 http://ftp.hu.debian.org/debian buster/main i386 Packages
        500 http://ftp.de.debian.org/debian buster/main i386 Packages
        100 /var/lib/dpkg/status

jkfloris
Level 9
Level 9
Posts: 1419
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 14, 2021 5:00 pm

This is a strange result. libudev1:i386 has only libc6:i386 as a dependency, but it isn't installed. :?
Are there any packages on hold?

Code: Select all

apt-mark showhold
Or are there some custom preferences in /etc/apt/preferences or /etc/apt/preferences.d/?

Code: Select all

apt-cache policy

hgabor84
Level 2
Level 2
Posts: 41
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 14, 2021 5:04 pm

There isn't any packages on hold.

Code: Select all

apt-cache policy
Csomagfájlok:
 100 /var/lib/dpkg/status
     release a=now
 500 https://linux.teamviewer.com/deb stable/main i386 Packages
     release o=TeamViewer GmbH,a=stable,l=TeamViewer,c=main,b=i386
     origin linux.teamviewer.com
 500 https://linux.teamviewer.com/deb stable/main amd64 Packages
     release o=TeamViewer GmbH,a=stable,l=TeamViewer,c=main,b=amd64
     origin linux.teamviewer.com
 500 http://ppa.launchpad.net/ztefn/haguichi-debian/ubuntu bionic/main i386 Packages
     release v=18.04,o=LP-PPA-ztefn-haguichi-debian,a=bionic,n=bionic,l=Haguichi Debian PPA,c=main,b=i386
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/ztefn/haguichi-debian/ubuntu bionic/main amd64 Packages
     release v=18.04,o=LP-PPA-ztefn-haguichi-debian,a=bionic,n=bionic,l=Haguichi Debian PPA,c=main,b=amd64
     origin ppa.launchpad.net
 100 http://deb.debian.org/debian buster-backports/main i386 Packages
     release o=Debian Backports,a=buster-backports,n=buster-backports,l=Debian Backports,c=main,b=i386
     origin deb.debian.org
 100 http://deb.debian.org/debian buster-backports/main amd64 Packages
     release o=Debian Backports,a=buster-backports,n=buster-backports,l=Debian Backports,c=main,b=amd64
     origin deb.debian.org
 500 http://ftp.de.debian.org/debian buster/main i386 Packages
     release v=10.8,o=Debian,a=stable,n=buster,l=Debian,c=main,b=i386
     origin ftp.de.debian.org
 500 http://ftp.de.debian.org/debian buster/main amd64 Packages
     release v=10.8,o=Debian,a=stable,n=buster,l=Debian,c=main,b=amd64
     origin ftp.de.debian.org
 500 https://dl.winehq.org/wine-builds/debian buster/main i386 Packages
     release o=dl.winehq.org,a=stable,n=buster,l=winehq,c=main,b=i386
     origin dl.winehq.org
 500 https://dl.winehq.org/wine-builds/debian buster/main amd64 Packages
     release o=dl.winehq.org,a=stable,n=buster,l=winehq,c=main,b=amd64
     origin dl.winehq.org
 500 http://ftp.hu.debian.org/debian buster-updates/non-free i386 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=non-free,b=i386
     origin ftp.hu.debian.org
 500 http://ftp.hu.debian.org/debian buster-updates/non-free amd64 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=non-free,b=amd64
     origin ftp.hu.debian.org
 500 http://ftp.hu.debian.org/debian buster-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=main,b=i386
     origin ftp.hu.debian.org
 500 http://ftp.hu.debian.org/debian buster-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=main,b=amd64
     origin ftp.hu.debian.org
 500 http://security.debian.org/debian-security buster/updates/non-free i386 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=non-free,b=i386
     origin security.debian.org
 500 http://security.debian.org/debian-security buster/updates/non-free amd64 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=non-free,b=amd64
     origin security.debian.org
 500 http://security.debian.org/debian-security buster/updates/main i386 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=i386
     origin security.debian.org
 500 http://security.debian.org/debian-security buster/updates/main amd64 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://ftp.hu.debian.org/debian buster/non-free i386 Packages
     release v=10.8,o=Debian,a=stable,n=buster,l=Debian,c=non-free,b=i386
     origin ftp.hu.debian.org
 500 http://ftp.hu.debian.org/debian buster/non-free amd64 Packages
     release v=10.8,o=Debian,a=stable,n=buster,l=Debian,c=non-free,b=amd64
     origin ftp.hu.debian.org
 500 http://ftp.hu.debian.org/debian buster/contrib i386 Packages
     release v=10.8,o=Debian,a=stable,n=buster,l=Debian,c=contrib,b=i386
     origin ftp.hu.debian.org
 500 http://ftp.hu.debian.org/debian buster/contrib amd64 Packages
     release v=10.8,o=Debian,a=stable,n=buster,l=Debian,c=contrib,b=amd64
     origin ftp.hu.debian.org
 500 http://ftp.hu.debian.org/debian buster/main i386 Packages
     release v=10.8,o=Debian,a=stable,n=buster,l=Debian,c=main,b=i386
     origin ftp.hu.debian.org
 500 http://ftp.hu.debian.org/debian buster/main amd64 Packages
     release v=10.8,o=Debian,a=stable,n=buster,l=Debian,c=main,b=amd64
     origin ftp.hu.debian.org

jkfloris
Level 9
Level 9
Posts: 1419
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Sun Mar 14, 2021 5:24 pm

Looks good.
All that's left is to manually install each dependency. :(

Code: Select all

sudo apt install libgphoto2-6:i386
sudo apt install libgphoto2-port12:i386
sudo apt install libldap-2.4-2:i386
# etc..
Maybe you will find the broken package.

hgabor84
Level 2
Level 2
Posts: 41
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Sun Mar 14, 2021 7:26 pm

Code: Select all

sudo apt-get install libgphoto2-6:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgphoto2-6:i386 : Depends: libgd3:i386 (>= 2.1.0~alpha~) but it is not going to be installed
                     Depends: libgphoto2-port12:i386 (>= 2.5.10) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Code: Select all

sudo apt-get install libgd3:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgd3:i386 : Depends: libtiff5:i386 (>= 4.0.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Code: Select all

sudo apt-get install libtiff5:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libtiff5:i386 : Depends: libzstd1:i386 (>= 1.3.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Code: Select all

sudo apt-get install libzstd1:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgdk-pixbuf2.0-0 : Depends: libtiff5 (>= 4.0.3) but it is not going to be installed
                      Recommends: libgdk-pixbuf2.0-bin
 libgtk-3-0 : Depends: adwaita-icon-theme but it is not going to be installed
              Recommends: libgtk-3-bin
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Code: Select all

sudo apt-get install libgdk-pixbuf2.0-0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgdk-pixbuf2.0-0 is already the newest version (2.38.1+dfsg-1).
libgdk-pixbuf2.0-0 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Code: Select all

sudo apt-get install libtiff5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libtiff5 is already the newest version (4.1.0+git191117-2~deb10u2).
libtiff5 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Code: Select all

sudo apt-get install libgtk-3-bin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgtk-3-bin is already the newest version (3.24.5-1).
libgtk-3-bin set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Code: Select all

sudo apt-get install adwaita-icon-theme
Reading package lists... Done
Building dependency tree       
Reading state information... Done
adwaita-icon-theme is already the newest version (3.30.1-1).
adwaita-icon-theme set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Thats hard.

jkfloris
Level 9
Level 9
Posts: 1419
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing wine

Post by jkfloris » Mon Mar 15, 2021 8:58 am

Code: Select all

sudo apt-get install libzstd1:i386
...
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgdk-pixbuf2.0-0 : Depends: libtiff5 (>= 4.0.3) but it is not going to be installed
                      Recommends: libgdk-pixbuf2.0-bin
 libgtk-3-0 : Depends: adwaita-icon-theme but it is not going to be installed
              Recommends: libgtk-3-bin
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
No idea what apt is doing here. The only dependency is libc6.

Are the version numbers of the 64 and 32-bit packages the same?

Code: Select all

apt policy libzstd1 libzstd1:i386

hgabor84
Level 2
Level 2
Posts: 41
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Mon Mar 15, 2021 10:08 am

Code: Select all

apt policy libzstd1 libzstd1:i386
libzstd1:
  Installed: 1.4.4+dfsg-3~bpo10+1
  Candidate: 1.4.4+dfsg-3~bpo10+1
  Version table:
 *** 1.4.4+dfsg-3~bpo10+1 100
        100 http://deb.debian.org/debian buster-backports/main amd64 Packages
        100 /var/lib/dpkg/status
     1.3.8+dfsg-3+deb10u2 500
        500 http://security.debian.org/debian-security buster/updates/main amd64 Packages
     1.3.8+dfsg-3 500
        500 http://ftp.hu.debian.org/debian buster/main amd64 Packages
        500 http://ftp.de.debian.org/debian buster/main amd64 Packages
libzstd1:i386:
  Installed: (none)
  Candidate: 1.3.8+dfsg-3+deb10u2
  Version table:
     1.4.4+dfsg-3~bpo10+1 100
        100 http://deb.debian.org/debian buster-backports/main i386 Packages
     1.3.8+dfsg-3+deb10u2 500
        500 http://security.debian.org/debian-security buster/updates/main i386 Packages
     1.3.8+dfsg-3 500
        500 http://ftp.hu.debian.org/debian buster/main i386 Packages
        500 http://ftp.de.debian.org/debian buster/main i386 Packages

spoon0042
Level 6
Level 6
Posts: 502
Joined: Thu Dec 24, 2009 11:00 am

Re: problem with installing wine

Post by spoon0042 » Mon Mar 15, 2021 10:59 am

Yeah, you've got different versions available which confuses apt. The easiest way to fix that would be to tell it to prefer buster-backports:

Code: Select all

apt -t=buster-backports install libzstd1:i386
You may need to repeat this process for other packages.

(It's also possible to downgrade, or to get apt to always prefer buster-backports but I'm trying to avoid confusing you, heh.)

hgabor84
Level 2
Level 2
Posts: 41
Joined: Mon Nov 27, 2017 5:06 pm

Re: problem with installing wine

Post by hgabor84 » Mon Mar 15, 2021 11:32 am

spoon0042 wrote:
Mon Mar 15, 2021 10:59 am
Yeah, you've got different versions available which confuses apt. The easiest way to fix that would be to tell it to prefer buster-backports:

Code: Select all

apt -t=buster-backports install libzstd1:i386
You may need to repeat this process for other packages.

(It's also possible to downgrade, or to get apt to always prefer buster-backports but I'm trying to avoid confusing you, heh.)
You are amazing boys! It was a long way to goal but finally all of my packages were repaired now!

Code: Select all

wine --version
wine-6.0
Image

Thank you very much! :)

Post Reply