Installing PublisherRocket on WINE

Open forum for end-user questions about Wine. Before asking questions, check out the Wiki as a first step.
Forum Rules
Post Reply
Level 1
Level 1
Posts: 6
Joined: Sun Aug 02, 2020 5:55 am

Installing PublisherRocket on WINE

Post by JohnParten » Sun Aug 02, 2020 6:33 am

Has anyone had success with installing "PublisherRocket" on WINE?
I can install OK on Virtual Machine running 32 bit Win7 but not on WINE

OS: Fedora 31
Wine Version: wine-5.13 (Staging)
I have created a new prefix (called TestBottle), installed dot35 and dotnet452 using winetricks
I have set the windows version to windows 7 using winetricks
Copied the installation file to the prefix directory and make executable
My command lines are ...
cd ~/.PlayOnLinux/TestBottle
WINEARCH=win32 WINEPREFIX=~/.PlayOnLinux/TestBottle ~/.PlayOnLinux/TestBottle/PublisherRocketSetup.exe

The installation immediate throws up a dialog box reporting "a serious problem has been encountered and also you may want to check the application database"
The console output is like this ...

06f8:fixme:ieframe:DllGetClassObject {9ba05972-f6a8-11cf-a442-00a0c90a8f39} {00000001-0000-0000-c000-000000000046} 0031DC68
06f8:err:ole:apartment_getclassobject DllGetClassObject returned error 0x80040111 for dll L"C:\\windows\\system32\\ieframe.dll"
06f8:err:ole:create_server class {9ba05972-f6a8-11cf-a442-00a0c90a8f39} not registered
06f8:fixme:ole:CoGetClassObject CLSCTX_REMOTE_SERVER not supported
06f8:err:ole:CoGetClassObject no class object {9ba05972-f6a8-11cf-a442-00a0c90a8f39} could be created for context 0x17
wine: Unhandled page fault on read access to 00000000 at address 00406366 (thread 06f8), starting debugger...
06cc:fixme:x11settings:X11DRV_ChangeDisplaySettingsEx Changing non-primary adapter L"\\\\.\\DISPLAY2" settings is currently unsupported.

I checked to be sure ieframe.dll exists in ~/.PlayOnLinux/TestBottle/drive_c/windows/system32. Not sure how to get round this.

... any help much appreciated
... JohnP

Level 1
Level 1
Posts: 6
Joined: Sun Aug 02, 2020 5:55 am

Re: Installing PublisherRocket on WINE

Post by JohnParten » Mon Aug 03, 2020 10:00 am

Fixed the ieframe.dll problem by installing "ie8" via winetricks
Now I am stuck on "explorer:webbrowser_QueryInterface ... interface not supported"

$ WINEARCH=win32 WINEPREFIX=~/.PlayOnLinux/wineprefix/TestBottle5 ~/.PlayOnLinux/wineprefix/PublisherRocketSetup.exe
002c:fixme:winediag:start_process Wine Staging 5.13 is a testing version containing experimental patches.
002c:fixme:winediag:start_process Please mention your exact version when filing bug reports on
0048:fixme:x11settings:X11DRV_ChangeDisplaySettingsEx Changing non-primary adapter L"\\\\.\\DISPLAY2" settings is currently unsupported.
002c:fixme:ntdll:EtwRegisterTraceGuidsA (6307379F, 630B1CF8, {0cfe0455-93ba-440d-a3fe-553973d0b723}, 1, 0066E934, (null), (null), 630B1D00): stub
002c:fixme:ntdll:EtwRegisterTraceGuidsA (6307379F, 630B1D18, {797fabac-7b58-4796-b924-d51178a59ce4}, 1, 0066E934, (null), (null), 630B1D20): stub
002c:fixme:ntdll:EtwEventRegister ({43d1a55c-76d6-4f7e-995c-64c711e5cafe}, 6309CE28, 00000000, 630B1500) stub.
002c:fixme:ntdll:EtwEventRegister ({9e3b3947-ca5d-4614-91a2-7b624e0e7244}, 63073C41, 630B3258, 630B3180) stub.
002c:fixme:ntdll:EtwEventEnabled (deadbeef, 6302B3C0): stub
002c:fixme:ntdll:EtwEventEnabled (deadbeef, 63020688): stub
002c:fixme:ntdll:EtwEventUnregister (deadbeef) stub.
0048:fixme:explorer:webbrowser_QueryInterface (0041A20C)->({00000003-0000-0000-c000-000000000046} 0069E7EC) interface not supported
0048:fixme:explorer:webbrowser_QueryInterface (0041A20C)->({00000003-0000-0000-c000-000000000046} 0069E754) interface not supported
0048:fixme:explorer:webbrowser_QueryInterface (0041A20C)->({00000019-0000-0000-c000-000000000046} 00B0B700) interface not supported
0024:fixme:ver:GetCurrentPackageId (0031FE34 00000000): stub
$ 00f4:fixme:ver:GetCurrentPackageId (0031FE34 00000000): stub

Level 1
Level 1
Posts: 6
Joined: Sun Aug 02, 2020 5:55 am

Re: Installing PublisherRocket on WINE

Post by JohnParten » Tue Aug 04, 2020 10:30 am

Here I am trying to provide more detail to any potential helper out there ...

So I did this command ...

WINEARCH=win32 WINEPREFIX=~/.PlayOnLinux/wineprefix/TestBottle5 WINEDEBUG=+relay wine ~/.PlayOnLinux/wineprefix/PublisherRocketSetup.exe &>relmsg1.txt

... which resulted in a 62 megabyte trace file called relmsg1.txt
Then I grepped for "interface not supported" and here is a small section of the trace file with these lines.

0048:Call user32.GetDesktopWindow() ret=004070da
0048:Ret user32.GetDesktopWindow() retval=00010020 ret=004070da
0048:Call ole32.CoGetMarshalSizeMax(0069e7fc,00b4d340,0041a20c,00000000,00000000,00000000) ret=6fde0da6
0048:fixme:explorer:webbrowser_QueryInterface Call KERNEL32.GetModuleHandleA(00419af0 "ntdll.dll") ret=004117d5
0048:Call ntdll.RtlInitAnsiString(0069e1f0,00419af0 "ntdll.dll") ret=7b014f8f
0048:Ret ntdll.RtlInitAnsiString() retval=0000000a ret=7b014f8f
0048:Call ntdll.RtlAnsiStringToUnicodeString(7ffd8bf8,0069e1f0,00000000) ret=7b015016
0048:Ret ntdll.RtlAnsiStringToUnicodeString() retval=00000000 ret=7b015016
0048:Call ntdll.RtlInitUnicodeString(0069e208,7ffd8c00 L"ntdll.dll") ret=7b023e89
0048:Ret ntdll.RtlInitUnicodeString() retval=00000014 ret=7b023e89
0048:Call ntdll.LdrGetDllHandle(00000000,00000000,0069e208,0069e200) ret=7b023ead
0048:Ret ntdll.LdrGetDllHandle() retval=00000000 ret=7b023ead
0048:Ret KERNEL32.GetModuleHandleA() retval=7bc00000 ret=004117d5
0048:Call KERNEL32.GetProcAddress(7bc00000,00419b2d "__wine_dbg_output") ret=004117e8
0048:Ret KERNEL32.GetProcAddress() retval=7bc5f840 ret=004117e8
(0041A20C)->({00000003-0000-0000-c000-000000000046} 0069E77C) interface not supported
0048:Call ntdll.RtlAllocateHeap(00110000,00000000,00000010) ret=652370e2
0048:Ret ntdll.RtlAllocateHeap() retval=00b30be8 ret=652370e2
0048:Call KERNEL32.HeapFree(00110000,00000000,00b30be8) ret=652365b1
0048:Ret KERNEL32.HeapFree() retval=00000001 ret=652365b1
0048:Ret ole32.CoGetMarshalSizeMax() retval=00000000 ret=6fde0da6
0048:Call rpcrt4.I_RpcGetBuffer(00b303f0) ret=6524da2a
0048:Call ntdll.RtlAllocateHeap(00110000,00000000,00000058) ret=6fe08ce7
0048:Ret ntdll.RtlAllocateHeap() retval=00b26c78 ret=6fe08ce7
0048:Ret rpcrt4.I_RpcGetBuffer() retval=00000000 ret=6524da2a
0048:Call KERNEL32.HeapFree(00110000,00000000,00000000) ret=6524da79
0048:Ret KERNEL32.HeapFree() retval=00000001 ret=6524da79
0048:Call ntdll.RtlAllocateHeap(00110000,00000000,00000018) ret=6fde059b
0048:Ret ntdll.RtlAllocateHeap() retval=00b30dc0 ret=6fde059b
0048:Call ole32.CoMarshalInterface(00b30dc0,00b4d340,0041a20c,00000000,00000000,00000000) ret=6fde0bb2
0048:fixme:explorer:webbrowser_QueryInterface (0041A20C)->({00000003-0000-0000-c000-000000000046} 0069E6E4) interface not supported
0048:Call ntdll.RtlAllocateHeap(00110000,00000000,00000010) ret=652370e2
0048:Ret ntdll.RtlAllocateHeap() retval=00b310f0 ret=652370e2
0048:Call ntdll.RtlAllocateHeap(00110000,00000008,00000078) ret=6526fdf1
0048:Ret ntdll.RtlAllocateHeap() retval=00b27028 ret=6526fdf1
0048:Call ntdll.RtlInitializeCriticalSection(00b27038) ret=6526fe1a
0048:Ret ntdll.RtlInitializeCriticalSection() retval=00000000 ret=6526fe1a
0048:fixme:explorer:webbrowser_QueryInterface (0041A20C)->({00000019-0000-0000-c000-000000000046} 00B27090) interface not supported
0048:Call KERNEL32.FindActCtxSectionGuid(00000000,00000000,00000005,00b4d340,0069e4bc) ret=652164bf
0048:Call ntdll.RtlFindActivationContextSectionGuid(00000000,00000000,00000005,00b4d340,0069e4bc) ret=7b0272c7
0048:Ret ntdll.RtlFindActivationContextSectionGuid() retval=c0150008 ret=7b0272c7
0048:Call ntdll.RtlNtStatusToDosError(c0150008) ret=7b0272e9
0048:Ret ntdll.RtlNtStatusToDosError() retval=000036b7 ret=7b0272e9

I am not sure I am using winedbg correctly.
Can anyone advise me given this extra info ?

Level 1
Level 1
Posts: 6
Joined: Sun Aug 02, 2020 5:55 am

Re: Installing PublisherRocket on WINE

Post by JohnParten » Tue Aug 11, 2020 6:17 am

Extra Info:
I tried ...
sudo dnf remove wine winetricks and playonlinux
I renamed the old .playonlinux and .wine directories
I reinstalled again ...
sudo dnf install wine winetricks playonlinux
created a new 32 bit prefix and installed dotnet452, ie8, & iertutil
then attempted to install publisher rocket again ~ the result is the same failure
... JohnP

Level 9
Level 9
Posts: 1283
Joined: Thu Aug 14, 2014 10:10 am

Re: Installing PublisherRocket on WINE

Post by jkfloris » Tue Aug 11, 2020 9:59 am

You can install the program with a little workaround:
- Create a clean Wineprefix
- Extract PublisherRocketSetup.exe to {your Wineprefix}/drive_c/PublisherRocketSetup
- Change directory to {your Wineprefix}/drive_c/PublisherRocketSetup
- Install the program with:

Code: Select all

WINEPREFIX={your Wineprefix} wine Update.exe --install=.
I don't have a licence key, so I can't fully test the program.

Level 1
Level 1
Posts: 6
Joined: Sun Aug 02, 2020 5:55 am

Re: Installing PublisherRocket on WINE

Post by JohnParten » Wed Aug 12, 2020 7:13 am

Hi jkfloris,

Thank you for posting on this topic. It sounds like you got it working where as I am still stuck.
I tried to follow the instructions you gave, but I think I am stumbling over the second step...

"- Extract PublisherRocketSetup.exe to {your Wineprefix}/drive_c/PusblisherRocketSetup"
I tried to use ark but it does not recognise the .exe file. I also tried unrar and unzip, but the indications are that this is just an exe file
Did you find a linux program that extracts this file??? If so can you please let me know the details.

As another experiment, I revisited the VM where PublisherRocket is installed, and tried to copy the resulting directory structure from there.
The path was c:\Users\johnp\AppData\Local\KDPRocket ...
... and there were five items, namely ...
app-2.0.51 (FileFolder)
packages (File Folder)
KDPRocket (Application)
SquirrelSetup (TextDocument)
Update (Application)

... since Update.exe was there I was hopeful that your last installation hint might work so I did try ...

WINEPREFIX=/home/johnp/.local/share/wineprefixes/TestBottle8 wine Update.exe --install=.

but this gave me an unhandled exception ... so I thought I would make this posting before trying to go any further.
Hopefully you can spot what I am doing wrong ~ many thanks ~ JohnP

Level 1
Level 1
Posts: 6
Joined: Sun Aug 02, 2020 5:55 am

Installing PublisherRocket on WINE ~ SUCCESS

Post by JohnParten » Wed Aug 12, 2020 8:47 am

Hi jkfloris

Thanks to you I now have SUCCESS ~ wow I did not think it was going to be possible!
For step 2 I did a little more research and learnt that many people have successfully decompressed EXE files with p7zip so I gave that a go. My steps were ...

A) sudo dnf install p7zip
B) 7za x PublisherRocketSetup.exe (this is with the EXE in the wineprefix/drive_c as you suggest)
C) WINEPREFIX=/home/johnp/.local/share/wineprefixes/TestBottle7 wine Update.exe --install=.

It works and takes me through all the installation procedure to finally ask for email address or license number.
I need to get back to publisherrocket .com to sort this out but it all looks good to me.

So many thanks for your help, much appreciated ...


Post Reply