Trouble running Epic Games Launcher

Open forum for end-user questions about Wine. Before asking questions, check out the Wiki as a first step.
Forum Rules
Post Reply
pcapazzi
Newbie
Newbie
Posts: 1
Joined: Wed Jun 17, 2020 9:29 am

Trouble running Epic Games Launcher

Post by pcapazzi » Wed Jun 17, 2020 11:32 am

Hello,
I've been trying to install the Epic Games Launcher. I found this on WineHQ which says it's Gold. There are no instructions though. I tried simply running it as

Code: Select all

wine EpicInstaller.msi
which failed. After Googling I see there is an msiexec function available and tried that which got me much further wine

Code: Select all

msiexec -i EpicInstall.msi
. I think the following happens after installation and during the first run of the application. The screen says it's Installing Prerequisites but in the console I see a continuous loop of this error message:

Code: Select all

00ed:err:setupapi:do_file_copyW Unsupported style(s) 0x144
. I CTRL-C the operation and try running it again I get the same error message. If I run the executable with the parameter

Code: Select all

-SkipBuildPatchPrereq 
it runs but has trouble... the screen is missing components.

jkfloris
Level 8
Level 8
Posts: 1133
Joined: Thu Aug 14, 2014 10:10 am

Re: Trouble running Epic Games Launcher

Post by jkfloris » Thu Jun 18, 2020 3:53 pm

Code: Select all

msiexec -i EpicInstall.msi
Maybe the "-" is a typo, but the command is:

Code: Select all

wine msiexec /i whatever.msi 
# or
wine start whatever.msi

Post Reply