Winlink Express

Open forum for end-user questions about Wine. Before asking questions, check out the Wiki as a first step.
Forum Rules
Post Reply
MythX
Level 2
Level 2
Posts: 14
Joined: Sun Dec 30, 2018 10:31 am

Winlink Express

Post by MythX » Sun Oct 06, 2019 10:42 am

I had this working (mostly) prior to performing a winetricks --self-update. The update was successful, but afterward, Winlink won't load anymore. Here's the messages I get:

Code: Select all

 ~ $ WINEPREFIX=~/winmor wine ~/winmor/drive_c/programs/RMS\ Express/RMS\ Express.exe 
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
0009:err:module:fixup_imports_ilonly mscoree.dll not found, IL-only binary L"RMS Express.exe" cannot be loaded
0009:err:module:LdrInitializeThunk Importing dlls for L"C:\\programs\\RMS Express\\RMS Express.exe" failed, status c0000135

Is this something I can fix?
Wine - 4.3
Ubuntu - bionic

Thanks in advance for any help.

jkfloris
Level 6
Level 6
Posts: 682
Joined: Thu Aug 14, 2014 10:10 am

Re: Winlink Express

Post by jkfloris » Sun Oct 06, 2019 11:26 am

"winetricks --self-update" does not modify your Wine prefixes or Wine installation. What else did you changed?

MythX
Level 2
Level 2
Posts: 14
Joined: Sun Dec 30, 2018 10:31 am

Re: Winlink Express

Post by MythX » Sun Oct 06, 2019 12:27 pm

Thanks for the response.

That was the only thing I changed, I was attempting to install .NET 2.0, but it failed. I assumed nothing had changed. I just installed it using the --force command. Now I'm back where I was prior, with a totally different problem (my original problem) and Winlink working partially once again.

Thanks for the help. I'll post again if I can't figure out my original problem.

jkfloris
Level 6
Level 6
Posts: 682
Joined: Thu Aug 14, 2014 10:10 am

Re: Winlink Express

Post by jkfloris » Mon Oct 07, 2019 3:42 am

Backup and remove your winmor Wine prefix and try again in a clean 32-bit prefix.

Post Reply