Deleted prefix, Mono installation persists

Open forum for end-user questions about Wine. Before asking questions, check out the Wiki as a first step.
Forum Rules
Locked
mzo
Level 2
Level 2
Posts: 30
Joined: Fri Mar 08, 2019 5:15 pm
Location: Los Angeles, California

Deleted prefix, Mono installation persists

Post by mzo » Mon May 06, 2019 5:06 pm

Hi,

I'm unable to remove Mono. I deleted .wine several times but when I run wineboot or winecfg to create it again, Mono is already found in there automatically. I tried to run winetricks dotnet472 but it fails at the first stage (installing .NET 4.0) as it detects a previous installation in the prefix. Also, dotnet verbs are supposed to remove Mono but the removal does not work.

I also tried to run

Code: Select all

wine64 uninstaller --remove '{E45D8920-A758-4088-B6C6-31DBB276992E}'
and

Code: Select all

wine uninstaller --remove '{E45D8920-A758-4088-B6C6-31DBB276992E}'
but it returns:

Code: Select all

uninstaller: The application with GUID '{E45D8920-A758-4088-B6C6-31DBB276992E}' was not found
When I make a new prefix or delete .wine and restart I no longer get the dialog window that asks if I want to install Mono and Gecko because they look already installed. Also, uninstalling Wine this way:

Code: Select all

sudo apt remove wine-devel
and then reinstalling it, does not fix the problem. Any help would be much appreciated. Below my terminal output when I boot wine after deleting the .wine folder.Thank you

Code: Select all

winecfg
wine: created the configuration directory '/home/mzo/.wine'
0012:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0012:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0012:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0012:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0012:err:ole:get_local_server_stream Failed: 80004002
0014:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0014:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0014:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0014:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0014:err:ole:get_local_server_stream Failed: 80004002
0017:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
0017:err:mscoree:LoadLibraryShim error reading registry key for installroot
0017:err:mscoree:LoadLibraryShim error reading registry key for installroot
0017:err:mscoree:LoadLibraryShim error reading registry key for installroot
0017:err:mscoree:LoadLibraryShim error reading registry key for installroot
0019:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
0019:err:mscoree:LoadLibraryShim error reading registry key for installroot
0019:err:mscoree:LoadLibraryShim error reading registry key for installroot
0019:err:mscoree:LoadLibraryShim error reading registry key for installroot
0019:err:mscoree:LoadLibraryShim error reading registry key for installroot
0019:err:msi:execute_command unable to execute command 2
0019:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 5)
0019:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 5)
0017:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0017:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
001d:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
001d:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
001d:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0010:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0010:fixme:dwmapi:DwmIsCompositionEnabled 0x6dbd1518
001f:fixme:iphlpapi:NotifyIpInterfaceChange (family 0, callback 0x69ebd3de, context 0x8465c0, init_notify 0, handle 0x113fa10): stub
0048:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
0042:fixme:ntoskrnl:ObDereferenceObject failed to release 0x1a550
0048:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0048:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0046:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0046:fixme:dwmapi:DwmIsCompositionEnabled 0x6d5d3018
004a:fixme:iphlpapi:NotifyIpInterfaceChange (family 0, callback 0x6a0cb608, context 0x8c88c8, init_notify 0, handle 0x110fc88): stub
wine: configuration in '/home/mzo/.wine' has been updated.

User avatar
dimesio
Moderator
Moderator
Posts: 12697
Joined: Tue Mar 25, 2008 10:30 pm

Re: Deleted prefix, Mono installation persists

Post by dimesio » Tue May 07, 2019 6:03 am

Wine's downloader for wine-mono and wine-gecko store the .msi files in ~/.cache/wine; that's what's being used to install them to the wineprefixes. You can delete them manually, but you will then be prompted for the download whenever you create a new wineprefix.

mzo
Level 2
Level 2
Posts: 30
Joined: Fri Mar 08, 2019 5:15 pm
Location: Los Angeles, California

Re: Deleted prefix, Mono installation persists

Post by mzo » Tue May 07, 2019 3:29 pm

That solved the problem for me. Thank you!

Locked