Cannot install Call of Duty 4 Modern Warefare patch v1.6

Open forum for end-user questions about Wine. Before asking questions, check out the Wiki as a first step.
Forum Rules
Locked
Vigneshd332
Level 2
Level 2
Posts: 12
Joined: Wed Mar 27, 2019 12:09 am

Cannot install Call of Duty 4 Modern Warefare patch v1.6

Post by Vigneshd332 » Fri Apr 05, 2019 8:43 am

Hello, I am unable to install COD4 Modern Warfare V1.6 Patch. I get an error message stating, " Error -1627 Function Failed". Please help. Thanks in Advance.


System Specs:
OS: Ubuntu 16.04.6 LTS
WINE: v1.6.2
CPU: Intel Core 2 Duo E4600 @ 2.4 GHz
GPU: Intel 950 GMA (128 MB)
Mother Board: Intel 945NGCL
Attachments
Error 1627.png
Error Message.

User avatar
Bob Wya
Level 12
Level 12
Posts: 2759
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: Cannot install Call of Duty 4 Modern Warefare patch v1.6

Post by Bob Wya » Fri Apr 05, 2019 4:35 pm

Vigneshd332 wrote:...
System Specs:
...
WINE: v1.6.2
...
@Vigneshd332

That version of Wine is years out of date, and no longer supported.

Please update to Wine (or Wine Staging 4.5), and retest COD4.
See: WineHQ Wiki: Ubuntu: Installing WineHQ packages.

Bob

Vigneshd332
Level 2
Level 2
Posts: 12
Joined: Wed Mar 27, 2019 12:09 am

Re: Cannot install Call of Duty 4 Modern Warefare patch v1.6

Post by Vigneshd332 » Fri Apr 05, 2019 9:43 pm

Actually I solved the problem. I updated to wine 4.1 staging (tkg) and still had the same error. Then I figured out that installing Microsoft Visual C++ 2005 redistributable x86 and Microsoft Visual C++ 2008 Redistributable x86 solved the problem. TO any one experiencing this particular error, please uninstall the program giving the error and install the two packages given above and reinstall your program. Thank you. WINE 4EVER!!!!

Locked