Struggling to get Gecko working - error reading registry key

Open forum for end-user questions about Wine. Before asking questions, check out the Wiki as a first step.
Forum Rules
Locked
Falken322
Newbie
Newbie
Posts: 1
Joined: Tue Jan 22, 2019 5:56 pm

Struggling to get Gecko working - error reading registry key

Post by Falken322 » Tue Jan 22, 2019 6:16 pm

For the life of me, I cannot get Gecko working. I'm using Ubuntu 18.04, and running winecfg for the first time results in this:

Code: Select all

joshua@WOPR:~$ winecfg
wine: created the configuration directory '/home/joshua/.wine'
0012:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0012:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0012:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0012:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0012:err:ole:get_local_server_stream Failed: 80004002
0014:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0014:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0014:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0014:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0014:err:ole:get_local_server_stream Failed: 80004002
0019:err:mscoree:LoadLibraryShim error reading registry key for installroot
0019:err:mscoree:LoadLibraryShim error reading registry key for installroot
0019:err:mscoree:LoadLibraryShim error reading registry key for installroot
0019:err:mscoree:LoadLibraryShim error reading registry key for installroot
Could not load wine-gecko. HTML rendering will be disabled.
wine: configuration in '/home/joshua/.wine' has been updated.
</pre>
.
Following WineHQ's directions for installing manually result in the following:

Code: Select all

joshua@WOPR:~$ wine msiexec /i wine_gecko-2.47-x86_64.msi 
0009:err:mscoree:LoadLibraryShim error reading registry key for installroot
0009:err:mscoree:LoadLibraryShim error reading registry key for installroot
0009:err:mscoree:LoadLibraryShim error reading registry key for installroot
0009:err:mscoree:LoadLibraryShim error reading registry key for installroot
I have also placed the msi file in /usr/share/wine/gecko, and have tried installing winbind using the ubuntu package manager which comes with wine-gecko. All to no avail. I believe the issue has something to do with the error message repeated from msiexec, but google has yielded nothing useful for that error message so far.

User avatar
dimesio
Moderator
Moderator
Posts: 12657
Joined: Tue Mar 25, 2008 10:30 pm

Re: Struggling to get Gecko working - error reading registry

Post by dimesio » Wed Jan 23, 2019 8:16 am

Falken322 wrote:

Code: Select all

joshua@WOPR:~$ wine msiexec /i wine_gecko-2.47-x86_64.msi 
0009:err:mscoree:LoadLibraryShim error reading registry key for installroot
Those messages are harmless and have nothing to do with wine-gecko (mscoree is part of wine-mono). From what you've posted, 64 bit wine-gecko was installed successfully. What makes you think it wasn't?

FYI, you also have to install 32 bit wine-gecko.

Locked